0

Overview

I have two Arista 7050SX switches. They don't support stacking. But I essentially will be using them as a stacked pair none the less (just means managing two individual switches).

They're currently connected together via a port channel of two qsfp links. No lacp. Trunk port, native vlan 10

Switch 2 is connected to a router via a /30 on et1 (routable port). Routing is enabled. Default route set. Vlan10 has an IP on a /26 (.2) and is reachable from elsewhere on the network (routing is working and my static route is up). Running config:

rj-sw02#show run
! Command: show running-config
! device: rj-sw02 (DCS-7050SX-64, EOS-4.19.3F)
!
! boot system flash:/EOS-4.19.3F.swi
!
transceiver qsfp default-mode 4x10G
!
hostname rj-sw02
!
spanning-tree mode mstp
!
no aaa root
!
clock timezone US/Eastern
!
vlan 10
   name phys-mgt
!
interface Port-Channel10
   description Switch Interconnect
   switchport trunk native vlan 10
   switchport trunk allowed vlan 1,10
   switchport mode trunk
!
interface Ethernet1
   no switchport
   ip address 172.16.64.2/30
!
interface Ethernet2
!
interface Ethernet3
!

...

interface Ethernet46
!
interface Ethernet47
!
interface Ethernet48
!
interface Ethernet49/1
   description Switches Interconnect
   channel-group 10 mode active
!
interface Ethernet49/2
   description Switches Interconnect
   channel-group 10 mode active
!
interface Ethernet49/3
   description Switches Interconnect
   channel-group 10 mode active
!
interface Ethernet49/4
   description Switches Interconnect
   channel-group 10 mode active
!
interface Ethernet50/1
!
interface Ethernet50/2
!
interface Ethernet50/3
!
interface Ethernet50/4
!
interface Ethernet51/1
   description Switches Interconnect
   channel-group 10 mode active
!
interface Ethernet51/2
   description Switches Interconnect
   channel-group 10 mode active
!
interface Ethernet51/3
   description Switches Interconnect
   channel-group 10 mode active
!
interface Ethernet51/4
   description Switches Interconnect
   channel-group 10 mode active
!
interface Ethernet52/1
!
interface Ethernet52/2
!
interface Ethernet52/3
!
interface Ethernet52/4
!
interface Management1
   ip address 192.168.1.1/24
!
interface Vlan10
   ip address 10.3.104.3/26
!
ip route 0.0.0.0/0 172.16.64.1
!
ip routing
!

Switch 1 has no direct connection to the router. Vlan10 has an IP on the same /26 as above, and is .3. Routing is also enabled. Default gw is the next hop in the /30 (and would need to traverse the interconnect). I cannot ping (not reachable) from elsewhere on my network. The switches can ping one another and I can ssh from sw2 to sw1* Running config:

rj-sw01#show run
! Command: show running-config
! device: rj-sw01 (DCS-7050SX-64, EOS-4.19.3F)
!
! boot system flash:/EOS-4.19.3F.swi
!
transceiver qsfp default-mode 4x10G
!
hostname rj-sw01
!
spanning-tree mode mstp
!
no aaa root
!
vlan 10
   name phys_mgt
!
interface Port-Channel10
   description Switch Interconnect
   switchport trunk native vlan 10
   switchport trunk allowed vlan 1,10
   switchport mode trunk
!
interface Ethernet1
!
interface Ethernet2
!

...

interface Ethernet47
!
interface Ethernet48
!
interface Ethernet49/1
   description Switches Interconnect
   channel-group 10 mode active
!
interface Ethernet49/2
   description Switches Interconnect
   channel-group 10 mode active
!
interface Ethernet49/3
   description Switches Interconnect
   channel-group 10 mode active
!
interface Ethernet49/4
   description Switches Interconnect
   channel-group 10 mode active
!
interface Ethernet50/1
!
interface Ethernet50/2
!
interface Ethernet50/3
!
interface Ethernet50/4
!
interface Ethernet51/1
   description Switches Interconnect
   channel-group 10 mode active
!
interface Ethernet51/2
   description Switches Interconnect
   channel-group 10 mode active
!
interface Ethernet51/3
   description Switches Interconnect
   channel-group 10 mode active
!
interface Ethernet51/4
   description Switches Interconnect
   channel-group 10 mode active
!
interface Ethernet52/1
!
interface Ethernet52/2
!
interface Ethernet52/3
!
interface Ethernet52/4
!
interface Management1
   ip address 192.168.1.1/24
!
interface Vlan10
   ip address 10.3.104.2/26
!
ip route 0.0.0.0/0 Port-Channel10 172.16.64.1
!
ip routing
!

Goal

I've run out of ports on one switch, hence the addition of the second. I have a bunch of hosts that need to communicate with one another, between switches. In theory, the PG I've created will accomplish that (presuming all my VLANs are part of that trunk) (please tell me if otherwise). I also need SSH access to both switches, which is where I've gotten stuck here.

Question 1: What am I doing wrong, given the above info & configs - why can't I reach the second switch?

Question 2: Is this the the best way to go about this, or should I be working with a different configuration strategy to get to where I want to be (a stacked pair, essentially)?

* I've noticed that when I reboot sw2, which isn't connected to the router directly, while it's down, I'm unable to connect to sw1

8
  • Please edit your question to include things like a good network description or diagram, the network device models, and the network device configurations. Speculation and guessing are off-topic here, and we need enough information to see where you may have gone wrong. You can refer to the Network Engineering Question Checklist for guidance, then edit your question.
    – Ron Maupin
    Aug 15, 2019 at 14:01
  • Erm.. minus the diagram and config dumps, which I didn't think we needed here since this is a relatively simple setup and is explained, I think I have everything covered already, no?
    – geudrik
    Aug 15, 2019 at 14:08
  • No. If something is not working, then you really need to give us enough information to see what may be configured incorrectly. As it stands, we can only guess, and that is off-topic here. We have seen things like someone who swore everything was configured correctly, but when he finally gave us the configurations, we saw a simple typo where two digits were reversed, and he still didn't see it when pointed out. We had to spell it in words before he could see it.
    – Ron Maupin
    Aug 15, 2019 at 14:12
  • Roger that, I'll dump the configs when I get in.
    – geudrik
    Aug 15, 2019 at 14:15
  • Configs added above!
    – geudrik
    Aug 15, 2019 at 15:56

2 Answers 2

1

You have a problem on Switch 1. Your default route is to an address that the switch doesn't know how to reach. The default route should be ip route 0.0.0.0/0 10.3.104.3. Switch 2 knows how to reach 172.16.64.1 because it is on a directly connected network, but Switch 1 doesn't know how to reach that network, so the next hop is Switch 2, not the router.

0

The.best way to connect two switches with one uplink by port -channel or ether -channel . Binding two cables into single instance and connect each cable to each switches interfàce and configure it for uplink interfàce .. i

You can reach secondary switch by management ip address . Create management Vlan and configure management VLAN in both primary and secondary switch . And try to access both switches by management ip address allocated to switches.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.