2

I believe I am missing something obvious. I am using GNS3 to lab out having two paths to a CORE network. See picture. The configuration works as I imagined, I can ping from each Switch every other Switch within VLAN212. I can also ping the loopbacks of the CORE switch from the other switches in the VLAN212 domain. Spanning tree has put SW-C f/15 in block mode which is good since this group of switches is a Layer 2 loop. The issue is, if I remove any of the links in the loop, the topology cannot recover. I thought Spanning Tree would only take 30 seconds to recalculate, but something else is preventing each switch to ping each other...Even in the localized VLAN 212. What I mean is if I remove the link from SW-A --> SW-C. I can no longer ping from SW-C any of the switches or even the CORE switch.

Perhaps I am going about this the wrong way. If there is a better way to get a secondary path to a group of non-stackable switches let me know. I am trying to get away from the fact that these non-stackable switches are daisy chained, with only 1 switch having a path to the core.

Any, I appreciate your help. Thank you!

Picture.enter image description here

Spanning Tree output SW-C with link intact:

SW-C#show spanning-tree brief

VLAN212
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     c801.2308.0001
             Cost        19
             Port        55 (FastEthernet1/14)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32768
             Address     c802.2308.0000
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface                                   Designated
Name                 Port ID Prio Cost  Sts Cost  Bridge ID            Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet1/14     128.55   128    19 FWD     0 32768 c801.2308.0001 128.56
FastEthernet1/15     128.56   128    19 FWD    19 32768 c802.2308.0000 128.56

SW-C#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/45/84 ms

REmove link from SW-A to SW-C

SW-C#show spanning-tree bri

VLAN212
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     c801.2308.0001
             Cost        19
             Port        55 (FastEthernet1/14)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32768
             Address     c802.2308.0000
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface                                   Designated
Name                 Port ID Prio Cost  Sts Cost  Bridge ID            Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet1/14     128.55   128    19 FWD     0 32768 c801.2308.0001 128.56
FastEthernet1/15     128.56   128    19 FWD    19 32768 c802.2308.0000 128.56

SW-C#
*Mar  1 00:09:52.311: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.0.0.11 (Vla                                                                             n212) is down: holding time expired
SW-C#
*Mar  1 00:09:55.903: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.0.0.2 (Vlan                                                                             212) is down: holding time expired
SW-C#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

ADDING SW RUNNING_CONFIGS

CORE

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CORE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 15
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
ip tcp synwait-time 5
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 2.2.2.2 255.255.255.0
!
interface Loopback2
 ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
 switchport access vlan 295
!
interface FastEthernet1/2
 switchport access vlan 296
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
interface Vlan295
 ip address 172.16.0.1 255.255.255.0
 ip summary-address eigrp 1 0.0.0.0 0.0.0.0
!
interface Vlan296
 ip address 172.16.1.1 255.255.255.0
 ip summary-address eigrp 1 0.0.0.0 0.0.0.0
!
router eigrp 1
 network 172.16.0.0 0.0.0.255
 network 172.16.1.0 0.0.0.255
 no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

SW-A

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW-A
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 15
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
 switchport access vlan 295
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
 switchport access vlan 212
!
interface FastEthernet1/15
 switchport access vlan 212
!
interface Vlan1
 no ip address
!
interface Vlan212
 ip address 10.0.0.1 255.255.255.0
!
interface Vlan295
 ip address 172.16.0.2 255.255.255.0
!
router eigrp 1
 network 0.0.0.0
 no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

SW-B

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW-B
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 15
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
 switchport access vlan 296
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
 switchport access vlan 212
!
interface FastEthernet1/15
 switchport access vlan 212
!
interface Vlan1
 no ip address
!
interface Vlan212
 ip address 10.0.0.2 255.255.255.0
!
interface Vlan296
 ip address 172.16.1.2 255.255.255.0
!
router eigrp 1
 network 0.0.0.0
 no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
mac-address-table static c809.094c.0000 interface FastEthernet1/14 vlan 1
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

SW-C

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW-C
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 15
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
 switchport access vlan 212
!
interface FastEthernet1/15
 switchport access vlan 212
!
interface Vlan1
 no ip address
!
interface Vlan212
 ip address 10.0.0.10 255.255.255.0
!
router eigrp 1
 network 0.0.0.0
 no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
mac-address-table static c80a.094c.0000 interface FastEthernet1/15 vlan 212
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

SW-D

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW-D
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 15
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
ip tcp synwait-time 5
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
 switchport access vlan 212
!
interface FastEthernet1/15
 switchport access vlan 212
!
interface Vlan1
 no ip address
!
interface Vlan212
 ip address 10.0.0.11 255.255.255.0
!
router eigrp 1
 network 0.0.0.0
 no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

HERE IS AN EXAMPLE OF REMOVE THE LINK BETWEEN SW C and B, and then readding the link.

SW-C#ping 1.1.1.1 repeat 100000

Type escape sequence to abort.
Sending 100000, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!........
*Mar  1 00:32:23.183: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.0.0.2 (Vlan212) is down: holding time expired................!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
*Mar  1 00:32:55.739: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.0.0.2 (Vlan212) is up: new adjacency!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!..........................................
.........................................................

For some reason it never recovers....

  • What is the output on Sw C of show spanning-tree vlan 212? – Ron Trunk Jan 30 '14 at 20:23
  • What does that output look like with the link disabled? – Dave in Ohio Jan 30 '14 at 21:17
  • @Jim the new show command is different than before. fa 1/15 is no longer blocking. So what did you do differently this time? – Ron Trunk Jan 30 '14 at 21:29
  • @Jim Notice that in the second listing (with link removed) you still hear BPDUs from port 1/14. So that means the link isn't actually removed. How, exactly, are you removing the link? – Ron Trunk Jan 30 '14 at 21:36
  • How is your EIGRP configured on these switches? Notice that in your second output you appear to lose EIGRP neighbors. – Dave in Ohio Jan 30 '14 at 22:13
3

The first thing that jumps out at me is you say you removed the link from A to C, but fa 1/14 is still in the forwarding state. That means the port is still up.

The second thing I notice is that the root port is also 1/14, which means it's up and hearing BPDUs from sw A. So I would guess you didn't really remove the link from A to C, but blocked traffic in some other way.

  • You want me to remove the link and give you the spanning tree summary? – Jim Jan 30 '14 at 21:19
  • @jim Your new edits are different that earlier show command. What is different? – Ron Trunk Jan 30 '14 at 21:30
  • I re added the link in order to take the two screenshots of before and after. – Jim Jan 31 '14 at 14:31
  • It seems like only if I reboot all the routers in the layer 2 domain, it will start pinging again... – Jim Jan 31 '14 at 15:54
  • @jim, can you join me in the general network engineering chat room? – Ron Trunk Jan 31 '14 at 16:05
2

This is an issue with GNS3. If you try to right-click and remove the link, GNS3 still reports to each switch that the link is still there. Use "shutdown" command to turn off the interfaces involved in the link.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.