2

I am trying to link up a few PCs through PT, with a mix of VLAN and physical connections. I have managed to ping 2 different PCs, but i cannot ping the switch, the router or any of the sub routes.

Here is the IP address details

192.168.50.15
255.255.255.0
192.168.10.1

Here is the setup for the ports on Switch B

Using 2764 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport access vlan 50
switchport trunk allowed vlan 1-99
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 50
switchport mode access

(This is the same up to Fa0/12)

interface FastEthernet0/13
switchport access vlan 80
switchport mode access

(this is the same for all the ports until 24)

interface GigabitEthernet0/1
switchport trunk allowed vlan 1-99
switchport mode trunk
!
interface GigabitEthernet0/2
switchport access vlan 32
switchport trunk allowed vlan 1-99
switchport mode trunk
!
interface Vlan1
ip address 192.168.70.1 255.255.255.0
!
interface Vlan50
mac-address 0002.4a18.6202
ip address 192.168.50.1 255.255.255.0
!
interface Vlan99
mac-address 0002.4a18.6203
ip address 192.168.99.2 255.255.255.0
!
ip default-gateway 192.168.10.1
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

Here is the setup for the ports on Switch A

Building configuration...

Current configuration : 2762 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport access vlan 50
switchport trunk allowed vlan 1-99
switchport mode trunk
!   
interface FastEthernet0/2
switchport access vlan 50
switchport mode access

(This is the same up to fa0/12)

interface FastEthernet0/13
switchport access vlan 80
switchport mode access

(This is the same for all the ports until 24)

interface GigabitEthernet0/1
switchport trunk allowed vlan 1-99
switchport mode trunk
!
interface GigabitEthernet0/2
switchport access vlan 32
switchport trunk allowed vlan 1-99
switchport mode trunk
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
!
!
interface Vlan50
mac-address 0001.64db.c002
ip address 192.168.50.1 255.255.255.0
!
interface Vlan99
mac-address 0001.64db.c003
ip address 192.168.99.1 255.255.255.0
!
ip default-gateway 192.168.10.1
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
!
end

Here is the details for the router

Current configuration : 1289 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
ip dhcp pool SERVICEPOOL
network 192.168.50.0 255.255.255.0
default-router 192.168.10.1
ip dhcp pool STUDENTPOOL
dns-server 8.8.8.8
domain-name STUDENTPOOL
ip dhcp pool ADMINPOOL
network 192.168.80.0 255.255.255.0
default-router 192.168.10.1
dns-server 8.8.8.8
!    
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2901/K9 sn FTX1524S0XS
!
!
!
!
!
spanning-tree mode pvst
!
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1.5
no ip address
!
interface GigabitEthernet0/1.50
encapsulation dot1Q 50
ip address 192.168.50.1 255.255.255.0
!
interface GigabitEthernet0/1.80
encapsulation dot1Q 80
ip address 192.168.89.254 255.255.255.0
!
interface Serial0/0/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

Here is the network diagram

Network Diagram

I did manage to find a solution to part of the original question, but im stumped with the rest of it.

Thanks in advance

  • You have not provided enough information to even begin to help. Please edit your question to include a network diagram, the network device models, and the network device configurations. If it is a layer-2 switch, then you cannot put IP addresses on the switch interfaces. – Ron Maupin Aug 23 '19 at 12:59
  • Please include the diagram and full network device configurations. – Ron Maupin Aug 23 '19 at 13:19
  • Network diagram and all connections are now included – Harry Betts Aug 24 '19 at 0:13
  • Please include the full network device configurations. You are missing some configurations that we need to see. – Ron Maupin Aug 24 '19 at 0:13
  • Is that showing the running configuration? – Harry Betts Aug 24 '19 at 0:34
1

If PC config is like I think it is so: 192.168.50.15 <- pc ip address 255.255.255.0 <- mask 192.168.10.1 <- default gateway

Then ofc its wrong because your gateway is in different subnet. Default gateway should be in the same subnet as computer so in this case gateway could be on 192.168.50.1. Now you should be able ping router about switch:

if your switch is Layer 2 device (not L3) and managment vlan have different addressing than your pc then switch should have ip default-gateway set, also L2 switch ip address you setting on vlan interface because you can't set ip address on normal physical interface on L2 switch.

| improve this answer | |
0

You have some serious configuration problems.

It looks like you have some addressing problems.

Switch:

interface Vlan1
 ip address 192.168.1.1 255.255.255.0 <- ##### Does not match network of router interface GigabitEthernet0/1 #####
!
interface Vlan50
 mac-address 0001.64db.c002
 ip address 192.168.50.1 255.255.255.0 <- ##### Duplicate of router interface GigabitEthernet0/1.50 #####
!
interface Vlan99
 mac-address 0001.64db.c003
 ip address 192.168.99.1 255.255.255.0 <- ##### Does not exist on router, so isolated and cannot reach any other network #####
!
ip default-gateway 192.168.10.1 <- ##### the switch does not know how to reach this network #####
!

Router:

interface GigabitEthernet0/1
ip address 192.168.10.1 255.255.255.0 
duplex auto
speed auto
!
interface GigabitEthernet0/1.5 <- ##### Useless and should be removed #####
no ip address
!
interface GigabitEthernet0/1.50
encapsulation dot1Q 50
ip address 192.168.50.1 255.255.255.0 <- ##### Duplicate of switch interface Vlan50 #####
!
interface GigabitEthernet0/1.80
encapsulation dot1Q 80
ip address 192.168.89.254 255.255.255.0<- ##### Does not match the DHCP pool network #####
!

If you are using layer-2 switches, you only need a single SVI (for switch management). Remove all the SVIs except for VLAN 1. Probably something like:

SwitchA:

interface Vlan1
 ip address 192.168.10.2 255.255.255.0
!

SwitchB:

interface Vlan1
 ip address 192.168.10.3 255.255.255.0
!

You also want to create the VLANs on the switches with the global vlan command, and you can optionally name them. You do not need to do this with VLAN 1, just any other VLANs you want to use. Based on what the router has defined, it will look something like this:

vlan 50
 name <VLAN name> ! This line is optional, and VLAN names cannot contain spaces
 exit
!
vlan80
 name <VLAN name, no spaces> ! This line is optional, and VLAN names cannot contain spaces
 exit
!

Also, your DHCP pools have some problems:

ip dhcp pool SERVICEPOOL
network 192.168.50.0 255.255.255.0
default-router 192.168.10.1 <- ##### The default gateway for a network must be an address on the network, in this case the router VLAN 50 address of 192.168.50.1 #####
ip dhcp pool STUDENTPOOL
dns-server 8.8.8.8
domain-name STUDENTPOOL
ip dhcp pool ADMINPOOL
network 192.168.80.0 255.255.255.0 <- ##### Does not match the router network for VLAN 80 of 192.168.89.0 #####
default-router 192.168.10.1 <- ##### The default gateway for a network must be an address on the network, in this case the router VLAN 80 address of 192.168.89.254 #####
dns-server 8.8.8.8
!    
| improve this answer | |
  • Just asking some followup questions for clarification, if I wanted the SVI to be VLAN 99 and ping-able from a PC on VLAN 50, is there anything I have to do differently for this? Also is there something additional I need to do to ping from a PC to a sub-interface on the router? Thanks – Harry Betts Aug 25 '19 at 5:34
  • If you do what I have outlined, the PCs will get proper addressing and gateways, and they should be able to ping the router interfaces. If you want VLAN 99, then you need to create it on the router, too. The only SVIs you need are for the management of the switch. Do not over complicate the switch configuration. – Ron Maupin Aug 25 '19 at 5:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.