1

My experimental setup

With reference to the above diagram: Is 10.124.124.141 supposed to be able to ping 10.124.124.161 if the setup is correct ? There is no router in-between, the idea is that the VLAN 215 spans two switches trunked together to make a single 48-port switch if you wish. I am however not getting this to work (the ping fails from either side). The configuration for port 16 on switch 2 is:

interface GigabitEthernet1/0/16
switchport trunk allowed vlan 10,20,215
switchport mode trunk
!       

The configuration for port 11 on switch 1 is:

interface GigabitEthernet1/0/11
switchport trunk allowed vlan 10,20,215
switchport mode trunk
spanning-tree portfast
! 

The configuration for port 21 on both switch 1 and 2 is:

interface GigabitEthernet1/0/21
switchport mode trunk
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
macro description cisco-switch
auto qos trust
spanning-tree link-type point-to-point
!

and port 23 is configured the same as port 21.

7
  • Why are you running trunk ports towards your hosts? Normally one would use an access port.
    – user56700
    Aug 28 '19 at 12:14
  • @user56700 - multiple VLANs per adapter
    – Waslap
    Aug 28 '19 at 12:17
  • So, it's something like ESXi or other type of system that supports tagging on the NIC directly?
    – Jesse P.
    Aug 28 '19 at 12:22
  • @JesseP. no, both hosts Linux, the VLANs are for easier QoS differentiation between broad classes of access to them
    – Waslap
    Aug 28 '19 at 12:30
  • But how are you tagging the traffic on the hosts so it knows which VLAN to use? In trunk mode, with no native VLAN defined on the switch ports, you need to do the tagging on the hosts to tell it to use VLAN 215.
    – Jesse P.
    Aug 28 '19 at 12:33
2

I have to apologise with my hat in my hand. I have swopped around two network cables on the back-plane of the server. In my defense, there are 4 cables marked with roman numerals and my eyes aren't that good so the II and III got swopped around.

3
  • Please accept your answer so this doesn't keep coming up as unsolved.
    – Jesse P.
    Aug 28 '19 at 13:22
  • It says I can only accept in 2 days
    – Waslap
    Aug 28 '19 at 13:38
  • Oh. Okay. I guess mark it in 2 days. :)
    – Jesse P.
    Aug 28 '19 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.