1

enter image description here

1) In Router 4(R4)

i have configured the 2 dhcp pool. first dhcp pool with ip address 150.10.10.0/24 and second one with 150.20.10.1/24 in subinterfaces f0/0.1 and f0/0.2 and encapsulated using (R4(config)#encapsulation dot1q 10) in two differnet vlans 10 and 20

2) In Switch 1:

i have trunk the e0 and e3

3) in switch 2:

i have created 2 vlans (vlan 10 and 20) i have keep int e0 and e1 in vlan 10 and e2 is keep in vlan 20 and e3 is trunk

so my question is:

1> how can i get R3 and R2 ip address from my first dhcp server

2> how can i get R1 ip address from my second dhcp server

but i am not receving the ip address to any of the client

R4 configuration:

upgrade fpd auto
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
!
ip dhcp excluded-address 150.10.10.1
ip dhcp excluded-address 150.20.10.1
!
ip dhcp pool SERVER1
 network 150.10.10.0 255.255.255.0
 default-router 150.10.10.1 
!         
ip dhcp pool SERVER2
 network 150.20.10.0 255.255.255.0
 default-router 150.20.10.1 
!         
!         
!         
no ip domain lookup
ip cef    
no ipv6 cef
!         
multilink bundle-name authenticated
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
redundancy
!         
!         
ip tcp synwait-time 5
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
interface FastEthernet0/0
 no ip address
 duplex half
!         
interface FastEthernet0/0.1
 encapsulation dot1Q 10
 ip address 150.10.10.1 255.255.255.0
!         
interface FastEthernet0/0.2
 encapsulation dot1Q 20
 ip address 150.20.10.1 255.255.255.0
!         
interface FastEthernet1/0
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
interface FastEthernet1/1
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
interface FastEthernet2/0
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
interface FastEthernet2/1
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
interface FastEthernet3/0
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
interface FastEthernet3/1
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
interface FastEthernet4/0
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
interface FastEthernet4/1
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
ip forward-protocol nd
no ip http server
no ip http secure-server
!         
!         
!         
no cdp log mismatch duplex
!         
!         
!         
control-plane
!         
!         
!         
mgcp profile default
!         
!         
!         
gatekeeper
 shutdown 
!         
!         
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login    
 transport input all
!         
!         
end

SWITCH 1 configuration:

  Using 1952 out of 262144 bytes, uncompressed size = 5025 bytes
!
! Last configuration change at 13:55:41 UTC Tue Sep 3 2019
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname ESW1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
vtp domain CISCO-vIOS
vtp mode transparent
!         
!         
!         
ip cef    
no ipv6 cef
!         
!         
spanning-tree mode pvst
spanning-tree extend system-id
!         
vlan internal allocation policy ascending
!         
vlan 10  
 name VLAN100
!         
vlan 10,20
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
interface Ethernet0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 media-type rj45
 negotiation auto
!         
interface Ethernet0/1
 media-type rj45
 negotiation auto
!         
interface Ethernet0/2
 media-type rj45
 negotiation auto
!         
interface Ethernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 media-type rj45
 negotiation auto
!         
ip forward-protocol nd
!         
no ip http server
no ip http secure-server
!         
!         
!         
!         
!         
!         
control-plane
!         
banner exec ^C
**************************************************************************
* IOSv - Cisco Systems Confidential                                      *
*                                                                        *
* This software is provided as is without warranty for internal          *
* development and testing purposes only under the terms of the Cisco     *
* Early Field Trial agreement.  Under no circumstances may this software *
* be used for production purposes or deployed in a production            *
* environment.                                                           *
*                                                                        *
* By using the software, you agree to abide by the terms and conditions  *
* of the Cisco Early Field Trial Agreement as well as the terms and      *
* conditions of the Cisco End User License Agreement at                  *
* http://www.cisco.com/go/eula                                           *
*                                                                        *
* Unauthorized use or distribution of this software is expressly         *
* Prohibited.                                                            *
**************************************************************************^C
banner incoming ^C
**************************************************************************
* IOSv - Cisco Systems Confidential                                      *
*                                                                        *
* This software is provided as is without warranty for internal          *
* development and testing purposes only under the terms of the Cisco     *
* Early Field Trial agreement.  Under no circumstances may this software *
* be used for production purposes or deployed in a production            *
* environment.                                                           *
*                                                                        *
* By using the software, you agree to abide by the terms and conditions  *
* of the Cisco Early Field Trial Agreement as well as the terms and      *
* conditions of the Cisco End User License Agreement at                  *
* http://www.cisco.com/go/eula                                           *
*                                                                        *
* Unauthorized use or distribution of this software is expressly         *
* Prohibited.                                                            *
**************************************************************************^C
banner login ^C
**************************************************************************
* IOSv - Cisco Systems Confidential                                      *
*                                                                        *
* This software is provided as is without warranty for internal          *
* development and testing purposes only under the terms of the Cisco     *
* Early Field Trial agreement.  Under no circumstances may this software *
* be used for production purposes or deployed in a production            *
* environment.                                                           *
*                                                                        *
* By using the software, you agree to abide by the terms and conditions  *
* of the Cisco Early Field Trial Agreement as well as the terms and      *
* conditions of the Cisco End User License Agreement at                  *
* http://www.cisco.com/go/eula                                           *
*                                                                        *
* Unauthorized use or distribution of this software is expressly         *
* Prohibited.                                                            *
**************************************************************************^C
!         
line con 0
 logging synchronous
line aux 0
line vty 0 4
 logging synchronous
 login    
line vty 5 15
 logging synchronous
 login    
!         
!         
end 

SWITCH 2 configuration:

Using 1956 out of 262144 bytes, uncompressed size = 5048 bytes
!
! Last configuration change at 14:20:30 UTC Tue Sep 3 2019
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname ESW2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
vtp domain CISCO-vIOS
vtp mode transparent
!         
!         
!         
ip cef    
no ipv6 cef
!         
!         
spanning-tree mode pvst
spanning-tree extend system-id
!         
vlan internal allocation policy ascending
!         
vlan 10  
 name VLAN10
!         
vlan 10,20 
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
interface Ethernet0/0
 switchport access vlan 10
 media-type rj45
 negotiation auto
!         
interface Ethernet0/1
 switchport access vlan 10
 media-type rj45
 negotiation auto
!         
interface Ethernet0/2
 switchport access vlan 20
 media-type rj45
 negotiation auto
!         
interface Ethernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 media-type rj45
 negotiation auto
!         
ip forward-protocol nd
!         
no ip http server
no ip http secure-server
!         
!         
!         
!         
!         
!         
control-plane
!         
banner exec ^C
**************************************************************************
* IOSv - Cisco Systems Confidential                                      *
*                                                                        *
* This software is provided as is without warranty for internal          *
* development and testing purposes only under the terms of the Cisco     *
* Early Field Trial agreement.  Under no circumstances may this software *
* be used for production purposes or deployed in a production            *
* environment.                                                           *
*                                                                        *
* By using the software, you agree to abide by the terms and conditions  *
* of the Cisco Early Field Trial Agreement as well as the terms and      *
* conditions of the Cisco End User License Agreement at                  *
* http://www.cisco.com/go/eula                                           *
*                                                                        *
* Unauthorized use or distribution of this software is expressly         *
* Prohibited.                                                            *
**************************************************************************^C
banner incoming ^C
**************************************************************************
* IOSv - Cisco Systems Confidential                                      *
*                                                                        *
* This software is provided as is without warranty for internal          *
* development and testing purposes only under the terms of the Cisco     *
* Early Field Trial agreement.  Under no circumstances may this software *
* be used for production purposes or deployed in a production            *
* environment.                                                           *
*                                                                        *
* By using the software, you agree to abide by the terms and conditions  *
* of the Cisco Early Field Trial Agreement as well as the terms and      *
* conditions of the Cisco End User License Agreement at                  *
* http://www.cisco.com/go/eula                                           *
*                                                                        *
* Unauthorized use or distribution of this software is expressly         *
* Prohibited.                                                            *
**************************************************************************^C
banner login ^C
**************************************************************************
* IOSv - Cisco Systems Confidential                                      *
*                                                                        *
* This software is provided as is without warranty for internal          *
* development and testing purposes only under the terms of the Cisco     *
* Early Field Trial agreement.  Under no circumstances may this software *
* be used for production purposes or deployed in a production            *
* environment.                                                           *
*                                                                        *
* By using the software, you agree to abide by the terms and conditions  *
* of the Cisco Early Field Trial Agreement as well as the terms and      *
* conditions of the Cisco End User License Agreement at                  *
* http://www.cisco.com/go/eula                                           *
*                                                                        *
* Unauthorized use or distribution of this software is expressly         *
* Prohibited.                                                            *
**************************************************************************^C
!         
line con 0
 logging synchronous
line aux 0
line vty 0 4
 logging synchronous
 login    
line vty 5 15
 logging synchronous
 login    
!         
!         
end
  • Did you create the VLANs oh the switches with the global vlan <vlan number> command (not the interface vlan<vlan number> command)? – Ron Maupin Sep 3 '19 at 14:51
  • 1
    150.10.10.0/24 is not a valid host address. – Ron Trunk Sep 3 '19 at 14:51
  • yes i have created the vlan using (vlan <vlan-id>) – Brijesh Sundi Sep 3 '19 at 14:54
  • i have provided the range fo ip address that can be alloted between 150.10.10.0 - 254 – Brijesh Sundi Sep 3 '19 at 14:55
  • You need to edit your question to include the full network device configurations. Speculation and guessing are off-topic here, and we can only guess where you went wrong unless you give us all the configurations. – Ron Maupin Sep 3 '19 at 15:11
2

On switch 2, the client ports are on VLAN 100 and 200 (not 10 and 20).

EDITED to include Marc Luethi's comment:

On ESW2, the switchports where R1, R2, R3 are connected are without spanning-tree portfast. That will leave these switchports in LIS/LRN spanning tree state for at least 30 seconds after they get 'line protocol up'. That might be long enough to let any DHCP client time out and give up

| improve this answer | |
  • i have changed the vlans still not receving the ip address – Brijesh Sundi Sep 4 '19 at 5:20
  • 2
    ... and on ESW2, the switchports where R1, R2, R3 are connected are without spanning-tree portfast. That will leave these switchports in LIS/LRN spanning tree state for at least 30 seconds after they get 'line protocol up'. That might be long enough to let any DHCP client time out and give up. – Marc 'netztier' Luethi Sep 5 '19 at 5:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.