5

I am playing around with pfsense and have an issue with it connecting properly to the internet.

It has the 1 WAN port by default but I also want to run 2 other networks 192.168.3.0 and 192.168.4.0 on 2 seperate network nics. (server has 3 total).

Does my default WAN port need to connect to a WAN port? I assume routers in order to connect to each other requires a WAN to WAN connection?

What I was to achieve is this: enter image description here

What I want to do is have all 3 networks connected to each other.

  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 7 '17 at 21:50
4

Does my default WAN port need to connect to a WAN port?

No, you don’t need to. WAN, in this sense, is just blocking inbound requests by default. I’ll assume the reason you’re using pfSense is to perform routing functions between those 2 networks (?). If you aren’t using it for any real firewall functions, then you would be alright to, technically, just use multiple LAN interfaces.

I assume routers in order to connect to each other requires a WAN to WAN connection?

I’m not entirely sure what you mean. If you are talking about needing to connect pfSense to your ISP connection, then no.

Remember one persons WAN is anthers LAN. In this sense, your Cisco Firewall’s WAN is the ISP, and it’s LAN is everything behind it. Your pfSense’s WAN is the Cisco Firewall, and it’s LAN is all networks residing behind it.

| improve this answer | |
3

on pfsense put a static global route:

192.168.2.0/24 -->>192.168.2.254

on the cisco router/firewall put 2 statis routes :

iproute 192.168.4.0 255.255.255.0 xxxx(wan interface of the pfsense box , ip from 192.168.2.xx subnet) iproute 192.168.3.0 255.255.255.0 xxxx(wan interface of the pfsense box , ip from 192.168.2.xx subnet)

make sure to uncheck the "block private networks" on the wan interface of the pfsense box , also you should disable nat on pfsense.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.