3

I used 5506 as firewall and I am trying to delete object network I created and it gives error as ERROR: unable to delete the object configuration. object (inside-net-obj) is being used.

commands I used are:

ciscoasa(config)#interface GigabitEthernet 1/3
ciscoasa(config-if)#nameif inside1
INFO: Security level for "inside1" set to 0 by default.
ciscoasa(config-if)#security-level 100
ciscoasa(config-if)#no shutdown
ciscoasa(config-if)#exit
ciscoasa(config)#interface GigabitEthernet 1/4
ciscoasa(config-if)#nameif outside1
INFO: Security level for "outside1" set to 0 by default.
ciscoasa(config-if)#ip address 172.16.20.1 255.255.255.0
ciscoasa(config-if)#no shutdown
ciscoasa(config-if)#exit
ciscoasa(config)#interface GigabitEthernet 1/3
ciscoasa(config-if)#ip address 192.168.10.1 255.255.255.0
ciscoasa(config-if)#exit
ciscoasa(config)#object network inside-net-obj
ciscoasa(config-network-object)#host 192.168.10.100
ciscoasa(config-network-object)#access-list out2in extended permit ip any object inside-net-obj
ciscoasa(config)#access-group out2in in interface outside1
ciscoasa(config)#no access-group out2in in interface outside1
ciscoasa(config)#no access-list out2in extended permit ip any object inside-net-obj
ciscoasa(config)#no object network inside-net-obj
ERROR: unable to delete object (inside-net-obj). object is being used.
ciscoasa(config)#show run | include inside-net-obj

object network inside-net-obj

Any help is appreciated.

1
  • 1
    Run show run | include inside-net-obj and paste the output in your question please.
    – Nakrule
    Sep 19, 2019 at 10:38

1 Answer 1

6

It's giving you that/those error(s) because removing that object would leave the access-list empty but still existing, which is not possible or allowed, and you can't delete an access-list like that (by just saying "no" on its only line).

What you need to do is: clear config access-list out2in

This will disassociate the access-list with the interface and delete it, freeing up the object it's referencing.

Then you can delete the object itself by issuing: no object network inside-net-obj

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.