0

I'm trying to set up a VLAN for my staging environment, but I'm having trouble.

Here's my network layout:

+--------------------+
| [1]  [2]  [3]  [4] |  Ubiquiti USG-PRO-4
+--|----|----|-------+
   |    |    +-------------> Internet
+--|----|-------+
| [2]  [3]  [8] |       Cisco SG200-08 #1
+------------|--+
             |
   +---------+
   |
+--|---------+
| [12]  [24] |          Cisco SG200-26
+---------|--+
          |
+---------|--+
| [8]    [1] |          Cisco SG200-08 #2
+--|---------+
   |
+--|--------------------------+
| [EXT1] [INT3] [INT4] [INT5] |   BNT Layer 2/3 Copper Gbit Ethernet Switch
+---------|------|------|-----+   Module for IBM Blade Center
        +---+  +---+  +---+
        | 1 |  | 2 |  | 3 |       Blades
        +---+  +---+  +---+

The USG has two networks defined and routes between these. Network two has VLANID 4000 assigned.

USG Config:

USG-PRO-4 Config

The #1 SG200-08 has following config:

Cisco SG200-08 #1 Config

The SG200-26:

Cisco SG200-26 Config

The #2 SG200-08:

Cisco SG200-08 #2 Config

And finally the BNT Layer2/3 Switch:

BNT Layer 2/3 Switch Config

I think the problem is with the BNT switch. I already tried to connect EXT2 from the BNT to g2 from the SG200-08#2 and assigning the ports to the VLAN. But then the BNT sets stp: BLOCKING on EXT1 because of the double link.

Thanks for hints!

[EDIT 1]: I canno't communicate beetween two blades on the same VLAN on the BNT.

[EDIT 2]: Added EXT1 on the BNT to the VLAN and enabled tagging. Now the Problem seems to be the USG. I can connect to VLAN via a PC on SG200-26 and I have connection to the VLAN Blades.

[EDIT 3]: Removed VLAN from USG and changed config of SG200-08#1:

SG200-08#1 new config

1

You're tagging VLAN 4000 on SG200-08#2/g8 but you're not tagging on BNT/EXT1 - that can't work. Either you tag on both sides in the same way or you don't tag.

You need to enable tagging and allow VLAN 4000 on EXT1.

An easy way to find out whether a switch VLAN is connected is to check the VLAN's MAC table - if a host's MAC from another switch is in the table the VLAN is connected. If the table stays empty the VLAN's not going anywhere.

2
  • Thanks. That worked. I can now connect from any PC on the net to the VLAN blades. But I can't connect to the USG. There must be some problem there or on the SG200-08#1. Sep 20 '19 at 6:54
  • OK. Found that problem to. Thanks a lot. Sep 20 '19 at 6:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.