0

I have two GigE cameras. I use 4 frame per second for capturing. Each frame of first camera is 2.3MB. Each frame of second camera is 1.8MB. So in a second I use 4 * 4.1 = 16.4 MB = 131 Mb of bandwidth. When I connect each of camera to a computer they work correctly while jumbo frame is enabled. When I use a cisco switch (SG110D-8) between my cameras and computer, cameras say that maximum packet frame is 1440. What is the problem? I read data sheet of the switch. It supports jumbo frame. I note that because of processing time, it is recommended that to use jumbo frame (9K).

7
  • 1
    Did you configure the switch to use jumbo frames?
    – Ron Maupin
    Oct 9, 2019 at 17:57
  • No! how can I do it? my switch is unmanaged.
    – Babak.Abad
    Oct 9, 2019 at 18:00
  • You can't for an unmanaged switch. Jumbo frames are non-standard, and each vendor does them differently, sometimes even with the same switch line or even the same switch. Not all switches can be configured for the same size jumbo frames.
    – Ron Maupin
    Oct 9, 2019 at 18:02
  • On page 5 of this link << media.dustin.eu/media/172104/sg110d-08hp.pdf >> you can see that it supports jumbo frames.
    – Babak.Abad
    Oct 9, 2019 at 18:06
  • Is that transfer done as UDP or as TCP? If TCP: What is the TCP MSS being advertised by either TCP speaker to the respective other? Capture and look at the first two data packets of a TCP session (the SYN and SYN ACK packets). Compare in both cases - with switch and without. Be sure that the DHCP service (if it's there) for the given network segment/subnet does not manipulate MTU in an unexpected way (DHCP option 26). Oct 9, 2019 at 20:29

1 Answer 1

1

According to the data sheet the 110 series supports a fixed jumbo size of 9216 bytes.

However, jumbo frames are non-standard and there's no real guarantee that they work. Possibly the camera is simply failing to detect the switch's size. If you can't force the size on the cam or if you do and it doesn't work there's little you can do short of trying another switch.

As a solution to your problem, connect the computer with a dedicated NIC for each camera and you're good. Alternatively, get a 10G switch and a NIC for the computer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.