0

I have used network policy server on my Windows Server 2012 r2 to manage my accounts on router 1941 but after I used auto secure to harden my router, all my accounts cannot log in anymore, any suggestion to fix the problem?

1
  • Hello! Seems like during auto secure configuration you didn't set up SSH settings. Do you have console access to device? Can you please update your post with sanitized router configuration? Just as a quick solution, you can try get into CLI via console and in configuration mode allow ssh access to vty (provided in answer) Dec 5 '19 at 11:01
0

Boot it in password recovery mode and go back to a good known configuration,

A tip when working with auth is to never save the config until you know it works then you can simply power cycle it to recover and if doing it remotely schedule a reboot that you cancel when it works that way you always have a fix available

4
  • is it possible to disable the auto secure? I manage to log in the router using serial line
    – zyzy
    Dec 5 '19 at 8:00
  • Sure just remove the commands you dont want using no <command_here> Dec 5 '19 at 8:56
  • tried, invalid input for no auto secure
    – zyzy
    Dec 5 '19 at 10:17
  • at the end, I power cycle to go back previous run start to solve the problem
    – zyzy
    Dec 5 '19 at 11:00
0

Connect to your router via console and in configuration mode enable ssh access to vty:

line vty 0 4
 transport input ssh
1
  • You may also need to generate a crypto key: “crypto key gen rsa mod 2048” for ssh to function Dec 5 '19 at 16:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.