I'm trying to upgrade the code on a fresh, out of the box Cisco ASA 5510. However, whenever I transfer the code via TFTP I get the following message -

Writing file disk0:asa847-k8.bin...

%Error writing disk0:asa847-k8.bin (I/O error)

When I run the dir command -

Directory of disk0:/

4      drwx  4096        00:03:28 Jan 01 2003  .private
104    -rwx  15390720    06:13:14 Apr 29 2013  asa825-k8.bin
105    -rwx  16280544    08:07:02 Apr 29 2013  asdm-645.bin
106    -rwx  28672       00:00:00 Jan 01 1980  FSCK0000.REC
3      drwx  4096        00:02:54 Jan 01 2003  log
10     drwx  4096        00:03:06 Jan 01 2003  crypto_archive
11     drwx  4096        00:03:10 Jan 01 2003  coredumpinfo
107    drwx  4096        08:07:12 Apr 29 2013  boot
108    -rwx  4096        00:00:00 Jan 01 1980  FSCK0001.REC
109    -rwx  12998641    08:03:26 Apr 29 2013  csd_3.5.2008-k9.pkg
2      drwx  4096        08:04:16 Apr 29 2013  csco_config
110    drwx  4096        08:03:28 Apr 29 2013  sdesktop
111    -rwx  6487517     08:04:04 Apr 29 2013  anyconnect-macosx-i386-2.5.2014-k9.pkg
112    -rwx  6689498     08:04:12 Apr 29 2013  anyconnect-linux-2.5.2014-k9.pkg
113    -rwx  4678691     08:04:16 Apr 29 2013  anyconnect-win-2.5.2014-k9.pkg
115    -rwx  6326        10:02:44 Feb 20 2014  oldconfig_2014Feb20_1725.cfg

No space information available

The No space information available is kind of concerning. Is it possible the disk is bad? Anyone experience this issue before? Any tips or troubleshooting steps to get around this?

  • It's possible that your disk is full. What is in the log, boot and coredumpinfo directories?
    – Ron Trunk
    Feb 20, 2014 at 18:28
  • After checking, those directories are empty with the exception of a small grub file. To rule out a full disk I deleted the anyconnect packages which should have freed up about 56mb. The transfer still fails due to an I/O error.
    – staticz
    Feb 20, 2014 at 18:37
  • 2
    @staticz The Cisco Support Forums recommend you try 2 things for these types of errors. 1) run fsck disk0: to run a file system check. 2) format disk0: to just wipe it out completely. I would give the 2nd a go just to start from scratch.
    – Ryan Foley
    Feb 20, 2014 at 19:00
  • @Fizzle Thanks for the link. I tried running fsck disk0" and get this message %Error checking disk0: (I/O error) The ASA complains of having no space when I try to write mem (like @Ron suggested) however I know there is space available as I've deleted all of the Any Connect pkg's. I will try to format disk0: and report back. Thank you for all of your suggestions!
    – staticz
    Feb 20, 2014 at 19:23
  • @Fizzle The format disk0: worked! I'm able to upload new code and write memory again. Thank you for your help!
    – staticz
    Feb 20, 2014 at 20:04

2 Answers 2


As mentioned in the comments; The Cisco Support Forums suggest there might be something corrupt with disk0. Since this is a new setup, (optionally) backup the contents, and reformat:

ASA(config)#format disk0:
Format operation may take a while. Continue? [confirm] y 

Then upload your new image (e.g. TFTP):

ASA(config)#copy tftp disk0:
  • Note: TFTP is one of many ways to copy contents to/from the system. Remove the (external) CF is an option. [the internal one is little harder to remove.]
    – Ricky
    Feb 20, 2014 at 21:41

Either the CF card is damaged or the filesystem is corrupt. Note, the 5510 has two CF cards; one external, and one internal. The internal one is where the platform license information is stored, so if you erase it, make sure you have your activation key. (the asa will not show you those files, btw)

They're both FAT formatted, so any windows (or DOS) machine should be able to read them. I'd suggest pulling them to make a backup before attempting to erase them.

Finally, some CF cards have a little switch to write-protect them. Check that it isn't in the WP mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.