0

I am having a problem with announcing a route from one BGP neighbor to the other This is my /etc/quagga/bgpd.conf

router bgp 208xxx
 bgp router-id 78.x.x.x
 neighbor 2001:19f0:ffff::1 remote-as 645xx
 neighbor 2001:19f0:ffff::1 ebgp-multihop 2
 neighbor 2a06:e881:670e:3::2 remote-as 207xxx
!
 address-family ipv6
 neighbor 2001:19f0:ffff::1 activate
 neighbor 2a06:e881:670e:3::2 activate
 network 2a06:e881:6700::/44
 network 2a0f:85c0:910::/44
 neighbor 2001:19f0:ffff::1 prefix-list no-input-v6 in
 neighbor 2001:19f0:ffff::1 prefix-list v-ipv6 out
 neighbor 2a06:e881:670e:3::2 prefix-list no-output out
 neighbor 2a06:e881:670e:3::2 prefix-list announce-c1in in
 exit-address-family
!
ipv6 prefix-list no-input-v6 seq 11 deny ::/0
ipv6 prefix-list v-ipv6 seq 10 permit 2a06:e881:6700::/44
ipv6 prefix-list v-ipv6 seq 11 permit 2a0f:85c0:910::/44
ipv6 prefix-list v-ipv6 seq 12 permit 2a0f:85c0:920::/48
ipv6 prefix-list no-output seq 10 deny ::/0
ipv6 prefix-list announce-c1in seq 10 permit 2a0f:85c0:x::/48

The neighbor 2a06:e881:670e:3::2 announces 2a0f:85c0:920::/48 to me using his AS. However, I want the route to be forwarded to 2001:19f0:ffff::1.

When I run sh ipv6 bgp neighbors 2001:19f0:ffff::1 advertised-routes I get this:

BGP table version is 0, local router ID is 78.141.208.19
Status codes: s suppressed, d damped, h history, * valid, > best, = multipath,
              i internal, r RIB-failure, S Stale, R Removed
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2a06:e881:6700::/44
                    2001:19f0:5001:65f:5400:2ff:fe3c:7741
                                             0          32768 i
*> 2a0f:85c0:910::/44
                    2001:19f0:5001:65f:5400:2ff:fe3c:7741
                                             0          32768 i

When I run sh ipv6 bgp 2a0f:85c0:920::/48 I get this:

BGP routing table entry for 2a0f:85c0:920::/48
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Advertised to non peer-group peers:
  2001:19f0:ffff::1
  207xxx
    2a06:e881:670e:3::2 from 2a06:e881:670e:3::2 (192.168.1.144)
    (fe80::xxxx:xxxx:xxxx:xxxx)
      Origin IGP, localpref 100, valid, external, best
      Last update: Wed Dec 18 14:41:18 2019

Did I do something wrong with filtering? Or did I make a mistake somewhere else? I've been looking at it for hours, but have no idea what the mistake is.

Update: As requested by a comment, here is snippet from the routing table:

Destination                    Next Hop                   Flag Met Ref Use If
::1/128                        ::                         U    256 1     0 lo
2a0f:85c0:910::/44             fe80::e11:8eff:fe12:1401   UG   20  1     0 ens4
fe80::/64                      ::                         U    256 1     0 ens4

The 2a0f route above is learned from BGP.

  • 1
    is this route getting installed in the host routing table? – Ron Trunk Dec 18 '19 at 16:32
  • @RonTrunk yes. If I look at route -6n the route for that subnet is there. Though its destination is a fe80:: address. Would that cause an issue? – mg20023 Dec 18 '19 at 16:39
  • 1
    Yes. If the route is not in the local routing table, it won't be advertised to peers. the most likely cause is your peer is unreachable. – Ron Trunk Dec 18 '19 at 20:34
  • 1
    Are both peers showing a link local address? – Ron Trunk Dec 19 '19 at 0:58
  • 1
    It might be better to include your routing table in your question to make this line of questioning simpler. – Ron Trunk Dec 19 '19 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.