0

I have a C9300-24P switch removed from stack which was configured as slave, after restarting it stops after checking hardware and indicating the switch number as one. The switch ends with

Switch:

Enable command and other commands to perform configuration is not being accepted as the status doesn't change to Switch# or Switch(Config)# mode.

Can someone help me in getting into exec mode and perform configuration on the switch.

Thank you,

the switch dir Bootflash details are as below:

switch: dir bootflash:

Size       Attributes Name
 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
2097152      -rw-     nvram_config
2097152      -rw-     nvram_config_bkup
25711560     -rw-     cat9k-cc_srdriver.16.08.01a.SPA.pkg
78484420     -rw-     cat9k-espbase.16.08.01a.SPA.pkg
1598408      -rw-     cat9k-guestshell.16.08.01a.SPA.pkg
404104132    -rw-     cat9k-rpbase.16.08.01a.SPA.pkg
27681732     -rw-     cat9k-sipbase.16.08.01a.SPA.pkg
52220868     -rw-     cat9k-sipspa.16.08.01a.SPA.pkg
31130564     -rw-     cat9k-srdriver.16.08.01a.SPA.pkg
14783424     -rw-     cat9k-webui.16.08.01a.SPA.pkg
9152         -rw-     cat9k-wlc.16.08.01a.SPA.pkg
6701         -rw-     packages.conf
31663077     -rw-     cat9k-rpboot.16.08.01a.SPA.pkg
4096         drw-     .installer
1110         -rw-     bootloader_evt_handle.log
4096         drw-     core
4096         drw-     .prst_sync
4096         drw-     .rollback_timer
4096         drw-     gs_script
4096         drw-     tech_support
4096         drw-     dc_profile_dir
252          -rw-     boothelper.log
118711       -rw-     memleak.tcl
2340         -rw-     tam_client_app.log
4096         drw-     .dbpersist
0            -rw-     NVRAM
4096         drw-     onep
34           -rw-     pnp-tech-time
55441        -rw-     pnp-tech-discovery-summary
736          -rw-     vlan.dat
556          -rw-     stby-vlan.dat

switch: set
ABNORMAL_RESET_COUNT=0
AUTOREBOOT_RESTORE=1
BAUD=9600
BOARDID=24663
BOOT=flash:packages.conf
BSI=0
LICENSE_BOOT_LEVEL=network-essentials+dna-essentials,all:C9300_24P;
MAC_ADDR=00:D6:FE:1F:85:80
MANUAL_BOOT=yes
MODEL_NUM=C9300-24P
MODEL_REVISION_NUM=A0
MOTHERBOARD_ASSEMBLY_NUM=73-18271-03
MOTHERBOARD_REVISION_NUM=A0
MOTHERBOARD_SERIAL_NUM=FOC22304VDS
RANDOM_NUM=1949930521
RET_2_RCALTS=1535122348
RET_2_RTS=
ROMMON_AUTOBOOT_ATTEMPT=3
STACK_1_1=2_0
SWITCH_NUMBER=1
SWITCH_PRIORITY=3
SYSTEM_SERIAL_NUM=FCW2231E0GY
TEMPLATE=access
VERSION_ID=V02
ip=146.26.72.250
switch_ignore_startup_cfg=1

Tried with suggested commands and switch status is still the same.

1
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can post and accept your own answer.
    – Ron Maupin
    Dec 17 '20 at 0:10
3

It looks like you have the required packages in place (assuming the contents of your packages.conf file reflect these packages).

The settings that look problematic to me after a quick look are the below:

MANUAL_BOOT=yes
switch_ignore_startup_cfg=1

I don't think I will have time to test these on a 9300 before my holiday break, but try entering the following commands:

set MANUAL_BOOT no
set switch_ignore_startup_cfg

Then power cycle the switch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.