5

I have the following config on a brocade icx with the premium license for L3 features:

stack unit 1
  module 1 icx6450-24p-poe-port-management-module
  module 2 icx6450-sfp-plus-4port-40g-module
!
global-stp
!
!
!
vlan 10 by port
 untagged ethe 1/1/1 to 1/1/24 ethe 1/2/1 
 router-interface ve 10
 spanning-tree 802-1w
!
vlan 50 name DEFAULT-VLAN by port
!
!
!
!
!
!                                                                 
!
!
optical-monitor 1
boot sys fl sec
enable telnet password .....
enable super-user-password .....
ip dhcp-server enable
!
ip dhcp-server pool noc
 dhcp-default-router 10.10.10.1 
 dns-server 208.67.222.222 
 domain-name noc.com
 excluded-address 10.10.10.1 10.10.10.10
 lease 1 0 0
 network 10.10.10.0 255.255.255.0
 deploy
!
ip route 0.0.0.0 0.0.0.0 x.x.x.137
!
fdp run

!
!
interface ethernet 1/2/1
 port-name To_9/11
 speed-duplex 1000-full-master
!
interface ve 10
 ip address x.x.x.140 255.255.255.248

I have a PC plugged into a random port 17 but it's not able to get a lease from this switch.

The logs show this when the PC tries to renew its ip:

    0d03h52m09s:A:DHCPS: unable to find an address pool for rx port 10, dropping DHCPOFFER message
0d03h52m09s:A:DHCPS: Exhausts all allocation methods, no address pool found from received port 10 
0d03h51m53s:A:DHCPS: unable to find an address pool for rx port 10, dropping DHCPOFFER message
0d03h51m53s:A:DHCPS: Exhausts all allocation methods, no address pool found from received port 10

Anyone know how I can get this to work properly and so that once the PC's get a lease, they will be able to browse the internet, etc?

Thanks

UPDATE

I made the following changes and now the PC is able to get a lease.

added a new vlan and put port 17 into it along with creating a new ve instance

 vlan 20 by port
     untagged ethe 1/1/17 
     router-interface ve 20
    spanning-tree 802-1w


interface ve 20
 ip address 10.10.10.1 255.255.255.0

Now I got this:

0d04h19m04s:I:DHCPS: sending ACK message to client 10.10.10.11    
0d04h19m04s:I:DHCPS: verified client requested address 10.10.10.11 in lease binding, updating entry
0d04h19m04s:I:DHCPS: No ARP-PING reply from client 10.10.10.11

Bindings from all pools:
    IP Address    Client-ID/        Lease expiration Type
                  Hardware address

   10.10.10.11    0013.72d1.c847   000d:23h:49m:43s   Automatic

Now just need to make sure I can browse the internet from the PC tomorrow and I'm all good!

Even though I figured it out on my own...hope this helps someone and thanks everyone :)

  • Do you have enough public IP addresses for your clients to pull from or are you restricted to private IP addresses? – Ryan Foley Feb 21 '14 at 9:18
5
interface ve 10
 ip address x.x.x.140 255.255.255.248

ip dhcp-server pool noc
 network 10.10.10.0 255.255.255.0

It doesn't work because ve 10 (the L3 interface) isn't within the noc dhcp pool (10.10.10.0/24) Your updated ve 20 is, but unless you have something upstream of here doing NAT, there won't be any internet access.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.