3

I recently installed an Adtran Netvanta 4430 to perform some basic VLANs on a network with a little bit of inter-VLAN routing, and I'm having a few odd issues, probably attributed to my inexperience on routers. The setup is that on interface 0/1 I have the uplink to an ONT, and on interface 0/2 it is connected to a switch. I must be missing something in the config side of things, as here is what I can do...

  • Make a trunk port as well as access ports for VLANs
  • Get IPs, DNS servers, name servers, domains, from router on ports with the correctly set VLAN
  • Ping 8.8.8.8 and google.com from the router

However, I cannot...

  • Ping from the computer connected to switch externally, internally works fine.
  • Look up DNS for name resolution
  • Ping from the switch (Adtran Netvanta 1534)

So what could this be? I have this config and I have tried messing with IP routing (default-gateway as well as something else I forgot) to no avail. I have also messed with access control lists and when I try to apply them, I get an error that says Error: you must first assign an IPv4 address which may be related. The switch is a very basic setup (for each port, switchport access vlan (blah) and a single switchport mode trunk) but the router is where it gets a little confusing in my opinion, as it's my first I've ever set up I've done lots of reading and research and I hate asking for help that basically looks like "I don't understand it, fix my config for me" (which I am trying not to do)... but I'm at a big loss now and any help is appreciated greatly!

Building configuration...
!
!
! ADTRAN, Inc. OS version 18.01.03.00
! Boot ROM version 17.04.01.00
! Platform: NetVanta 4430, part number 1700630E1
! Serial number LBADTNXXXXXXXX
!
!
hostname "Router"
no enable password
!
clock timezone -8
clock no-auto-correct-DST 
!
ip subnet-zero
ip classless
ip routing
ipv6 unicast-routing
!
!
ip name-server 8.8.8.8 8.8.4.4 
!       
!
no auto-config
!
no event-history
no logging forwarding
no logging email
!
no service password-encryption
!
!
!
ip firewall
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
!
!
!
!
!       
!
!
no dot11ap access-point-control
!
!
!
!
ip dhcp-server excluded-address 10.10.3.1 10.10.3.3
ip dhcp-server excluded-address 10.10.10.1 10.10.10.15
!
ip dhcp-server pool “VLAN3”
  network 10.10.3.0 255.255.255.192
  domain-name “vlan3.com"
  dns-server 8.8.8.8 (ISP Provided DNS)
  default-router 10.10.3.1
!
ip dhcp-server pool “VLAN2”
  network 10.10.10.0 255.255.255.0
  default-router 10.10.10.1
!
ip dhcp-server pool “VLAN4”
  network 192.168.5.0 255.255.255.0
  domain-name “vlan4.com"
  dns-server 8.8.8.8 (ISP Provided DNS)
  default-router 192.168.5.1
!
ip dhcp-server pool “VLAN5”
  network 10.10.5.0 255.255.255.192
  domain-name “vlan5.com"
  dns-server 8.8.8.8 (ISP Provided DNS)
  default-router 10.10.5.1
!
ip dhcp-server pool “VLAN6”
  network 10.10.6.0 255.255.255.0
  domain-name “vlan6.com”
  dns-server 8.8.8.8 (ISP Provided DNS)
  default-router 10.10.6.1
!
ip dhcp-server pool "Canon 1”
  default-router 192.168.5.1
  host 192.168.5.234 255.255.255.0
  hardware-address
f4:a9:97:xx:xx:xx ethernet
!
ip dhcp-server pool “printer2”
  default-router 192.168.5.1
  host 192.168.5.201 255.255.255.0
  hardware-address 84:ba:3b:xx:xx:xx ethernet
!
ip dhcp-server pool "C5550"
!
!
!
!
!
!
!
no ethernet cfm
!
interface eth 0/1
  no ip address
  shutdown
!
!
!
interface gigabit-eth 0/1
  ip address  (EXTERNAL IP) 255.255.255.252 
  no shutdown
!
!       
interface gigabit-eth 0/2
  encapsulation 802.1q
  no shutdown
!
interface gigabit-eth 0/2.2
  description BLAH
  vlan-id 2
  ip address  10.10.10.1  255.255.255.0 
  no shutdown
interface gigabit-eth 0/2.3
  description BLAH
  vlan-id 3
  ip address  10.10.3.1  255.255.255.192 
  no shutdown
interface gigabit-eth 0/2.4
  description BLAH
  vlan-id 4
  ip address  192.168.5.1  255.255.255.0 
  no shutdown
interface gigabit-eth 0/2.5
  description BLAH
  vlan-id 5
  ip address  10.10.5.1  255.255.255.192 
  no shutdown
interface gigabit-eth 0/2.6
  description BLAH
  vlan-id 6
  ip address  10.10.6.1  255.255.255.0 
  no shutdown
!
!
!
!
!
!
!
!
!
ip access-list extended PermitAny
  permit ip any  any    
!
ip access-list extended printers
  permit ip 10.10.3.0 0.0.0.192  host 192.168.5.0    
  permit ip 10.10.2.0 0.0.0.255  192.168.5.0 0.0.0.255    
  permit ip 10.10.6.0 0.0.0.255  192.168.5.0 0.0.0.255    
  permit ip 10.10.3.0 0.0.0.192  192.168.5.0 0.0.0.255    
!
!
!
!
ip policy-class print
  allow list printers
  nat source list PermitAny interface gigabit-ethernet 0/1 overload
!
!
!
ip route 0.0.0.0 0.0.0.0 (GATEWAY OF ONT)
!
no tftp server
no tftp server overwrite
no ip http server
no ip http secure-server
no ip snmp agent
no ip ftp server
ip ftp server default-filesystem flash
no ip scp server
no ip sntp server
!
!       
!
!
!
!
!
!
ip sip udp 5060
ip sip tcp 5060
!
!
!
!
!
!
!
!
!
!
!
!
!
!
line con 0
  no login
!
line telnet 0 4
  login
  no shutdown
line ssh 0 4
  login local-userlist
  no shutdown
!
!
!
!
!
end```




7
  • 4
    I do not see where you are performing NAT for your private addressing. Remember that Private addressing is not allowed on the public Internet, so you need to translate the Private addresses to public addresses.
    – Ron Maupin
    Dec 25, 2019 at 5:07
  • Ahhh shucks! To be honest I remember reading about that in the AOS command reference but never got a solid answer on what it was for. Do you have any good guides or documentation for NATting on Cisco-esque equipment that I could read? Or even an example, even though I hate to ask for it? Dec 25, 2019 at 5:17
  • 1
    Unfortunately, product or resource recommendations are explicitly off-topic here, but simply searching for cisco nat will turn up a lot of Cisco documents on the subject.
    – Ron Maupin
    Dec 25, 2019 at 5:19
  • No worries at all, I will go read and see if anything confuses me. Who knew that 3 hours of pulling my hair out would be fixed with one comment! Thank you so much!! Dec 25, 2019 at 5:27
  • 1
    Update: found a nice article on how to do basic NATting with overload just so I can get something up and going with a route to the internet! I'll be back later once I find another issue. Thanks again Ron! Dec 25, 2019 at 6:13

1 Answer 1

3

You did not configure NAT for your Private-to-Public addressing, so your packets will be dropped on the public Internet. The ISPs have agreed not to route packets with Private addressing.


Unfortunately, I'm not completely sure how to do that on your Adtran device. The syntax appears similar to Cisco IOS, but there are a few differences, so I do not know if the Cisco syntax for NAT configuration will actually work on your device.

1
  • Ehh, I'll work out the little differences between AOS and Cisco. I really appreciate it Ron, and hope you had a happy holiday! Dec 26, 2019 at 5:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.