1

I'm trying to ping from Router DC_GE to BE: enter image description here

I uploaded the Packet Tracer File (v. 7.2.1):

https://www.4shared.com/file/aEsd_0Piiq/Topologie_Ausgangspunkt_MH.html

CD_GE:

CD_GE#show running-config 
Building configuration...

Current configuration : 1198 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname CD_GE
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback0
 ip address 10.255.255.11 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.0.11.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 209.165.0.9 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 209.165.0.17 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet1/1
 ip address 209.165.0.25 255.255.255.248
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 10
 router-id 1.1.1.1
 log-adjacency-changes
 passive-interface FastEthernet0/1
 passive-interface FastEthernet1/0
 passive-interface FastEthernet1/1
 network 10.0.11.0 0.0.0.255 area 1
 network 209.165.0.8 0.0.0.7 area 1
 network 209.165.0.16 0.0.0.7 area 1
 network 209.165.0.24 0.0.0.7 area 1
 default-information originate
!
router rip
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end


CD_GE#

GE:

GE#show running-config 
Building configuration...

Current configuration : 1168 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname GE
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524LPW0-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback0
 ip address 10.255.255.10 255.255.255.255
!
interface GigabitEthernet0/0
 description LAN_GE
 ip address 10.0.12.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description Transfer_GE
 ip address 10.0.11.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 10.0.10.2 255.255.255.252
!
interface Serial0/0/1
 ip address 10.0.19.1 255.255.255.252
 clock rate 1000000
!
interface Serial0/1/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/1/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 10
 router-id 2.2.2.2
 log-adjacency-changes
 passive-interface GigabitEthernet0/0
 network 10.0.11.0 0.0.0.255 area 1
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end 
GE#

BE (deprecated, see amended version below):

BE#show running-config
Building configuration...

Current configuration : 957 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname BE
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524NE1A-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 10.0.10.1 255.255.255.252
 clock rate 4000000
!
interface Serial0/0/1
 ip address 10.0.20.1 255.255.255.252
 clock rate 4000000
!
interface Serial0/1/0
 ip address 209.165.0.2 255.255.255.248
 ipv6 address 2001:DB8:123:C000::2/64
!
interface Serial0/1/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end


BE#

I can ping from DC_GE to GE and from GE to BE, but not all the way through.


Adding BE router to OSPF:

BE#show running-config 
Building configuration...

Current configuration : 1120 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname BE
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524NE1A-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 10.0.10.1 255.255.255.252
 clock rate 4000000
!
interface Serial0/0/1
 ip address 10.0.20.1 255.255.255.252
 clock rate 4000000
!
interface Serial0/1/0
 ip address 209.165.0.2 255.255.255.248
 ipv6 address 2001:DB8:123:C000::2/64
!
interface Serial0/1/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 10
 router-id 1.1.1.1
 log-adjacency-changes
 network 10.0.10.0 0.0.0.3 area 0
 network 10.0.20.0 0.0.0.3 area 0
 network 209.165.0.0 0.0.0.7 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end


BE#

GE after adding it to area A1 and Backbone area 0.

GE#show ip ospf 
 Routing Process "ospf 10" with ID 2.2.2.2
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 It is an area border router
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 2. 2 normal 0 stub 0 nssa
 External flood list length 0
    Area 1
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm executed 8 times
        Area ranges are
        Number of LSA 7. Checksum Sum 0x03dd6d
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
    Area BACKBONE(0)
        Number of interfaces in this area is 2
        Area has no authentication
        SPF algorithm executed 3 times
        Area ranges are
        Number of LSA 7. Checksum Sum 0x02ed96
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

GE#
  • Likely, one or both routers lack a route to the other one. You'll need to add the relevant config details to your question - not everyone's got PT. – Zac67 Dec 26 '19 at 20:43
  • You need to provide the network device configurations, otherwise we can only guess where you sent wrong, and guessing and speculation are off-topic here. Please edit your question to include the configurations. – Ron Maupin Dec 26 '19 at 20:45
  • Added the routing information.. would that help? Requesting to reopen the question. – TMOTTM Dec 26 '19 at 20:49
  • Please include all the network device configurations. – Ron Maupin Dec 26 '19 at 21:22
  • running-config of the two routers is added to the question. I hope that's the most relevant one but will add whatever might else be needed. – TMOTTM Dec 26 '19 at 21:24
2

Your problem is that neither the DC_GE nor the BE router knows how to reach the other router. They both know how to reach the GE router because they are directly connected to it, and each knows about the directly connected networks.

A router will drop packets destined to a network for which a route does not exist in its routing table. Routers learn routes in three ways:

  1. Directly connected networks
  2. Statically configured routes
  3. Dynamically through a routing protocol

You have OSPF configured between the DC_GE and the GE routers, but the only interface in the GE router participating in OSPF is the one directly connected to DC_GE, meaning that GE is learning routes from DC_GE, but DC_GE is not learning any routes from GE.

That means that DC_GE has no route to BE (or any networks beyond the GE interface), so it will not send any traffic toward BE.

Conversely BE has no information about any networks beyond the GE interface to which it is connected.

You need to make GE an ABR. It already has an interface in Area 1, but you need to make the interface toward BE an Area 0 interface. Adding that interface to OSPF on GE using Area 0 should allow all three routers to exchange routing information.

| improve this answer | |
  • Thanks, will come back when I figured out how to do that. – TMOTTM Dec 26 '19 at 22:00
  • It is exactly the same way you put the interface to DC_GE into Area 1. Simply use a network statement for that interface network, but use Area 0 instead of Area 1. – Ron Maupin Dec 26 '19 at 22:02
  • OK. i'm added the network configurations.. am I supposed to see ABR somewhere? GE is now in two areas (see the amended question text). – TMOTTM Dec 26 '19 at 22:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.