1

I am relatively new to this and I have been trying various configs but nothing is catching. I have three routers, with various vlans. The vlans are working. The routers are seeing each other using OSPF. But I cannot get hosts on one side to see hosts on the next side.

I originally had all the links as /30 subnet but I am not sure is this is correct. I tried others but in no attempts was the gigabit detected so I removed thems

RIGHT {hostname R3M

!
!
!
!
ip dhcp excluded-address 172.20.0.1
ip dhcp excluded-address 172.20.2.1
ip dhcp excluded-address 172.20.4.1
ip dhcp excluded-address 172.20.0.1 172.20.0.9
ip dhcp excluded-address 172.20.2.1 172.20.2.9
ip dhcp excluded-address 172.20.4.1 172.20.4.9
!
ip dhcp pool Consulting
 network 172.20.0.0 255.255.254.0
 default-router 172.20.0.1
ip dhcp pool HR
 network 172.20.2.0 255.255.254.0
 default-router 172.20.2.1
ip dhcp pool IT
 network 172.20.4.0 255.255.254.0
 default-router 172.20.4.1
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2901/K9 sn FTX15243FV0-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
 ip address 172.20.40.25 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.15
 encapsulation dot1Q 15
 ip address 172.20.0.1 255.255.254.0
!
interface GigabitEthernet0/0.25
 encapsulation dot1Q 25
 ip address 172.20.2.1 255.255.254.0
!
interface GigabitEthernet0/0.35
 encapsulation dot1Q 35
 ip address 172.20.4.1 255.255.254.0
!
interface GigabitEthernet0/0.88
 encapsulation dot1Q 88
 ip address 172.20.6.1 255.255.255.128
!
interface GigabitEthernet0/0.90
 encapsulation dot1Q 90 native
 ip address 172.20.6.139 255.255.255.128
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 172.20.20.1 255.255.255.252
!
interface Serial0/0/1
 ip address 172.20.20.6 255.255.255.252
 clock rate 64000
!
interface Serial0/1/0
 no ip address
 clock rate 64000
 shutdown
!
interface Serial0/1/1
 no ip address
 clock rate 64000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 router-id 11.11.11.11
 log-adjacency-changes
 network 172.20.20.0 0.0.0.3 area 0
 network 172.20.20.4 0.0.0.3 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end}

{MS1#show run

Building configuration...

Current configuration : 5702 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname MS1
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 15
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
!
interface FastEthernet0/2
 switchport access vlan 25
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
!
interface FastEthernet0/3
 switchport access vlan 35
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
!
interface FastEthernet0/4
 switchport access vlan 88
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
!
interface FastEthernet0/5
 switchport access vlan 15
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
!
interface FastEthernet0/6
 switchport access vlan 25
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
!
interface FastEthernet0/7
 switchport access vlan 35
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
!
interface FastEthernet0/8
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/9
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/10
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/11
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/12
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/13
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/14
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/15
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/16
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/17
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/18
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/19
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/20
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/21
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/22
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/23
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/24
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface GigabitEthernet0/1
 description To Router
 switchport trunk native vlan 90
 switchport trunk allowed vlan 15,25,35,88,90
 switchport mode trunk
 switchport nonegotiate
 no cdp enable
!
interface GigabitEthernet0/2
 description Link to MS2
 switchport trunk native vlan 90
 switchport trunk allowed vlan 15,25,35,88,90
 switchport mode trunk
 switchport nonegotiate
 no cdp enable
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan88
 mac-address 00d0.9715.0d01
 ip address 172.20.6.10 255.255.255.128
!
ip default-gateway 172.20.6.1
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

}

BOTTOM
{

R2L#show run
Building configuration...

Current configuration : 1968 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2L
!
!
!
!
ip dhcp excluded-address 172.20.8.1 172.20.8.9
ip dhcp excluded-address 172.20.10.1 172.20.10.9
ip dhcp excluded-address 172.20.12.1 172.20.12.9
!
ip dhcp pool Consulting
 network 172.20.8.0 255.255.254.0
 default-router 172.20.8.1
ip dhcp pool HR
 network 172.20.10.0 255.255.254.0
 default-router 172.20.10.1
ip dhcp pool IT
 network 172.20.12.0 255.255.254.0
 default-router 172.20.12.1
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2901/K9 sn FTX15246R9I-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0
 ip address 172.20.20.29 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.15
 encapsulation dot1Q 15
 ip address 172.20.8.1 255.255.254.0
!
interface GigabitEthernet0/0.25
 encapsulation dot1Q 25
 ip address 172.20.10.1 255.255.254.0
!
interface GigabitEthernet0/0.35
 encapsulation dot1Q 35
 ip address 172.20.12.1 255.255.254.0
!
interface GigabitEthernet0/0.88
 encapsulation dot1Q 88
 ip address 172.20.14.1 255.255.255.128
!
interface GigabitEthernet0/0.90
 encapsulation dot1Q 90
 no ip address
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 172.20.20.2 255.255.255.252
 clock rate 64000
!
interface Serial0/0/1
 ip address 172.20.20.10 255.255.255.252
!
interface Serial0/1/0
 no ip address
 clock rate 64000
 shutdown
!
interface Serial0/1/1
 no ip address
 clock rate 64000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 router-id 22.22.22.22
 log-adjacency-changes
 network 172.20.20.0 0.0.0.3 area 0
 network 172.20.20.8 0.0.0.3 area 0
!
router rip
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end}

{LS1#show run

Building configuration...

Current configuration : 5512 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname LS1
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 15
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
!
interface FastEthernet0/2
 switchport access vlan 25
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
!
interface FastEthernet0/3
 switchport access vlan 35
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
!
interface FastEthernet0/4
 switchport access vlan 88
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
!
interface FastEthernet0/5
 switchport access vlan 15
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
!
interface FastEthernet0/6
 switchport access vlan 25
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
!
interface FastEthernet0/7
 switchport access vlan 35
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
!
interface FastEthernet0/8
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/9
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/10
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/11
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/12
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/13
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/14
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/15
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/16
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/17
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/18
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/19
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/20
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/21
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/22
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/23
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface FastEthernet0/24
 switchport access vlan 11
 switchport mode access
 speed 100
 no cdp enable
 spanning-tree portfast
 spanning-tree bpduguard enable
 storm-control broadcast level 75
 shutdown
!
interface GigabitEthernet0/1
 switchport trunk native vlan 90
 switchport trunk allowed vlan 15,25,35,88,90
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport access vlan 11
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan88
 mac-address 00d0.9741.4601
 ip address 172.20.6.11 255.255.255.128
!
ip default-gateway 172.20.14.1
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end}

TOP
{CR1#show r

Building configuration...

Current configuration : 1095 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname CR1
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2901/K9 sn FTX15245A6C-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 172.20.20.9 255.255.255.252
 clock rate 64000
!
interface Serial0/0/1
 ip address 172.20.20.5 255.255.255.252
!
interface Serial0/1/0
 no ip address
 clock rate 64000
 shutdown
!
interface Serial0/1/1
 no ip address
 clock rate 64000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 router-id 33.33.33.33
 log-adjacency-changes
 network 172.20.20.4 0.0.0.3 area 0
 network 172.20.20.8 0.0.0.3 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

}

I am unsure what to do with the G/ports. I would love someone to help or point me in the right direction.

I hope this edit helps. It's a lot of info.

enter image description here

5
  • Please include the network device configurations. We cannot simply guess where you may have gone wrong in the configurations.
    – Ron Maupin
    Commented Dec 27, 2019 at 20:19
  • No, what I meant was to do do a show running config on each network device, then copy that and paste it into the question using the Preformatted-text option ({}). We need to see the configurations for all the network devices (routers and switches) because we have no idea where you may have misconfigured something.
    – Ron Maupin
    Commented Dec 27, 2019 at 20:40
  • The OSPF network statements tell OSPF which interfaces it should include in the OSPF process. Granted, you many not want to send OSPF hellos out the VLANs, so there is the passive-interface command that will stop that for interfaces you have included in the OSPF process. You need network statements that will include every interface that you wish to advertise to other OSPF routers. You can use the passive command for the interfaces where there are no routes.
    – Ron Maupin
    Commented Dec 27, 2019 at 21:07
  • I was traveling so I never got a chance to respond. I will try this and let you know. Also thank you for just responding.
    – JamMan
    Commented Dec 28, 2019 at 19:23
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can post and accept your own answer.
    – Ron Maupin
    Commented Dec 17, 2020 at 14:43

1 Answer 1

3

You are not advertising the VLANs to other routers because they are not part of the OSPF domain.

The OSPF configuration defines which interfaces are included in OSPF (i.e. the domain). You have only included the links between the routers, so that is all that OSPF will advertise.

To make this work, create network statements in the OSPF section that include the router subinterfaces.

For example, on R1, you can include:

network 172.20.0.1 0.0.0.0 area 0

That will advertise VLAN 15. You can do the rest for the other VLANs (on both routers).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.