2

i have an issue with an ISR4331 Box. My aim is to install IOS 16.09.04 on the box currently running at 155-3.S4b.

#sh run | sec boot
boot-start-marker
boot system flash bootflash:/isr4300-universalk9.16.09.04.SPA.bin
boot-end-marker

The path to the image is correct:

#dir bootflash:/isr4300-universalk9.16.09.04.SPA.bin
Directory of bootflash:/isr4300-universalk9.16.09.04.SPA.bin

   15  -rw-        585126403  Jan 10 2020 09:02:12 +00:00  isr4300-universalk9.16.09.04.SPA.bin

3232477184 bytes total (1989283840 bytes free)

And the image itself is OK too:

Embedded Hash   SHA1 : 87D928C49CBD8EFB40C0A06BF2EBFD57498F302B
Computed Hash   SHA1 : 87D928C49CBD8EFB40C0A06BF2EBFD57498F302B
Starting image verification
Hash Computation:    100%Done!
Computed Hash   SHA2: b026294539f32f3ea152a93347212005
                      931587215d531f954487823e29879c62
                      27cc9892a9e6507c5590222414bbff01
                      f1a2ad8ab2e0255bff7823c6ccffb863

Embedded Hash   SHA2: b026294539f32f3ea152a93347212005
                      931587215d531f954487823e29879c62
                      27cc9892a9e6507c5590222414bbff01
                      f1a2ad8ab2e0255bff7823c6ccffb863

Digital signature successfully verified in file bootflash:/isr4300-universalk9.16.09.04.SPA.bin

Embedded hash verification successful.

After a reboot the Box still runs at 155-3.S4b. So i think it is a fallback after trying to boot 16.09.04.

i'm quite confused because i'm running this combination of HW and IOS on about 40 boxes without any issues and did the upgrade procedure about hundrets of times. Unfortunately i can't get the console output during boot because the box is installed at a remote site. The running logfile doesn't give any clues.

Any ideas how to troubleshoot this on a remote box with SSH access only?

2

Luckily i found an old ISR4331 in our storage racks with the same Software state as the one i struggle with.

It seems that the ROMMON Bootloader is zu old to handle the image bundle format of IOS 16.09.04. so that the builtin Rommon image could not be loaded during the IOS Upgrade process.

RSA Signed RELEASE Image Signature Verification Successful.
Package Load Test Latency : 10704 msec 

Unknown image structure
boot: error executing "boot bootflash:/isr4300-universalk9.16.09.04.SPA.bin"
autoboot: boot failed, restarting...

My solution was to take IOS XE 16.3.9 as an intermediate step to have the ROMMON firmware updated in a proper way.

Problem solved!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.