1

I'm trying to connect my small topology to the internet through the Cloud device, but I'm not able to connect to even my own desktop's IP from the virtual router I have.

I have Windows Defender rules allowing inbound and outbound traffic to and from gns3, gns3server, and gns3vmnet(I've also tried turning off defender). In my GNS3 VM, I have Adapter 3 set to Bridged Adapter, which is using my desktop's NIC (Intel(R) Ethernet Connection (2) I219-V)

Environment

-Windows 10

-GNS3 2.2.3

-My virtual router is using VyOS 1.1.8

-Using VirtualBox 6.1 to manage my vm's

So far I've tried:

-setting my virtual router's external interface, eth1 (the one connected to the cloud) to accept an address via dhcp (which hasn't happened)

-ping from the router to Google. I get "Network is unreachable"

-Connecting the router to the Host Only, NAT, and Bridged interfaces on the Cloud device

-Changed the Host Only and Bridged Adapter interfaces in VirtualBox to "Allow VMs" in promiscuous mode.

-set interface eth2 on my router to 192.168.1.17/24 (same net address as my pc) to see if I could ping from the router to the desktop, or vice-versa. I get "Destination Host is unreachable" whenever I try pinging from either device to the other. My desktop IP is 192.168.1.70/24.

-Followed this video to try and connect my topology to the internet: https://youtu.be/2zeoC2Q4mW0

Of course the router just magically gets an address on its external interface whenever the presenter sets it to receive an address via dhcp, but mine won't

-Followed this specific video to set up a VyOS 1.1.8 router in my topology: https://youtu.be/3oi53Yxh0ik

This example uses VirtualBox to manage vm's as well, similar to my topology. I have my router interfaces set up the same way from VirtualBox as well (attached to "Not Attached", since I'll be connecting the router only to virtual devices within my virtual network anyway).

-installed a loopback adapter on my Windows 10 system. Next, I went to Control Panel, right clicked on my physical ethernet connection > Sharing > Allow other network users to connect... > selected "Ethernet3", the connection corresponding to my loopback adapter. At this point I verified that the loopback adapter received the address of 192.168.137.1/24

-Tried changing interface 3 of the GNS3 vm to use the loopback adapter

-Changed the address of one of the addresses on my router to the address 192.168.137.2/24 and attempted to ping 192.168.137.1. Got "destination host unreachable". Video followed for reference: https://youtu.be/JOX6ptyX3O4 Wasn't able to find anything like this relevant to Windows 10.

I'm not sure what else to do from here. Is the issue really with GNS3 or could it be with VirtualBox, and what could I do to find out where the problem lies?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.