0

I have a Cisco 5508 Wireless LAN controller and a Cisco AIR-CAP3702I-A-K9 Access point.

The WLC release is: 7.0.252.0

The AP is : Cisco IOS Software, C3700 Software (AP3G2-K9W8-M), Version 15.3(3)JA9, RELEASE SOFTWARE (fc2)

According to what I thought I learned about the AP discovery process, in the case of an ios miss-match, that the AP downloads the image from the WLC.

Howver looking at this document -- compatibility matrix -- with the exerpt below, it looks like they aren't compatible.

So if they aren't compatible (as I'm just learing for now) , is there anything I can do with out a Cisco service contract? I can buy one of the AP's on the list for fairly cheap, but will that guaranty they are compatible?

7.0.252.0    

Lightweight APs: 1040, 1120, 1130, 1140, 1220, 1230, 1240, 1250, 1260, 1300, 3500, OEAP 600 Series, 3500p, AP801, and AP802

Outdoor and Industrial APs: 1522, 1524SB, 1552E, 1552H, 1552I, 1552C, and 1552S
5

Cisco's policy is to offer free software upgrades for security vulnerabilities. They only let you get the feature set you already have, and they give you the smallest "feature version" upgrade for which they have a fix. One trick is to find a security vulnerability that affects your current version requiring an upgrade to the version you want. Recent security vulnerabilities are the best way to search (old security vulnerabilities for 7.0 tend to upgrade to a later release of 7.0, but recent security vulnerabilities tend not to have a fixed version for old feature releases).

Your WLC is vulnerable to the Cisco Wireless LAN controller secure shell denial of service vulnerability. https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20191016-wlc-ssh-dos

All versions prior to 8.5.140.0 are vulnerable.

Cisco has released free software updates that address the vulnerability described in this advisory.

Customers who purchase directly from Cisco but do not hold a Cisco service contract and customers who make purchases through third-party vendors but are unsuccessful in obtaining fixed software through their point of sale should obtain upgrades by contacting the Cisco TAC: https://www.cisco.com/c/en/us/support/web/tsd-cisco-worldwide-contacts.html

Edited from comments: OP was unsuccessful after calling TAC. TAC said his case didn't warrant use of the policy because OP bought the WLC used, through a third party, it's out warranty has expired and it's EoL.

The EOL notice is at https://www.cisco.com/c/en/us/products/collateral/wireless/5500-series-wireless-controllers/eos-eol-notice-c51-740221.html The "end of new service attachment date" was August 1st 2019, so in theory it's not possible to buy support.

Back to the original question, release notes for 7.0.252.0 are at https://www.cisco.com/c/en/us/td/docs/wireless/controller/release/notes/crn70mr7.html It confirms support for the Cisco 3502i access-point, which has an internal antenna and is inexpensive used. But WLC software has changed dramatically since 7.0 so using 7.0 WLC software for training (my assumption) will be helpful but not ideal.

| improve this answer | |
  • Calling Cisco TAC, they say my case doesn't warrant use of this policy because; i bought the WLC used, through a third party, it's out warranty has expired and it's EoL. I'm not sure if there's a work around for that. – Frank Jan 27 at 18:27
  • You could probably pick up a used compatible AP for not much money. – Ron Trunk Jan 27 at 20:24
  • My company was able to provide me free Cisco 3702i APs for training, but I had to purchase my own WLC. I took your guy's advice and ordered a couple of 3502i APs. Cisco sure doesn't make it easy for independent learners though. – Frank Jan 27 at 20:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.