0

I have a 2921 Cisco router in one place, and a Windows XP computer on another. I made my Cisco router as PPTP server, and my XP computer as a client.

The router is located within a LAN with address scope of 10.253.2.0/24, without Internet access.

Here is the router's full configuration:

    Using username "offer".
Using keyboard-interactive authentication.
Password:
Router#show run
Building configuration...

Current configuration : 3681 bytes
!
! Last configuration change at 17:42:02 IST Wed Jan 29 2020 by offer
! NVRAM config last updated at 17:58:04 IST Wed Jan 29 2020 by offer
! NVRAM config last updated at 17:58:04 IST Wed Jan 29 2020 by offer
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
aaa new-model
!
!
aaa authentication ppp default local
!
!
!
!
!
aaa session-id common
clock timezone IST 2 0
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
vpdn enable
!
vpdn-group 1
 ! Default PPTP VPDN group
 accept-dialin
  protocol pptp
  virtual-template 1
 l2tp tunnel timeout no-session 15
!
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-78248474
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-78248474
 revocation-check none
 rsakeypair TP-self-signed-78248474
!
!
!
!
username offer privilege 15 password 0 offer
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address 10.253.2.5 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 10.253.1.5 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Virtual-Template1
 ip unnumbered GigabitEthernet0/1
 peer default ip address pool ForMe
 no keepalive
 ppp authentication pap
!
ip local pool ForMe 10.253.2.100
ip forward-protocol nd
!
ip http server
ip http secure-server
!
ip route 10.253.0.0 255.255.0.0 10.253.1.1
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 password offer123
 transport input all
line vty 5 15
 password offer123
 transport input all
!
scheduler allocate 20000 1000
ntp master
ntp server 10.253.1.13
end

Router#

So, on the PPTP client I unchecked the "Use remote default gateway" so I'll still have local Internet access not through the remote router.

The problem: When I dial that connection - it adds a route to 10.0.0.0 mask 255.0.0.0 to use the PPTP connection, instead of adding the correct route: 10.253.2.0 netmask 255.255.255.0.

How can I configure the Cisco router to inform the right 'available network' to the Windows XP computer when the connection is made? What protocol is used to exchange such information between PPTP server and client?

Many thanks!

  • Please edit your question to include the router configuration. – Ron Maupin Feb 5 at 16:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.