2

I have an internal web server on port 80. I need help commands maybe to configure port forwarding to access the server on my private network from a public IP

Current running config

interface Tunnel1
 ip unnumbered GigabitEthernet0/0/0
 tunnel source X.139.250.X
 tunnel mode ipsec ipv4
 tunnel destination X.232.253.X
 tunnel protection ipsec profile 3DESMD5
!
interface Tunnel2
 ip unnumbered GigabitEthernet0/0/0
 tunnel source X.139.250.X
 tunnel mode ipsec ipv4
 tunnel destination X.232.2.X
 tunnel protection ipsec profile 3DESMD5
!
interface GigabitEthernet0/0/0
 description SAF WAN
 ip address X.139.250.X 255.255.255.0
 ip nat outside
 negotiation auto
!
interface GigabitEthernet0/0/1
 description LAN
 ip address X.21.10.X 255.255.255.0
 ip nat inside
 negotiation auto
!
interface GigabitEthernet0/0/2
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 no ip address
 shutdown
 negotiation auto
!
interface Vlan1
 no ip address
 shutdown
!
ip nat inside source list 102 interface GigabitEthernet0/0/0 overload
ip forward-protocol nd
no ip http server
no ip http secure-server
ip tftp source-interface GigabitEthernet0
ip route 0.0.0.0 0.0.0.0 X.139.250.220
ip route X.31.15.X 255.255.255.0 Tunnel1 name VPN-HQ(/24)
ip route X.31.40.X 255.255.252.0 Tunnel2 name VPN-PALE
ip route X.32.0.X 255.255.0.0 Tunnel1 name VPN-HQ(/16)
!
!
access-list 102 permit ip X.21.10.X 0.0.0.255 any
!
!
!
control-plane
!
!
4
  • Cisco is a brand, not a product. We need to know what model device you have, and also a full sanitized config. We can't just guess - that's off limits here.
    – Jesse P.
    Feb 12, 2020 at 12:57
  • Sorry, it's a Cisco router 4300 Series Feb 12, 2020 at 12:58
  • 2
    By the way, IANA has reserved three IPv4 ranges for use as examples when you do not want to use real IPv4 addresses, and you should use those. That way, people can test what you put as a configuration, and there will be no confusion about addressing or networks. The three ranges are: 192.0.2.0/24, 198.51.100.0/24, and 203.0.113.0/24. Use them in place of any public addressing (private addressing is fine to post as it is), and network engineers will understand that those are not real addresses, but they are addresses that can be mocked up and tested.
    – Ron Maupin
    Feb 12, 2020 at 14:39
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can post and accept your own answer.
    – Ron Maupin
    Nov 19, 2022 at 22:47

1 Answer 1

0

According to your requirement a inbound connectivity need to establish to access application hosted inside internal network accessing it from outside

Static NAT configuration is required on cisco 4300 router to hide internal server ip address from exposing outside

NAT public ip address provided by ISP with server private ip address .

**Example **

Nat configuration

Router(config) ip nat inside souce static 203.X.X.X 192.168.X.X

Where as 203.X.X.X = public ip address provided by ISP

192.168.X.X = private ip address of server

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.