1

I'm currently troubleshooting a network i built and I'm having an issue with ping connectivity, i have set up DHCP and DNS and my end devices can get IP's from DHCP as well as i have intervlan connectivity and all of my end devices can ping each-other, as well as my router can ping my end devices, but neither of my 2 switches are unable to ping any of these devices. If someone could inform me of what I'm overlooking in my configuration it would be greatly appreciated thank you!

This is my Router Config

hostname ChinaRouter
!
!
!
!
ip dhcp excluded-address 192.168.99.2
!
ip dhcp pool Student
 network 192.168.30.0 255.255.255.0
 default-router 192.168.30.254
 dns-server 192.168.99.2
ip dhcp pool Management
 network 192.168.99.0 255.255.255.0
 default-router 192.168.99.254
 dns-server 192.168.99.2
ip dhcp pool VOIP
 network 192.168.10.0 255.255.255.0
 default-router 192.168.10.254
 option 150 ip 192.168.10.254
 dns-server 192.168.99.2
ip dhcp pool Instructor
 network 192.168.20.0 255.255.255.0
 default-router 192.168.20.254
 dns-server 192.168.99.2
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX15245JP0-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 ip address 192.168.0.254 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.10
 encapsulation dot1Q 10
 ip address 192.168.10.254 255.255.255.0
!
interface GigabitEthernet0/1.20
 encapsulation dot1Q 20
 ip address 192.168.20.254 255.255.255.0
!
interface GigabitEthernet0/1.30
 encapsulation dot1Q 30
 ip address 192.168.30.254 255.255.255.0
!
interface GigabitEthernet0/1.99
 encapsulation dot1Q 99
 ip address 192.168.99.254 255.255.255.0
!
interface Serial0/1/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/1/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 passive-interface GigabitEthernet0/0
 passive-interface GigabitEthernet0/1
 network 192.168.10.0 0.0.0.255 area 0
 network 192.168.20.0 0.0.0.255 area 0
 network 192.168.30.0 0.0.0.255 area 0
 network 192.168.99.0 0.0.0.255 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

This is my Switch 1 Config

hostname ChinaSW1
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/2
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/3
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/4
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/5
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/6
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/7
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/8
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/9
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/10
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/11
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/12
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/13
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/14
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/15
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/16
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/17
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/18
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/19
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/20
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/21
 description VOIP
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/22
 description Management PC
 switchport access vlan 99
 switchport mode access
!
interface FastEthernet0/23
 description Trunking
 switchport mode trunk
!
interface FastEthernet0/24
 description Trunking
 switchport mode trunk
!
interface GigabitEthernet0/1
 description Connection to router
 switchport mode trunk
!
interface GigabitEthernet0/2
 description Printer
 switchport access vlan 20
 switchport mode access
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

And This is my Switch 2 Config

hostname ChinaSW2
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/2
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/3
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/4
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/5
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/6
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/7
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/8
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/9
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/10
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/11
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/12
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/13
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/14
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/15
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/16
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/17
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/18
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/19
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/20
 description Student PC
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/21
 description VOIP
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/22
 description Management PC
 switchport access vlan 99
 switchport mode access
!
interface FastEthernet0/23
 description Trunking
 switchport mode trunk
!
interface FastEthernet0/24
 description Trunking
 switchport mode trunk
!
interface GigabitEthernet0/1
 description Connection to router
 switchport mode trunk
!
interface GigabitEthernet0/2
 description Printer
 switchport access vlan 20
 switchport mode access
!
interface Vlan1
 no ip address
 shutdown
!
ip default-gateway 192.168.0.254
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end
2
  • When you get an answer to your question, you delete the post. That is not how this works, and you should accept answers that help you. SE sites are not help sites, they are Q&A archives. The premise is that if you have a question, others probably have the same question. You post a question and get answers, and the question and answers are archived for others with the same question to see later.
    – Ron Maupin
    Mar 28, 2020 at 1:03
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can post and accept your own answer.
    – Ron Maupin
    Dec 17, 2020 at 16:29

2 Answers 2

1

Neither of your switches has a layer-3 interface configured, and only one even has a gateway configured. Without an address, your switches cannot participate in any network layers above layer-2.

Switching happens at layer-2, and unmanaged switches cannot ping or be pinged. A managed switch with a configured management interface (and gateway to be able to reach networks other than the one on which its management interface is configured) and address can ping and be pinged.

On each switch, you need to add an SVI for one of the VLANs, configure it with an address in the VLAN network, and configure a gateway for the same network. That will add a management interface for your switch. The management interface is like another host on the VLAN, and it does not have any affect switching.


Also, you have configured OSPF on the router, but that is completely unnecessary and wastes router CPU cycles and adds unnecessary traffic on the networks because it is not actually exchanging routing information with any other router. Routing protocols do not route; they only exchange routing information with other routers.

0

When L3 interface for network is configured on router or layer3 devices then you càn ping destination from this router or layer3 device because when traffic is initiated for ping .

Source address is : source address of device Destination address : destination ip address Source mac address Destination mac address

Are taken into accounts , destination ip address is verified with àgainst route entries in làyer3 devices and further forwards packets accordinglly to route entry present in router.

Basically from layer2 switch we cannnot ping beacuse layer2 switch is subjected to màv address table . When ping traffic is initiated from layer2 switch destination ip address cannot verified with mac -address table

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.