0

I have a really simple set-up but I still cannot find what is wrong. Sorry if duplicate, I searched and didn't find.

  • I have a HP 5130 switch, I install 2 VLAN (30 & 42) + the VLAN 1 for management
  • The VLAN 42 has an interface with IP address: 192.168.42.1/24
  • port 1 is a trunk
  • The ports 9 to 16 are hybrid and untagged 1 and 30
  • The ports 17 to 24 are hybrid and untagged 1 and 42
  • I connected 2 PC:
    • 192.168.42.10/24, GW 192.168.42.1, port 21
    • 192.168.42.99/24, GW 192.168.42.1, port 23
  • The two PC can ping each other
  • Not any PC can ping 192.168.42.1 ...

  • If I change the IP of one PC to 192.168.12.99/24 (VLAN 1, management), I can ping 192.168.12.1 and 192.168.42.1 ...

I don't get what is wrong... What did I miss ???

Thank you !!

Here is my conf:

  #
 version 7.1.045, Release 3113P05
#
 sysname MyAwesomeSwitch
#
 command-alias enable
#
 irf mac-address persistent timer
 irf auto-update enable
 undo irf link-delay
 irf member 1 priority 1
#
 lldp global enable
#
 password-recovery enable
#
vlan 1
 name "DEFAULT_VLAN"
#
vlan 10
 name "Lab"
 description Lab
#
vlan 30
 name VLAN30
#
vlan 42
#
 stp global enable
#
interface NULL0
#
interface Vlan-interface1
 ip address 192.168.12.1 255.255.255.0
#
interface Vlan-interface42
 ip address 192.168.42.1 255.255.255.0
#
interface GigabitEthernet1/0/1
 description Trunk
 port link-type trunk
 port trunk permit vlan 1 10 30 42
#
interface GigabitEthernet1/0/2
#
interface GigabitEthernet1/0/3
#
interface GigabitEthernet1/0/4
#
interface GigabitEthernet1/0/5
#
interface GigabitEthernet1/0/6
#
interface GigabitEthernet1/0/7
#
interface GigabitEthernet1/0/8
#
interface GigabitEthernet1/0/9
 port link-type hybrid
 port hybrid vlan 1 30 untagged
#
interface GigabitEthernet1/0/10
 port link-type hybrid
 port hybrid vlan 1 30 untagged
#
interface GigabitEthernet1/0/11
 port link-type hybrid
 port hybrid vlan 1 30 untagged
#
interface GigabitEthernet1/0/12
 port link-type hybrid
 port hybrid vlan 1 30 untagged
#
interface GigabitEthernet1/0/13
 port link-type hybrid
 port hybrid vlan 1 30 untagged
#
interface GigabitEthernet1/0/14
 port link-type hybrid
 port hybrid vlan 1 30 untagged
#
interface GigabitEthernet1/0/15
 port link-type hybrid
 port hybrid vlan 1 30 untagged
#
interface GigabitEthernet1/0/16
 port link-type hybrid
 port hybrid vlan 1 30 untagged
#
interface GigabitEthernet1/0/17
 port link-type hybrid
 port hybrid vlan 1 42 untagged
#
interface GigabitEthernet1/0/18
 port link-type hybrid
 port hybrid vlan 1 42 untagged
#
interface GigabitEthernet1/0/19
 port link-type hybrid
 port hybrid vlan 1 42 untagged
#
interface GigabitEthernet1/0/20
 port link-type hybrid
 port hybrid vlan 1 42 untagged
#
interface GigabitEthernet1/0/21
 port link-type hybrid
 port hybrid vlan 1 42 untagged
#
interface GigabitEthernet1/0/22
 port link-type hybrid
 port hybrid vlan 1 42 untagged
#
interface GigabitEthernet1/0/23
 port link-type hybrid
 port hybrid vlan 1 42 untagged
#
interface GigabitEthernet1/0/24
 port link-type hybrid
 port hybrid vlan 1 42 untagged
#
interface Ten-GigabitEthernet1/0/25
#
interface Ten-GigabitEthernet1/0/26
#
interface Ten-GigabitEthernet1/0/27
#
interface Ten-GigabitEthernet1/0/28
#
 scheduler logfile size 16
#
line class aux
 user-role network-admin
#
line class vty
 user-role network-operator
#
line aux 0
 user-role network-admin
#
line vty 0 63
 user-role network-operator
#
radius scheme system
 user-name-format without-domain
#
domain system
#
 domain default enable system
#
role name level-0
 description Predefined level-0 role
#
role name level-1
 description Predefined level-1 role
#
role name level-2
 description Predefined level-2 role
#
role name level-3
 description Predefined level-3 role
#
role name level-4
 description Predefined level-4 role
#
role name level-5
 description Predefined level-5 role
#
role name level-6
 description Predefined level-6 role
#
role name level-7
 description Predefined level-7 role
#
role name level-8
 description Predefined level-8 role
#
role name level-9
 description Predefined level-9 role
#
role name level-10
 description Predefined level-10 role
#
role name level-11
 description Predefined level-11 role
#
role name level-12
 description Predefined level-12 role
#
role name level-13
 description Predefined level-13 role
#
role name level-14
 description Predefined level-14 role
#
user-group system
#
local-user admin class manage
 password hash #THISISAHASHTRUSTME#
 service-type ssh http
 authorization-attribute user-role network-admin
 authorization-attribute user-role network-operator
#
 ip http enable
#
return
2
  • 1
    The port hybrid vlan 1 42 untagged may create ambiguity (I'm not familiar with Comware) - what are you trying to achieve?
    – Zac67
    Apr 10 '20 at 10:48
  • I changed all the hybrid to access to remove the ambiguity, it now works, thank you !
    – n0n0bstan
    Apr 13 '20 at 3:57
2

What are you trying to accomplish with all this hybrid port business? This mode is meant for dealing with IP Phones. While one can specify multiple untagged VLANs, untagged traffic received on the port belongs to one, and only one, VLAN -- the PVID, which is VLAN 1 by default. That's why you can't ping 192.168.42.1; untagged traffic is forwarded into VLAN 1 where interface-vlan42 won't see it.

(one can also use hybrid mode for protocol based vlans, eg. an IP vlan and an IPX vlan.)

See Also: HPE Discussion with a few different use-cases.

To quote Richard Litchfield:

There seem to be a limited number of use cases for hybrid ports. I would suggest always sticking to access or trunk ports unless there is a specific problem that is solved by using hybrid ports. (If memory serves, they were originally a bit of kludge to allow a VOIP phone with cascaded PC to work when neither the phone nor PC could be configured to use VLAN tags.)

Hybrid ports are not universally recognised (not standards-based) and may cause other issues. For instance, a hybrid port on a Comware switch has problems talking to ProCurve switch port.

1
  • I configured the switch by using http interface and the hybrid ports have been configured by default. I changed them to access port and now it works ! Thank you !
    – n0n0bstan
    Apr 13 '20 at 3:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.