5

I have 2 brocade switches running vrrp-extended for a specific vlan. Connected to these 2 is an access switch with the default route set to the vrrp-extended virtual ip address.

The problem is that I can't ping the gateway when both vrid are enabled but if I disable one of them, then the ip becomes pingable, I can ping remote ip's, etc.

Here are some configs:

Brocade1

 interface ve 510
 ip address 1.1.1.2 255.255.255.240
 ip vrrp-extended vrid 1
  backup
  advertise backup
  ip-address 1.1.1.1
  enable

Brocade2

interface ve 510
 ip address 1.1.1.3 255.255.255.240
 ip vrrp-extended vrid 1
  backup priority 255
  advertise backup
  ip-address 1.1.1.1
  enable

Anyone know if I need to change anything to get it to work properly? Keep in mind this is not regular vrrp.

Thanks

UPDATE

If I have both vrid's enabled but disable one of the interfaces, then things work again. Not sure if it's related to spanning tree but it might be.

The brocade switches are running 802.1w and the access switch is a cisco running rapid-pvst.

Here is some output with the interface on Brocade1 disabled:

--- VLAN 510 [ STP Instance owned by VLAN 510 ] ----------------------------

Bridge IEEE 802.1W Parameters:

Bridge           Bridge Bridge Bridge Force    tx   
Identifier       MaxAge Hello  FwdDly Version  Hold 
hex              sec    sec    sec             cnt  
10000012f21e8818 20     2      15     Default  3    

RootBridge       RootPath  DesignatedBri-   Root  Max Fwd Hel 
Identifier       Cost      dge Identifier   Port  Age Dly lo  
hex                        hex                    sec sec sec 
10000012f21e8818 0         10000012f21e8818 Root  20  15  2   

Port IEEE 802.1W Parameters:

       <--- Config Params --><-------------- Current state -----------------> 
Port   Pri PortPath P2P Edge Role       State       Designa-  Designated       
Num        Cost     Mac Port                        ted cost  bridge           
2/1    128 0        F   F    DISABLED   DISABLED    0         0000000000000000 
8/21   128 20000    T   F    DESIGNATED FORWARDING  0         10000012f21e8818 
8/22   128 20000    T   F    DESIGNATED FORWARDING  0         10000012f21e8818

Ports 8/21 to 8/22 are interswitch trunk ports btw the brocade1/2 devices.

Brocade2

--- VLAN 510 [ STP Instance owned by VLAN 510 ] ----------------------------

Bridge IEEE 802.1W Parameters:

Bridge           Bridge Bridge Bridge Force    tx   
Identifier       MaxAge Hello  FwdDly Version  Hold 
hex              sec    sec    sec             cnt  
8000000cdba0d219 20     2      15     Default  3    

RootBridge       RootPath  DesignatedBri-   Root  Max Fwd Hel 
Identifier       Cost      dge Identifier   Port  Age Dly lo  
hex                        hex                    sec sec sec 
10000012f21e8818 20000     10000012f21e8818 5/1   20  15  2   

Port IEEE 802.1W Parameters:

      <--- Config Params -->|<------------- Current state ------------------->
Port  Pri PortPath  P2P Edge Role       State       Designa-  Designated       
Num       Cost      Mac Port                        ted cost  bridge           
2/2   128 200000    T   F    DESIGNATED FORWARDING  20000     8000000cdba0d219 
5/1   128 20000     T   F    ROOT       FORWARDING  0         10000012f21e8818 
5/2   128 20000     T   F    ROOT       FORWARDING  0         10000012f21e8818

Ports 5/1 to 5/2 are interswitch trunk ports btw brocade1/2.

From the access switch:

VLAN0510
  Spanning tree enabled protocol rstp
  Root ID    Priority    4096
             Address     0012.f21e.8818
             Cost        20019
             Port        48 (FastEthernet0/48)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    61950  (priority 61440 sys-id-ext 510)
             Address     0013.80fa.0480
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/48              Root FWD 19        128.48   P2p 

Port f0/47 is not up bc it's disabled on brocade1.

  • Can you display the output of "sh ip vrrp-extended vrid 1"? Have you tried lowering the backup priority below 255? – James.Birmingham Mar 11 '14 at 3:07
  • Hi James...yes I initially left it at the default priority and then increased to 255 to make it master. It definitely looks like a spanning tree problem. It seems to be a compatibility issue between 802.1w and rapid-pvst. Might be that the BPDU's are having trouble communicating btw devices. Could that be an option? – Network Samurai Mar 11 '14 at 3:27
  • That could be the issue. May want to look into "dual mode" on the Brocade port as that allows for the port to accept tagged and untagged traffic. Here's an interesting article about Brocade and Cisco interoperability link – James.Birmingham Mar 11 '14 at 3:54
  • Sorry not familiar with Brocade however are you sure an additional command isn't required, eg the equivalent of JUNOS 'accept-data'? – Big Perm Mar 11 '14 at 5:47
  • EDIT - Going to post as answer for now – Network Samurai Mar 11 '14 at 13:32
3

Here is what I had to do to get it to work:

I had to disable 802.1w on the trunk ports specifically (2/1 and 2/2) under the default vlan on both brocade switches.

So spanning-tree is enabled for the actual vlan 510 and the default vlan 50 is disabled on the two ports that go to the cisco switch.

Then everything started to work fine.

So now I have this in the configs on the brocades:

vlan 50 name DEFAULT-VLAN by port
 spanning-tree 802-1w
 spanning-tree 802-1w ethe 2/1 disable

vlan 50 name DEFAULT-VLAN by port
 spanning-tree 802-1w
 spanning-tree 802-1w ethe 2/2 disable

Not sure if this is recommended or not though.

  • Besides the two brocades running vrrp, do you have any other switches in the topology? – Mike Pennington Mar 11 '14 at 13:37
  • Yes, I have other brocades that hang off of each of them. They don't have dual uplinks though like this cisco one does. – Network Samurai Mar 11 '14 at 14:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.