1

I am having trouble getting route redistribution into ISIS working. It works from ISIS to BGP, but I can't get the opposite to show up. I am using IOS-XR

Network has 3 routers:

A----B----C

A and B have an isis connection B and C have a BGP connection

Router A has some 10.0.0.0 subnets that are shared with Rotuer B via ISIS. Router B is then passing these on to Router C with BGP, using the redistribute isis command.

Router C has a 192.168.56.0 subnet that is shared with Router B via BGP. Router B wants to share this with Router A via ISIS, but when I use the redistribute bpg command the route does not get added to the isis routes, and never shows on Router A.

I am not sure what I am doing wrong here.

Configuration for Router A (running IOS):

! trimmed, several interfaces with `ip router isis`
router isis
 net 49.0000.0000.0000.0000.00

configuration for Router B (running IOS XR):

router isis 1
 net 49.0000.1111.0000.0000.00
 distribute bgp-ls
 address-family ipv4 unicast
  redistribute bgp 65000 level-1
 !
 interface GigabitEthernet0/0/0/0
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/0/0/1
  address-family ipv4 unicast
  !
 !
!
router bgp 65000
 bgp router-id 10.255.0.101
 address-family ipv4 unicast
  redistribute isis 1
 !
 neighbor 10.100.0.1
  remote-as 65000
  address-family ipv4 unicast

Configuration for Router C (running IOS XR):

router bgp 65000
 bgp router-id 192.168.56.200
 address-family ipv4 unicast
  network 192.168.56.0/24
 !
 neighbor 10.100.0.2
  remote-as 65000
  address-family ipv4 unicast
  !
 !

On Router C running show route bgp lists all of the routes from ISIS on A and B.
On Router B running show route isis shows all of the ISIS provided routes I expect, and running show route bgp shows the 192.168.56.0 route that I expect from C
On Router A the 192.168.56.0 route does not exist.

4

By default redistribution of IBGP into an IGP is disabled. To redistribute IBGP routes into an IGP, you need the command bgp redistribute-internal. Configuring this on B will inject BGP routes into ISIS.

router bgp 65000
 bgp redistribute-internal

More info here:https://www.cisco.com/c/en/us/td/docs/routers/xr12000/software/xr12k_r3-9/routing/configuration/guide/xr12krc39_chapter1.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.