2

In the following configuration, INTERNAL1 and INTERNAL4 are RR and INTERNAL2 and INTERNAL3 are clients. I am not able to see the routes 20.1.1.0 and 10.1.1.0 on INTERNAL3 and 30.1.1.0 and 40.1.1.0 on INTERNAL2. 10.1.1.0 is connected to fa0/0 of ISP1, 20.1.1.0 is connected to fa0/0 of ISP2, 30.1.1.0 is connected to fa0/0 of ISP3 and 40.1.1.0 is connected to fa0/0 of ISP4. I am not able to under why RR is not advertising routes further to the other side from INTERNAL2 to INTERNAL3 and vice versa?TOPOLOGY

INTERNAL2(config)#do sh ip route
Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets
B       20.1.1.0 [20/0] via 112.1.1.2, 00:06:58
     112.0.0.0/24 is subnetted, 1 subnets
C       112.1.1.0 is directly connected, FastEthernet0/1
     110.0.0.0/24 is subnetted, 1 subnets
C       110.1.1.0 is directly connected, FastEthernet0/0
     111.0.0.0/24 is subnetted, 1 subnets
C       111.1.1.0 is directly connected, FastEthernet2/0
     10.0.0.0/24 is subnetted, 1 subnets
B       10.1.1.0 [20/0] via 111.1.1.1, 00:06:58
     150.1.0.0/24 is subnetted, 1 subnets
B       150.1.1.0 [200/0] via 110.1.1.1, 00:07:00
     120.0.0.0/24 is subnetted, 1 subnets
C       120.1.1.0 is directly connected, FastEthernet1/0

INTERNAL3(config)#do sh ip route
Gateway of last resort is not set

     140.1.0.0/24 is subnetted, 1 subnets
C       140.1.1.0 is directly connected, FastEthernet0/1
     114.0.0.0/24 is subnetted, 1 subnets
C       114.1.1.0 is directly connected, FastEthernet1/0
     113.0.0.0/24 is subnetted, 1 subnets
C       113.1.1.0 is directly connected, FastEthernet2/0
     130.1.0.0/24 is subnetted, 1 subnets
C       130.1.1.0 is directly connected, FastEthernet0/0
     40.0.0.0/24 is subnetted, 1 subnets
B       40.1.1.0 [20/0] via 114.1.1.2, 00:06:36
     150.1.0.0/24 is subnetted, 1 subnets
B       150.1.1.0 [200/0] via 130.1.1.1, 00:06:38
     30.0.0.0/24 is subnetted, 1 subnets
B       30.1.1.0 [20/0] via 113.1.1.1, 00:06:40


   INTERNAL4(config)#do sh ip route
    Gateway of last resort is not set

         140.1.0.0/24 is subnetted, 1 subnets
    C       140.1.1.0 is directly connected, FastEthernet0/1
         114.0.0.0/24 is subnetted, 1 subnets
    B       114.1.1.0 [200/0] via 140.1.1.1, 00:12:39
         20.0.0.0/24 is subnetted, 1 subnets
    B       20.1.1.0 [200/0] via 112.1.1.2, 00:12:33

         40.0.0.0/24 is subnetted, 1 subnets
    B       40.1.1.0 [200/0] via 114.1.1.2, 00:12:41
         10.0.0.0/24 is subnetted, 1 subnets
    B       10.1.1.0 [200/0] via 111.1.1.1, 00:12:39

         30.0.0.0/24 is subnetted, 1 subnets
    B       30.1.1.0 [200/0] via 113.1.1.1, 00:12:36

[ONLY RELEVANT CONFIGURATION DISPLAYED FOR INTERNAL4]

INTERNAL2#sh run | s bgp
router bgp 64100
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 110.1.1.1 remote-as 64100
 neighbor 111.1.1.1 remote-as 64001
 neighbor 112.1.1.2 remote-as 64002
 neighbor 120.1.1.2 remote-as 64100
 !
 address-family ipv4
  neighbor 110.1.1.1 activate
  neighbor 111.1.1.1 activate
  neighbor 112.1.1.2 activate
  neighbor 120.1.1.2 activate
  no auto-summary
  no synchronization
  network 110.1.1.0 mask 255.255.255.0
  network 111.1.1.0 mask 255.255.255.0
  network 112.1.1.0 mask 255.255.255.0
  network 120.1.1.0 mask 255.255.255.0
 exit-address-family

INTERNAL4#sh run | s bgp
router bgp 64100
 no bgp default ipv4-unicast
 bgp cluster-id 64100
 bgp log-neighbor-changes
 neighbor 120.1.1.1 remote-as 64100
 neighbor 140.1.1.1 remote-as 64100
 neighbor 150.1.1.1 remote-as 64100
 !
 address-family ipv4
  neighbor 120.1.1.1 activate
  neighbor 120.1.1.1 route-reflector-client
  neighbor 140.1.1.1 activate
  neighbor 140.1.1.1 route-reflector-client
  neighbor 150.1.1.1 activate
  no auto-summary
  no synchronization
  network 10.1.1.0 mask 255.255.255.0
  network 20.1.1.0 mask 255.255.255.0
  network 150.1.1.0 mask 255.255.255.0
 exit-address-family

INTERNAL1#sh run | s bgp
router bgp 64100
 no bgp default ipv4-unicast
 bgp cluster-id 64100
 bgp log-neighbor-changes
 neighbor 110.1.1.2 remote-as 64100
 neighbor 130.1.1.2 remote-as 64100
 neighbor 150.1.1.2 remote-as 64100
 !
 address-family ipv4
  neighbor 110.1.1.2 activate
  neighbor 110.1.1.2 route-reflector-client
  neighbor 130.1.1.2 activate
  neighbor 130.1.1.2 route-reflector-client
  neighbor 150.1.1.2 activate
  no auto-summary
  no synchronization
  network 150.1.1.0 mask 255.255.255.0
 exit-address-family

INTERNAL3#sh run | s bgp
router bgp 64100
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 113.1.1.1 remote-as 64003
 neighbor 114.1.1.2 remote-as 64004
 neighbor 130.1.1.1 remote-as 64100
 neighbor 140.1.1.2 remote-as 64100
 !
 address-family ipv4
  neighbor 113.1.1.1 activate
  neighbor 114.1.1.2 activate
  neighbor 130.1.1.1 activate
  neighbor 140.1.1.2 activate
  no auto-summary
  no synchronization
  network 113.1.1.0 mask 255.255.255.0
  network 114.1.1.0 mask 255.255.255.0
  network 130.1.1.0 mask 255.255.255.0
  network 140.1.1.0 mask 255.255.255.0
 exit-address-family
  • I suggest you add to your post the BGP configuration for involved routers. There are several rules governing route-reflection. Make sure you haven't disabled client-to-client reflection and don't have conflicting RR cluster-ids (or if you do, that you understand why.) Be sure that the next-hops of your routes are reachable via your IGP as well. That is a common error that's not caused by your RR configuration; it would be apparent even if you had a normal IBGP session from, for example, INTERNAL2 to INTERNAL3. In fact, temporarily adding such a session is a good troubleshooting step. – Jeff Wheeler May 12 '20 at 23:53
  • @JeffWheeler I have added the configurations. I am running iBGP between INTERNAL1, 2, 3 and 4. – MUSR May 13 '20 at 0:05
  • seconding what Jeff pointed out - what NLRI's are the client routers using and are they reachable to one another? I'd confirm that the BGP routes are received and valid on the RR's and then look to see if they are received but invalid on the client routers. – rnxrx May 13 '20 at 0:29
  • @rnxrx So I am not able to see any received routes, that means they are becoming invalid, but why? There are no filters applied on any router, neither for inbound nor for outbound INTERNAL3#sh ip bgp nei 140.1.1.2 received-routes % Inbound soft reconfiguration not enabled on 140.1.1.2 – MUSR May 13 '20 at 1:25
  • 1
    I'd start there. If you remove the RR client configuration then you're just looking at a pair of iBGP peers. We're not seeing the rest of the configuration, but if you're not able to get the route advertised across that basic peering relationship then setting up the RR isn't going to help. – rnxrx May 13 '20 at 1:59
0

Double-check that the next-hops of your routes are reachable via your IGP. This is probably what's wrong.

If router A has a route 192.0.2.0/24 -> 203.0.113.1 and announces this route to router B but router B does not know how to reach 203.0.113.1 it will not install the 192.0.2.0/24 route.

Do you have something like OSPF or IS-IS configured to serve as your IGP? If so, try 1) adding the ISP4 fa0/0 interface as a passive interface to your OSPF config, or 2) use next-hop-self to rewrite the BGP next-hop to the loopback address of INTERNAL3 as you propagate it to IBGP neighbors.

If you didn't configure an IGP, you need one. BGP is not meant to work inside an AS without an IGP such as OSPF or IS-IS.

  • 2
    Thanks for the answer Jeff. I got your point. Exactly that was the issue. I resolved it. – MUSR May 15 '20 at 1:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.