1

Ok, so I've been toying with veth links for my Cisco routers and they have been working fine. However when you throw in a virtual switch like the Cisco nx-osv or vios l2 image, using veth interfaces don't seem to allow traffic.

I can see them in virt manager and I've tried changing mode from bridge to private but nothing works.

This leads me to believe that veth links don't like traffic coming from or two Cisco virtual switches.

Has anyone got any ideas about why this would be the case

Basically it looks like this the connection:

[CSR1-vm]-VETH:PORT1--VETH:PORT2-[CSR2-vm] - this works. Using the sudo ip add PORT1 type veth peer name PORT2

However, when I do this:

[CSR1-vm]-PORT1--PORT2-[NX-OSv]-PORT3--PORT4-[CSR2-vm]

The connection doesnt work between CSR1 and 2 So its either some setting with veth or something with the nx-os preventing it I know the nxos works as I've tried it in gns3, however, I want to implement it in qemu/kvm as allows me greater flexibility. (particularly for spanning tree)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.