0

Within GNS3, I am attempting to configure five Cisco 3660 routers in a ring topology with EIGRP, as an early exercise to try and learn how to use EIGRP:

network topology (original)

These routers and virtual PCs are configured per the following table. All networks are /24: ip config

In addition to the IPs, every router interface has the following options:

no shut
bandwidth 1000

Each router also has the following EIGRP configuration entered:

router eigrp 1
network <network of e1/0, ending in .0>
network <network of e1/1, ending in .0>
network <network of f0/0, ending in .0>
no auto-summary

No other configuration options have been modified from defaults. Routers are running software C3660-IK9O3S-M 12.4(13b)

Currently I am observing that any (trace)route will not use the link between R5 and R1 (e.g. a route from PC5 -> PC1 goes via R5 -> R4 -> R3 -> R2 -> R1 rather than R5 -> R1). Additionally, removal of any link along this path (e.g. the link between R3 and R4) will cause R5 to report destination host unreachable when pinging PC1 from PC5. I have confirmed that all interfaces on all routers have the correct IP and are up.

I would expect that in this current configuration, routes would choose the path with the least hops, given all bandwidths are equal, and that in the event of a link failure between two adjacent routers, the traffic would flow the opposite way around the ring.

Further investigation suggests that R5 does not know about any routes on its E1/0 interface, except for the directly connected 192.168.5.0/24 network:

R5#sho ip eigrp top all
IP-EIGRP Topology Table for AS(1)/ID(192.168.50.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 192.168.40.0/24, 1 successors, FD is 2588160, serno 5
        via 192.168.4.1 (2588160/2562560), Ethernet1/0
P 192.168.50.0/24, 1 successors, FD is 2562560, serno 3
        via Connected, FastEthernet0/0
P 192.168.10.0/24, 1 successors, FD is 2664960, serno 30
        via 192.168.4.1 (2664960/2639360), Ethernet1/0
P 192.168.1.0/24, 1 successors, FD is 2662400, serno 28
        via 192.168.4.1 (2662400/2636800), Ethernet1/0
P 192.168.2.0/24, 1 successors, FD is 2636800, serno 26
        via 192.168.4.1 (2636800/2611200), Ethernet1/0
P 192.168.3.0/24, 1 successors, FD is 2611200, serno 4
        via 192.168.4.1 (2611200/2585600), Ethernet1/0
P 192.168.4.0/24, 1 successors, FD is 2585600, serno 1
        via Connected, Ethernet1/0
P 192.168.5.0/24, 1 successors, FD is 2585600, serno 2
        via Connected, Ethernet1/1
P 192.168.30.0/24, 1 successors, FD is 2613760, serno 27
        via 192.168.4.1 (2613760/2588160), Ethernet1/0

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 192.168.20.0/24, 1 successors, FD is 2639360, serno 29
        via 192.168.4.1 (2639360/2613760), Ethernet1/0
R5#sho ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D    192.168.30.0/24 [90/2613760] via 192.168.4.1, 00:49:53, Ethernet1/0
D    192.168.10.0/24 [90/2664960] via 192.168.4.1, 00:49:53, Ethernet1/0
D    192.168.40.0/24 [90/2588160] via 192.168.4.1, 01:01:11, Ethernet1/0
C    192.168.4.0/24 is directly connected, Ethernet1/0
D    192.168.20.0/24 [90/2639360] via 192.168.4.1, 00:49:53, Ethernet1/0
C    192.168.5.0/24 is directly connected, Ethernet1/1
C    192.168.50.0/24 is directly connected, FastEthernet0/0
D    192.168.1.0/24 [90/2662400] via 192.168.4.1, 00:49:56, Ethernet1/0
D    192.168.2.0/24 [90/2636800] via 192.168.4.1, 00:49:56, Ethernet1/0
D    192.168.3.0/24 [90/2611200] via 192.168.4.1, 01:01:14, Ethernet1/0

Is my expectation of this EIGRP configuration possible? If not, why not? What technique/technology should I look at instead? If so, what could be wrong, and what steps can I take to effectively troubleshoot this?

References so far:

UPDATE: As part of my experimentation, I have updated the router topology. This is the new toplogy being used with the config files below: network toplogy (updated)

Router configurations (including the additional link from R2/e1/2 to R4/e1/2 and associated EIGRP config):

R1:

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
ip cef
no ip domain lookup
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
 bandwidth 1000
 ip address 192.168.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Ethernet1/0
 bandwidth 1000
 ip address 192.168.5.2 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 bandwidth 1000
 ip address 192.168.1.1 255.255.255.0
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.10.0
 no auto-summary
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
end

R2:

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
ip cef
no ip domain lookup
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
 bandwidth 1000
 ip address 192.168.20.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Ethernet1/0
 bandwidth 1000
 ip address 192.168.1.2 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 bandwidth 1000
 ip address 192.168.2.1 255.255.255.0
 half-duplex
!
interface Ethernet1/2
 bandwidth 1000
 ip address 192.168.100.1 255.255.255.0
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.20.0
 network 192.168.100.0
 no auto-summary
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
end

R3:

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
 bandwidth 1000
 ip address 192.168.30.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Ethernet1/0
 bandwidth 1000
 ip address 192.168.2.2 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 bandwidth 1000
 ip address 192.168.3.1 255.255.255.0
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 network 192.168.2.0
 network 192.168.3.0
 network 192.168.30.0
 no auto-summary
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
end

R4:

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
ip cef
no ip domain lookup
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
 bandwidth 1000
 ip address 192.168.40.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Ethernet1/0
 bandwidth 1000
 ip address 192.168.3.2 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 bandwidth 1000
 ip address 192.168.4.1 255.255.255.0
 half-duplex
!
interface Ethernet1/2
 bandwidth 1000
 ip address 192.168.100.2 255.255.255.0
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 network 192.168.3.0
 network 192.168.4.0
 network 192.168.40.0
 network 192.168.100.0
 no auto-summary
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
end

R5:

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
ip cef
no ip domain lookup
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
 bandwidth 1000
 ip address 192.168.50.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Ethernet1/0
 bandwidth 1000
 ip address 192.168.4.2 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 bandwidth 1000
 ip address 192.168.5.1 255.255.255.0
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 network 192.168.4.0
 network 192.168.5.0
 network 192.168.50.0
 no auto-summary
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
end

R1 CDP and EIGRP neighbours:

R1#show cdp nei det
-------------------------
Device ID: R2
Entry address(es):
  IP address: 192.168.1.2
Platform: Cisco 3660,  Capabilities: Router Switch IGMP
Interface: Ethernet1/1,  Port ID (outgoing port): Ethernet1/0
Holdtime : 146 sec

Version :
Cisco IOS Software, 3600 Software (C3660-IK9O3S-M), Version 12.4(13b), RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Tue 24-Apr-07 21:18 by prod_rel_team

advertisement version: 2
VTP Management Domain: ''
Duplex: half

-------------------------
Device ID: R5
Entry address(es):
  IP address: 192.168.5.1
Platform: Cisco 3660,  Capabilities: Router Switch IGMP
Interface: Ethernet1/0,  Port ID (outgoing port): Ethernet1/1
Holdtime : 135 sec

Version :
Cisco IOS Software, 3600 Software (C3660-IK9O3S-M), Version 12.4(13b), RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Tue 24-Apr-07 21:18 by prod_rel_team

advertisement version: 2
VTP Management Domain: ''
Duplex: half

R1#sho ip eigrp neighbors detail
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.1.2             Et1/1             14 02:08:10   58   783  0  42
   Version 12.4/1.2, Retrans: 9, Retries: 0, Prefixes: 9
R1#sho ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.1.2             Et1/1             11 02:08:18   58   783  0  42

R2 CDP and EIGRP neighbours:

R2#   sho cdp nei det
-------------------------
Device ID: R3
Entry address(es):
  IP address: 192.168.2.2
Platform: Cisco 3660,  Capabilities: Router Switch IGMP
Interface: Ethernet1/1,  Port ID (outgoing port): Ethernet1/0
Holdtime : 135 sec

Version :
Cisco IOS Software, 3600 Software (C3660-IK9O3S-M), Version 12.4(13b), RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Tue 24-Apr-07 21:18 by prod_rel_team

advertisement version: 2
VTP Management Domain: ''
Duplex: half

-------------------------
Device ID: R1
Entry address(es):
  IP address: 192.168.1.1
Platform: Cisco 3660,  Capabilities: Router Switch IGMP
Interface: Ethernet1/0,  Port ID (outgoing port): Ethernet1/1
Holdtime : 119 sec

Version :
Cisco IOS Software, 3600 Software (C3660-IK9O3S-M), Version 12.4(13b), RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Tue 24-Apr-07 21:18 by prod_rel_team

advertisement version: 2
VTP Management Domain: ''
Duplex: half

-------------------------
Device ID: R4
Entry address(es):
  IP address: 192.168.100.2
Platform: Cisco 3660,  Capabilities: Router Switch IGMP
Interface: Ethernet1/2,  Port ID (outgoing port): Ethernet1/2
Holdtime : 158 sec

Version :
Cisco IOS Software, 3600 Software (C3660-IK9O3S-M), Version 12.4(13b), RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Tue 24-Apr-07 21:18 by prod_rel_team

advertisement version: 2
VTP Management Domain: ''
Duplex: half

R2#sho ip eig nei det
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
2   192.168.100.2           Et1/2             13 01:14:45   16   200  0  31
   Version 12.4/1.2, Retrans: 1, Retries: 0, Prefixes: 6
1   192.168.1.1             Et1/0             13 02:10:28   26   200  0  14
   Version 12.4/1.2, Retrans: 2, Retries: 0, Prefixes: 1
0   192.168.2.2             Et1/1             11 02:10:28   28   200  0  22
   Version 12.4/1.2, Retrans: 2, Retries: 0, Prefixes: 6

R3 CDP and EIGRP neighbours:

R3#   sho cdp nei det
-------------------------
Device ID: R2
Entry address(es):
  IP address: 192.168.2.1
Platform: Cisco 3660,  Capabilities: Router Switch IGMP
Interface: Ethernet1/0,  Port ID (outgoing port): Ethernet1/1
Holdtime : 161 sec

Version :
Cisco IOS Software, 3600 Software (C3660-IK9O3S-M), Version 12.4(13b), RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Tue 24-Apr-07 21:18 by prod_rel_team

advertisement version: 2
VTP Management Domain: ''
Duplex: half

-------------------------
Device ID: R4
Entry address(es):
  IP address: 192.168.3.2
Platform: Cisco 3660,  Capabilities: Router Switch IGMP
Interface: Ethernet1/1,  Port ID (outgoing port): Ethernet1/0
Holdtime : 0 sec

Version :
Cisco IOS Software, 3600 Software (C3660-IK9O3S-M), Version 12.4(13b), RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Tue 24-Apr-07 21:18 by prod_rel_team

advertisement version: 2
VTP Management Domain: ''
Duplex: half

R3#sho ip eig nei det
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   192.168.3.2             Et1/1             10 01:25:21  374  2244  0  33
   Version 12.4/1.2, Retrans: 0, Retries: 0, Prefixes: 8
0   192.168.2.1             Et1/0             13 02:09:05   74   444  0  41
   Version 12.4/1.2, Retrans: 2, Retries: 0, Prefixes: 8

R4 CDP and EIGRP neighbours:

R4#sho cdp nei det
-------------------------
Device ID: R2
Entry address(es):
  IP address: 192.168.100.1
Platform: Cisco 3660,  Capabilities: Router Switch IGMP
Interface: Ethernet1/2,  Port ID (outgoing port): Ethernet1/2
Holdtime : 137 sec

Version :
Cisco IOS Software, 3600 Software (C3660-IK9O3S-M), Version 12.4(13b), RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Tue 24-Apr-07 21:18 by prod_rel_team

advertisement version: 2
VTP Management Domain: ''
Duplex: half

-------------------------
Device ID: R3
Entry address(es):
  IP address: 192.168.3.1
Platform: Cisco 3660,  Capabilities: Router Switch IGMP
Interface: Ethernet1/0,  Port ID (outgoing port): Ethernet1/1
Holdtime : 121 sec

Version :
Cisco IOS Software, 3600 Software (C3660-IK9O3S-M), Version 12.4(13b), RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Tue 24-Apr-07 21:18 by prod_rel_team

advertisement version: 2
VTP Management Domain: ''
Duplex: half

-------------------------
Device ID: R5
Entry address(es):
  IP address: 192.168.4.2
Platform: Cisco 3660,  Capabilities: Router Switch IGMP
Interface: Ethernet1/1,  Port ID (outgoing port): Ethernet1/0
Holdtime : 149 sec

Version :
Cisco IOS Software, 3600 Software (C3660-IK9O3S-M), Version 12.4(13b), RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Tue 24-Apr-07 21:18 by prod_rel_team

advertisement version: 2
VTP Management Domain: ''
Duplex: half

R4#sho ip eig nei det
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
2   192.168.100.1           Et1/2             10 01:16:06 1033  5000  0  43
   Version 12.4/1.2, Retrans: 0, Retries: 0, Prefixes: 5
1   192.168.3.1             Et1/0             14 01:27:32   26   200  0  23
   Version 12.4/1.2, Retrans: 1, Retries: 0, Prefixes: 5
0   192.168.4.2             Et1/1             12 02:10:36   24   200  0  12
   Version 12.4/1.2, Retrans: 1, Retries: 0, Prefixes: 2

R5 CDP and EIGRP neighbours:

R5#sho cdp nei det
-------------------------
Device ID: R1
Entry address(es):
  IP address: 192.168.5.2
Platform: Cisco 3660,  Capabilities: Router Switch IGMP
Interface: Ethernet1/1,  Port ID (outgoing port): Ethernet1/0
Holdtime : 120 sec

Version :
Cisco IOS Software, 3600 Software (C3660-IK9O3S-M), Version 12.4(13b), RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Tue 24-Apr-07 21:18 by prod_rel_team

advertisement version: 2
VTP Management Domain: ''
Duplex: half

-------------------------
Device ID: R4
Entry address(es):
  IP address: 192.168.4.1
Platform: Cisco 3660,  Capabilities: Router Switch IGMP
Interface: Ethernet1/0,  Port ID (outgoing port): Ethernet1/1
Holdtime : 123 sec

Version :
Cisco IOS Software, 3600 Software (C3660-IK9O3S-M), Version 12.4(13b), RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Tue 24-Apr-07 21:18 by prod_rel_team

advertisement version: 2
VTP Management Domain: ''
Duplex: half

R5#sho ip eig nei det
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.4.1             Et1/0             13 03:06:46   68   918  0  32
   Version 12.4/1.2, Retrans: 5, Retries: 0, Prefixes: 8
  • As a quick check, type show ip eigrp neighbors on each router. Each one should have two neighbors – Ron Trunk Jun 30 at 1:51
  • @RonTrunk I can see that R1 and R5 do not recognise each other as neighbours (R2 - R4 have two neighbours each), but I cannot work out why. Does EIGRP automatically detect this loop setup as invalid and ignore these neighbours? If so, how can it be insructed to accept (and utilise) this setup? – toxicantidote Jun 30 at 2:03
  • As an experiment, I have tried adding a link between e1/2 on R2 and R4 with IPs 192.168.100.1 and 192.168.100.2 respectively, and adding the 192.168.100.0 network to EIGRP on both routers. Running a traceroute from R1 to R5 now skips R3, using the new link. Shutting down e1/2 on R2 will cause this trace to route via R3 automatically (i.e. backup link). – toxicantidote Jun 30 at 2:15
  • 1
    You have a misconfiguration on R1 or R5. They should be neighbors. If you post the configurations we can see what that is. – Ron Trunk Jun 30 at 2:20
  • 1
    One more thing is to run the show cdp neighbor on each router. – Ron Maupin Jun 30 at 3:08
1

I see a problem in your configuration that would explain your problem.

R1 does not have EIGRP enabled on Eth 1/0. To add it:

router eigrp 1
network 192.168.5.0

Since reloading GNS3 seemed to fix it, I suspect you changed the config at some point but didn't save it.

| improve this answer | |
  • This actually seems like the more likely scenario, given those dumps are from 'sho run' on each router. Good eyes, thanks. – toxicantidote Jun 30 at 22:13
1

Deleting and recreating R1 and R5 using the config files posted above has resolved the issue. Route selection and failover behaviour from each node is as expected, with routes taking the least number of hops, and routing around missing links when they occur.

This appears to have been an unusual GNS3 glitch.

| improve this answer | |
  • Well, at least you got some practice at troubleshooting. Please accept your answer when you can so that the question does not keep popping up forever, looking for an answer. – Ron Maupin Jun 30 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.