-1

I have a lab where I'm connecting a Cisco CSR1000V and a Nexus 9000 switch. These devices are connected back to back. Relevant configuration is:

Router:

interface Port-channel1
mtu 9216
!
interface Port-channel1.1000
encapsulation dot1Q 1000
 ip address 10.1.1.2 255.255.255.128
vrrp 1 ip 10.1.1.1
vrrp 1 priority 150
vrrp 1 track 1 decrement 70
!
interface GigabitEthernet2
mtu 9216
no ip address
speed 1000
channel-group 1
!

Nexus 9K:

interface Vlan1000
ip address 10.1.1.4/25
!
interface port-channel1
switchport mode trunk
mtu 2916
spanning-tree port type normal
!
ip route 0.0.0.0/0 10.1.1.1
!
interface Ethernet1/1
switchport mode trunk
mtu 2916
channel-group 1
!

Connection is between router G2 and Nexus E1/1. Problem is, they can't talk to each other. The Router is master in vrrp status. Interfaces look good:

Router

Port Channel 1:

Router Port channel 1

The Nexus switch shows the same interface status:

E1/1:

Nexus E1/1

Port Channel 1:

Nexus po1

So, all looks up but can't ping switch from router:

CSR-2.rt#ping 10.1.1.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.4, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

At this point I can't tell if the issue is on the CSR or in the Nexus switch. Any help would be appreciated.

Thanks.

5
  • 1
    Please, never use images for text. Simply copy the text and paste it into the question using the Preformatted-text option ({}). Also, you cannot connect a layer-3 port channel to a layer-2 port channel, and VRRP is pointless with a single router.
    – Ron Maupin
    Jul 1 '20 at 23:05
  • 1
    Have you created VLAN 1000 on the Nexus? Type show spanning-tree vlan 1000
    – Ron Trunk
    Jul 2 '20 at 12:16
  • I'd start by correcting your interface-to-port-channel configurations. Your screenshots indicate each side of the port-channel has two members, but your config pastes show only one. Additionally, your CSR1000V side has traffic but N9K has no traffic. Without knowing more, we cannot rule out a cabling mistake. Enabling LLDP and LACP, and verifying the connectivity between devices, would be good next steps. Jul 2 '20 at 14:08
  • -1 for the screenshot images
    – Zac67
    Jul 3 '20 at 17:23
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can post and accept your own answer.
    – Ron Maupin
    Dec 16 '20 at 23:22
0

Thank you all for your comments. The original topology has two routers and two Nexus switches where I wanted to enable features like VRRP on the L3 level and vPC on L2 among others. However, as issues on both layers started piling up, I downsized features and connections until I came with the a poin-to-point issue that triggered this post.

But as Jeff noted, the Po1 had two members because I forgot to shutdown the connection to the second Nexus switch, so once I turned it down pings were successful.

At this point I guess it's time for me to go back to the drawing board and review all settings. But now I had connectivity between the router and the switch.

Thanks again!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.