0

Morning:

I'm new to the world of Cisco Packet tracer, and I am creating a network for a uni project. So far, what I have is:

5 VLANs (subnetted to 192.168.2.0/26, 192.168.3.0/36 etc)

All are connected to ports Gig 1/0/2 - 1/0/6 on a 3650 switch

The end devices are able to communicate with all the respective VLANs accordingly.

The VLANs all terminate at the switch and (I believed) trunked to port 1/0/24 which has an IP 192.168.40.1/30. Port 1/0/24 is then connected to a port on a generic PT router on port 9/0 with IP 192.168.40.2, which is also the default IP Router (Gateway of Last Resort).

From there, the router is connected to another router, both of which are in a subnet of 192.168.50.0/30 and then that router is connected to another 3650 switch on a subnet of 192.168.60.0/30.

The routers and switches can ping each other without an issue. I have set up routing by using EIGRP.

The issue that I seem to have is that no matter what I try, I cannot get the end devices' packets to go any further than the trunked port. Example ping results below:

Pinging the switch:

C:>ping 192.168.40.1 Pinging 192.168.40.1 with 32 bytes of data:

Reply from 192.168.40.1: bytes=32 time=11ms TTL=255 Reply from 192.168.40.1: bytes=32 time=35ms TTL=255 Reply from 192.168.40.1: bytes=32 time=30ms TTL=255 Reply from 192.168.40.1: bytes=32 time=36ms TTL=255

Pinging the router

C:>ping 192.168.40.2

Pinging 192.168.40.2 with 32 bytes of data:

Request timed out. Request timed out. Request timed out. Request timed out.

Switch#show protocols

Global values:

  Internet Protocol routing is enabled

GigabitEthernet1/0/2 is up, line protocol is up

GigabitEthernet1/0/3 is up, line protocol is up

GigabitEthernet1/0/4 is up, line protocol is up

GigabitEthernet1/0/5 is up, line protocol is up

GigabitEthernet1/0/6 is up, line protocol is up

GigabitEthernet1/0/24 is up, line protocol is up

  Internet address is 192.168.40.1/30

Vlan2 is up, line protocol is up

  Internet address is 192.168.2.62/26

Vlan3 is up, line protocol is up

  Internet address is 192.168.3.62/26

Vlan4 is up, line protocol is up

  Internet address is 192.168.4.62/26

Vlan5 is up, line protocol is up

  Internet address is 192.168.5.62/26

Vlan6 is up, line protocol is up

  Internet address is 192.168.6.62/26

Running Config (Sanitised-ish)

Switch#show running-config
Building configuration...

Current configuration : 2815 bytes
!
version 16.3.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch!
!
ip dhcp excluded-address 192.168.2.1 192.168.2.10
ip dhcp excluded-address 192.168.3.1 192.168.3.10
ip dhcp excluded-address 192.168.4.1 192.168.4.10
ip dhcp excluded-address 192.168.5.1 192.168.5.10
ip dhcp excluded-address 192.168.6.1 192.168.6.10
!
ip dhcp pool vlan2
 network 192.168.2.0 255.255.255.192
 default-router 192.168.2.62
 dns-server 8.8.8.8
ip dhcp pool vlan3
 network 192.168.3.0 255.255.255.192
 default-router 192.168.3.62
 dns-server 8.8.8.8
ip dhcp pool vlan4
 network 192.168.4.0 255.255.255.192
 default-router 192.168.4.62
 dns-server 8.8.8.8
ip dhcp pool vlan5
 network 192.168.5.0 255.255.255.192
 default-router 192.168.5.62
 dns-server 8.8.8.8
ip dhcp pool vlan6
 network 192.168.6.0 255.255.255.192
 default-router 192.168.6.62
 dns-server 8.8.8.8!
!
ip cef
ip routing
!
no ipv6 cef!
!
spanning-tree mode pvst!
!
interface GigabitEthernet1/0/2
 switchport access vlan 2
!
interface GigabitEthernet1/0/3
 switchport access vlan 3
!
interface GigabitEthernet1/0/4
 switchport access vlan 4
!
interface GigabitEthernet1/0/5
 switchport access vlan 5
!
interface GigabitEthernet1/0/6
 switchport access vlan 6
!
interface GigabitEthernet1/0/24
 no switchport
 ip address 192.168.40.1 255.255.255.252
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 mac-address 0004.9aa1.d701
 ip address 192.168.2.62 255.255.255.192
!
interface Vlan3
 mac-address 0004.9aa1.d702
 ip address 192.168.3.62 255.255.255.192
!
interface Vlan4
 mac-address 0004.9aa1.d703
 ip address 192.168.4.62 255.255.255.192
!
interface Vlan5
 mac-address 0004.9aa1.d704
 ip address 192.168.5.62 255.255.255.192
!
interface Vlan6
 mac-address 0004.9aa1.d705
 ip address 192.168.6.62 255.255.255.192
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.40.2 
!
ip flow-export version 9

!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

Router 1 Configuration (Sanitised)

Router#show running-config 
Building configuration...

Current configuration : 707 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
no ip cef
no ipv6 cef

!
interface GigabitEthernet8/0
 ip address 192.168.50.1 255.255.255.252
!
interface GigabitEthernet9/0
 ip address 192.168.40.2 255.255.255.252
 duplex auto
 speed auto
!
router eigrp 10
 network 192.168.40.0 0.0.0.3
 network 192.168.50.0 0.0.0.3
 auto-summary
!
router ospf 1
 log-adjacency-changes
 network 192.168.40.0 0.0.0.3 area 0
 network 192.168.50.0 0.0.0.3 area 0
!
ip classless
!
ip flow-export version 9!
!
line con 0
!
line aux 0
!
line vty 0 4
 login!
!
end

IP Routing

Switch#show ip rout
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.40.2 to network 0.0.0.0

     192.168.2.0/26 is subnetted, 1 subnets
C       192.168.2.0 is directly connected, Vlan2
     192.168.3.0/26 is subnetted, 1 subnets
C       192.168.3.0 is directly connected, Vlan3
     192.168.4.0/26 is subnetted, 1 subnets
C       192.168.4.0 is directly connected, Vlan4
     192.168.5.0/26 is subnetted, 1 subnets
C       192.168.5.0 is directly connected, Vlan5
     192.168.6.0/26 is subnetted, 1 subnets
C       192.168.6.0 is directly connected, Vlan6
     192.168.40.0/30 is subnetted, 1 subnets
C       192.168.40.0 is directly connected, GigabitEthernet1/0/24
D    192.168.50.0/24 [90/3072] via 192.168.40.2, 00:13:12, GigabitEthernet1/0/24
D    192.168.60.0/24 [90/3328] via 192.168.40.2, 00:13:12, GigabitEthernet1/0/24
S*   0.0.0.0/0 [1/0] via 192.168.40.2

Based upon further research, I did the following:

Switch>show interfaces gigabitEthernet 1/0/23 switchport 
Name: Gig1/0/23
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: down
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 100 (Inactive)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: 2-6
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Appliance trust: none
Router#show running-config 
Building configuration...

Current configuration : 978 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
no ip cef
no ipv6 cef
!
interface GigabitEthernet8/0
 ip address 192.168.50.1 255.255.255.252
!
interface GigabitEthernet9/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet9/0.1
 encapsulation dot1Q 1 native
 ip address 192.168.2.62 255.255.255.192
!
interface GigabitEthernet9/0.2
 encapsulation dot1Q 2
 ip address 192.168.3.62 255.255.255.192
!
interface GigabitEthernet9/0.3
 encapsulation dot1Q 3
 ip address 192.168.4.62 255.255.255.192
!
interface GigabitEthernet9/0.4
 encapsulation dot1Q 4
 ip address 192.168.5.62 255.255.255.192
!
interface GigabitEthernet9/0.5
 encapsulation dot1Q 5
 ip address 192.168.6.62 255.255.255.192
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

I feel like I am so close to cracking this, but the link from 1/0/23 to 9/0 is still down, and I'm unsure how to bring it up to test it.

13
  • You'll need to add the (sanitized) switch config to your question, else we can't see how things are set up.
    – Zac67
    Jul 2, 2020 at 9:40
  • I've added the running configs of the switch, and the router connected directly to the switch.
    – LordVader
    Jul 2, 2020 at 9:51
  • You did not enable routing on the switch.
    – Ron Maupin
    Jul 2, 2020 at 9:54
  • Really? I could have sworn that I did.
    – LordVader
    Jul 2, 2020 at 10:02
  • 1
    You also need the router to know about the networks on the other side of the switch, either with static routes, or through a routing protocol.
    – Ron Maupin
    Jul 2, 2020 at 11:01

1 Answer 1

1

You do not have EIGRP enabled on your (layer 3) switch, so the router and other devices don't know how to reach the networks on the switch.

And BTW, you are not trunking VLANs. The VLANs terminate on the switch. Port 1/0/24 is a routed interface, not a trunk port.

8
  • Hi Ron... I have now enabled EIGRP on the switch, but that has not resolved the issue. So I guess the next stage is to change 1/0/24 from a routed interface into a trunk port?
    – LordVader
    Jul 2, 2020 at 12:40
  • Sorry to be a pain... Do you know any good articles that could assist in what I need to do here? I have been banging my head against a proverbial brick wall for 3 days now, and am risking a divorce if I keep doing so lol.
    – LordVader
    Jul 2, 2020 at 12:43
  • Did you include all your interfaces in the router config (with network statements)? Do you see all your subnets on other routers?
    – Ron Trunk
    Jul 2, 2020 at 13:34
  • Hi Ron: There's nothing past the second switch at the moment. I'm just trying to get the end devices to be able to ping out to the second switch, and then I can configure the VLANs on that side
    – LordVader
    Jul 2, 2020 at 13:51
  • I have updated the ip routes to show EIGRP enabled correctly
    – LordVader
    Jul 2, 2020 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.