I have following BGP configuration and trying to reduce my convergence time with help of BFD but having hard time.

router bgp 1111
  address-family ipv4 unicast
    remote-as 2222
    update-source loopback160
    ebgp-multihop 2
    address-family ipv4 unicast

This is what i did to enable BFD

feature bfd
bfd interval 500 min_rx 500 multiplier 5
bfd echo-interface loopback160
router bgp 1111

Now when i run (no output), that means BGP isn't registered to BFD, if i enable OSFP then i can see some output in show bfd neighbors command. I tried debug and no output in debug logs. trying to understand why BGP not getting registered. (My peer ISP did enabled BDF their side) my nxos version is 7.0(3)I4(7)

# show bfd neighbors

1 Answer 1


NX-OS 7.x likely does not support BFD BGP Multihop

BFD BGP multihop support was introduced in NX-OS 8.1(1) according to the NX-OS 7K Command Guide.

BFD BGP multihop support was introduced in NX-OS 9.2(1) according to the NX-OS 9K Command Guide.

The NX-OS 5.x Command Guide explicitly calls out support for only for single-hop EBGP and iBGP peers.

Finally, multi-hop is only supported on the newer ASIC's (-EX and newer) and not the 9396PX hardware platform, according to the Guidelines and Limitations for BFD Multihop in the NX-OS 9K Command Guide. Thanks, @rnxrx for pointing this out as well.

You should be able verify by looking for the multihop command:


R1(config)# bfd ?
    echo-interface    Configure interface used for bfd echo frames
    echo-rx-interval  Configure BFD session echo rx interval
    interval          Configure BFD session interval parameters
    ipv4              Ipv4 sessions
    ipv6              Ipv6 sessions
    multihop          Configure BFD Multihop session interval parameters
    slow-timer        Configure slow mode timer for sessions
    startup-timer     Configure Delayed Start Up timer for sessions
  • 2
    You're on the right track, but this still won't help him - multi-hop is only supported on the newer ASIC's (-EX and newer) and not the 9396PX he mentions. See cisco.com/c/en/us/td/docs/switches/datacenter/nexus9000/sw/92x/… and search for guidelines and limitations.
    – rnxrx
    Jul 17, 2020 at 1:40
  • @TDurden, Yes i don't have multihop option in command-line. I thought even i don't have multi-hop support but atleast i should see something on show bfd neighbors command right? In lab i have created BGP session on physical interface without any multihop even in that case i didn't see any output in show bfd neighbors (feel like something is missing here)
    – Satish
    Jul 17, 2020 at 2:30
  • @rnxrx - Sounds like Satish has multiple obstacles to overcome. The ASIC limitation is a great catch. Do you mind if I integrate your comment into my answer?
    – TDurden
    Jul 17, 2020 at 4:02
  • 1
    @TDurden - help yourself! To the additional points, though, this is one of the pitfalls of the 9Kv. There are certain features which are specifically tied to the forwarding hardware. The T2/ALE ASIC's in his switch have markedly different capabilities than the Cloudscale (EX/FX/FX2/GX) boxes that followed. There are actually things you can do in the old boxes that you can't in the new ones, but far more things in the new ones that were never implemented in the old ones. Given that BFD processing needs to be in hardware it's no wonder it doesn't simulate well.
    – rnxrx
    Jul 18, 2020 at 0:46
  • 1
    Update: if i set update-source Ethernet1/2 in BGP then it works but if i do update-source loopback0 it failed (so it is clear multi-hop is not supported and not giving you any output in show bfd neighbors
    – Satish
    Jul 21, 2020 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.