0

I have an issue with my PIM-SSM multicast configuration using ISR4431s.    I am wanting to forward broadcast data from an application from one VLAN in on the multicast source to another VLAN on a multicast router on a small network.  The method I am using is PIM-SSM.  I have a multicast source R1, a multicast transition router R2, and a multicast receiver, the R3 device.   Any insight into why the broadcast data is not forwarding is welcome.

  Here is the topology and configs:

              R1—R2—R3

R1 Config (Multicast Source):

hostname R1
ip multicast-routing distributed
ip pim spt-threshold infinity
ip pim ssm default
no ip igmp snooping
vtp mode transparent
spanning-tree extend system-id
vlan internal allocation policy ascending
vlan 100
interface GigabitEthernet0/0/0
 ip address 10.194.234.226 255.255.255.252
 ip nat outside
 ip pim sparse-dense-mode
interface GigabitEthernet0/1/0
 switchport access vlan 100
 switchport mode access
interface Vlan100
 ip address 10.1.1.1 255.255.255.0
 ip nat inside
 ip pim sparse-dense-mode
 ip multicast helper-map broadcast 232.1.1.1 bcast-to-mcast ttl 50
ip forward-protocol udp 3205
ip nat inside source static udp 10.1.1.71 3205 10.194.234.226 3205 extendable
ip route 0.0.0.0 0.0.0.0 G0/0/0
ip access-list extended bcast-to-mcast
 permit udp any any eq 3205
end

R2 Config (Multicast Transition Router):

hostname R2
ip multicast-routing distributed
ip pim spt-threshold infinity
vtp mode transparent
spanning-tree extend system-id
vlan internal allocation policy ascending
interface GigabitEthernet0/0/0
 ip address 10.194.234.225 255.255.255.252
 ip pim sparse-dense-mode
 no shutdown
 negotiation auto
interface GigabitEthernet0/0/1
 ip address 10.156.51.225 255.255.255.252
 ip pim sparse-dense-mode
 no shutdown
 negotiation auto
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/1
end

R3 Config (Multicast Receiver, NOTE:  192.142.1.99 is not the device that is receiving the data.  Other devices on vlan 600 need the data):  

hostname R3
ip multicast-routing distributed
ip pim spt-threshold infinity
ip pim ssm default
no ip igmp snooping
vtp mode transparent
spanning-tree extend system-id
vlan internal allocation policy ascending
vlan 600
interface GigabitEthernet0/0/0
 ip address 10.156.51.226 255.255.255.252
 ip pim sparse-dense-mode
 ip multicast helper-map 232.1.1.1 192.142.1.255 bcast-to-mcast
 ip igmp version 3
 negotiation auto
interface GigabitEthernet0/1/0
 switchport access vlan 600
 switchport mode access
interface GigabitEthernet0/1/1
switchport access vlan 600
switchport mode access
interface Vlan600
 ip address 192.142.1.1 255.255.255.0
 ip broadcast-address 192.142.1.255
 ip directed-broadcast
 ip pim sparse-dense-mode
 ip igmp join-group 232.1.1.1 source 10.194.234.226
 ip igmp version 3
ip forward-protocol udp 3205
ip nat inside source static tcp 192.142.1.99 61000 10.156.51.226 61000 extendable
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0
ip access-list extended bcast-to-mcast
 permit udp any any eq 3205
end
  • I haven't thoroughly looked at your config as it's a little tough to read (I made a formatting edit to your post to help, which is pending review) but what jumps out at me immediately is your R3 configuration has bcast-to-mcast and I think you want mcast-to-bcast there. Separately, I think your config for R2 unicast routing table might be based on some confusion about how to get the multicast RPF tree setup correctly; you should configure the routing table of each router so it can reach the involved subnets, without installing two different, likely incorrect default routes on R2. – Jeff Wheeler Aug 1 at 15:37
  • It’s a simple network hence the static default routes. I can ping R1 G0/0/0 to R3 G0/0/0. I have not tried pinging vlan 100 to vlan 600 on the real network. My Packet tracer sim of the basic network does ping vlan 100 device to vlan 600 device. I cannot sim PIM-SSM in packet tracer. I also believe I see the the correct neighbors for each multicast port. The access list change, oh yes. I can change it for future reference thanks for telling me about that. – Joe Hughes Aug 1 at 16:45
  • 1
    I will have a look at setting up the individual static routes too. – Joe Hughes Aug 1 at 17:27
  • I just noticed I don’t have IGMP version 3 enabled on the R1 source vlan 100 and G0/0/0. I bet that is my problem. – Joe Hughes Aug 1 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.