0

I'm trying to learn my way around Cisco switches by watching an online course [1] and trying the commands from there on a switch I have access to. One of the first commands I've tried, show vlan brief, doesn't seem to be supported on the switch I tried it on. Could you help me to figure out why is it so? Do different versions of IOS have different ways of configuring VLANs? Or my switch doesn't have this feature enabled? Or maybe I'm doing something completely silly, and is not in the right mode or something?

Here's output from the console:

RP/0/RP0/CPU0:xy16.nuq09#show license                                                                     
                                ^                                                                         
% Invalid input detected at '^' marker.                                                                   
RP/0/RP0/CPU0:xy16.nuq09#show version                                                                     
Fri Aug 28 14:11:27.261 PDT                                                                               
Cisco IOS XR Software, Version 6.5.3                                                                      
Copyright (c) 2013-2019 by Cisco Systems, Inc.
                                                                                                          
Build Information:                                                                                        
 Built By     : ahoang                           
 Built On     : Tue Mar 26 06:35:07 PDT 2019                                                              
 Built Host   : iox-ucs-025                                                                                                                                                                                          
 Workspace    : /auto/srcarchive13/prod/6.5.3/ncs5k/ws                                                    
 Version      : 6.5.3                                                                                     
 Location     : /opt/cisco/XR/packages/                                                                   
                                                                                                          
cisco NCS-5001 () processor                 
System uptime is 36 weeks 3 days 3 hours 5 minutes
                                                                                                          
RP/0/RP0/CPU0:xy16.nuq09#show vlan?                                                                       
                               ^                                                                          
% Invalid input detected at '^' marker.                                                                   
RP/0/RP0/CPU0:xy16.nuq09#show vlan
                               ^
% Invalid input detected at '^' marker.

[1] https://www.linkedin.com/learning/learning-cisco-cli-switch-configuration

7
  • 2
    That is a router, not a switch: "The Cisco® Network Convergence System 5000 Series offers a high-density, small-form-factor MPLS aggregation router for metro aggregation." – Ron Maupin Aug 28 '20 at 21:47
  • Does every Cisco router lack "show vlan" command? I tried two routers in Cisco Packet Tracer: ISR4331 and 2811, and both of them do support "show vlan" command. These two routers seem to run "IOS" though, and the one I have access to is running "IOS XR", can that be the difference determining if a particular box supports "show vlan" or not? – Kirill Spitsyn Aug 28 '20 at 22:35
  • VLANs are for layer-2 switches. A VLAN logically divides a switch into multiple broadcast domains, as if they were separate, unconnected switches. Routers bound VLANs. – Ron Maupin Aug 28 '20 at 22:42
  • 3
    That is because it has a switch module in it. Some Cisco routers can have switch modules, then they get (a limited set of) switch commands. – Ron Maupin Aug 28 '20 at 23:30
  • 1
    It honestly depends on your use-case, but you can replicate a lot of the behaviors of a conventional switch by using bridge-groups or MST instances - check out cisco.com/c/en/us/td/docs/iosxr/ncs5000/vpn/63x/… for some examples. – rnxrx Aug 29 '20 at 3:55
1

The NCS-5001 is a router, not a switch. While it does support 802.1Q VLAN tagging and trunking, it does not support switching (=L2 forwarding) between subinterfaces in the same VLAN.

Accordingly, the vlan and show vlan commands do not make sense on the router. show interfaces should display the subinterface configurations.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.