4

I have a set up with back to back connection with EIGRP over frame-relay, mention below the device connection setup using GNS3.

Problem is: I am configuring EIGRP over frame-relay, but its not showing EIGRP neighbors under show ip route command output. Please help me on it..

These are the configuration on routers between R1 and R2; I removed keepalives and am using the same DLCI in frame-relay.

R1:

conf t
int se0/0
ip add 131.1.12.1 255.255.255.0
encapsulation frame-relay
no keepavlive
frame-relay map ip 131.1.12.2 100
no sh

router eigrp 100
network 131.1.12.0 0.0.0.255

R2:

conf t
int se0/0
ip add 131.1.12.2 255.255.255.0
encapsulation frame-relay
no keepavlive
frame-relay map ip 131.1.12.1 100

int fa1/0
ip add 131.1.23.2 255.255.255.0
no sh

router eigrp 100
net 131.1.12.0 0.0.0.255
net 131.1.23.0 0.0.0.255

Network Diagram


Update after one.time's answer:

Thanks for your reply.

I have two issues.

1) I had done the configuration as per your guidelines, now its working fine. But the problem is i cant able to ping the any of the routers own interfaces from the router itself and from the same rotuer i can able to ping other neighbors. mentioned the one router config and ping results below.

R2:-

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
!
interface Serial0/0
 ip address 131.1.12.2 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 131.1.12.1 100 broadcast
!
interface FastEthernet1/0
 ip address 131.1.23.2 255.255.255.0
 duplex auto speed auto
!
router eigrp 100
 network 2.0.0.0 0.0.0.0
 network 2.0.0.0
 network 131.1.12.0 0.0.0.255
 network 131.1.23.0 0.0.0.255
 no auto-summary

Ping results :-

R2#ping 131.1.23.1

Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 131.1.23.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R2#ping 131.1.23.2

Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 131.1.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R2#
R2#
R2#ping 131.1.12.2

Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 131.1.12.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R2#
R2#ping 131.1.12.1

Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 131.1.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/36/56 ms
R2#

2) i want to setup my devices like:- -R2 and R3's interface should be confiugred to be in vlan 23. -R1 and R2,R3 and R4 should be configured in a frame-relay multipoint manner but do not use a sub-interface to accomplish this task.

1
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 8, 2017 at 16:26

1 Answer 1

3

There are a few ways to accomplish a back-to-back frame-relay connection.

A quick search returns the following options:

Your configuration is closer to hybrid switching, however, you're missing a few key elements.

Frame-Relay

Either R1 or R2 will need to have frame-relay switching enabled to act as the frame-relay switch.

R1(config)#frame-relay switching

The newly designated frame switch's Serial0/0 interface needs to be changed to the frame-relay interface type dce in order to provide LMI.

R1(config)#int s0/0
R1(config-if)#frame-relay intf-type dce

Finally you don't need to include the no keepavlive syntax when performing hybrid switching.

EIGRP

Your matching(required) static frame-relay map statements may include the broadcast statement in order for EIGRP to establish a neighbor adjacency.

R1(config)#int s0/0
R1(config-if)# frame-relay map ip 131.1.12.2 100 broadcast

R2(config)#int s0/0
R2(config-if)# frame-relay map ip 131.1.12.1 100 broadcast

IP: s=131.1.12.1 (local), d=224.0.0.10 (Serial0/0), len 60, sending broad/multicast
Serial0/0(o): dlci 100(0x1841), pkt type 0x800(IP), datagramsize 64
Serial0/0(o):Pkt sent on dlci 100(0x1841), pkt type 0x800(IP), datagramsize 64

Without the broadcast statement, EIGRP messages sent to the multicast address 224.0.0.10 will fail to be encapsulated.

IP: s=131.1.12.1 (local), d=224.0.0.10 (Serial0/0), len 60, sending broad/multicast
Serial0/0: broadcast search
Serial0/0:encaps failed on broadcast for link 7(IP)
IP: s=131.1.12.1 (local), d=224.0.0.10 (Serial0/0), len 60, encapsulation failed

Unicast EIGRP

Or, instead of using the broadcast keyword with your static frame-relay map statements to avoid encapsulation failures, you can specify EIGRP unicast neighbors under EIGRP process 100 and your adjacency should form.

R1(config-if)#router eigrp 100
R1(config-router)#neighbor 131.1.12.2 s0/0
%DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 131.1.12.2 (Serial0/0) is down: Static peer configured
%DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 131.1.12.2 (Serial0/0) is up: new adjacency

R2(config-if)#router eigrp 100
R2(config-router)#neighbor 131.1.12.1 s0/0
%DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 131.1.12.1 (Serial0/0) is down: Static peer configured
%DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 131.1.12.1 (Serial0/0) is up: new adjacency
3
  • Thanks for your reply; please look at the update to my question. I cant ping any of the router's own interfaces from the router itself
    – user4927
    Mar 25, 2014 at 9:02
  • @user4927, as for R1 and R2 not being able to ping their own interfaces...this is common when using a multipoint interface (your configuration above) as well as multipoint sub-interfaces. Right now your router(s) do not have a DLCI to use for pinging their own interfaces. To meet your criteria a static frame-relay statement will need to be placed under each interface using the same DLCI (100) pointing to the local IP address of the physical interface. Example: R1 frame-relay map ip 131.1.12.1 100 R2 frame-relay map ip 131.1.12.2 100.
    – one.time
    Mar 25, 2014 at 15:22
  • @user4927, it may be worth taking a look at this document to get a good feel for frame-relay.
    – one.time
    Mar 25, 2014 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.