1

We have two Site to Site VPNs and Remote Access VPN configured. Using the builtin IPsec client on OSX all subnets are accessible however when using L2TP built in client on Windows 10 ICMP traffic works for all subnets, TCP traffic works only for Office1 subnet (192.168.6.x).

I ran Wireshark on the Test PC 2 and confirmed I got TCP traffic, so I know the traffic is making it over the site to site just not back again.

I used packet tracer on Office2's ASA to confirm a packet from TestPC 2 would be routed over the Site to Site OK. If I do the same on Office1 ASA it says it drops the packet but I think this might be because packet tracer doesn't understand the hairpin traffic.

Network Diagram

Result of the command: "show running-config"

: Saved

:
: Serial Number: ***********
: Hardware:   ASA5506, 4096 MB RAM, CPU Atom C2000 series 1250 MHz, 1 CPU (4 cores)
:
ASA Version 9.8(1)
!
hostname ciscoasa
enable password ********************************************* pbkdf2
names
ip local pool ClientVPNPool 192.168.8.20-192.168.8.254 mask 255.255.255.0

!
interface GigabitEthernet1/1
 nameif outside
 security-level 0
 ip address 10.0.0.2 255.255.255.0
!
interface GigabitEthernet1/2
 bridge-group 1
 nameif inside_1
 security-level 100
!
interface GigabitEthernet1/3
 bridge-group 1
 nameif inside_2
 security-level 100
!
interface GigabitEthernet1/4
 bridge-group 1
 nameif inside_3
 security-level 100
!
interface GigabitEthernet1/5
 bridge-group 1
 nameif inside_4
 security-level 100
!
interface GigabitEthernet1/6
 bridge-group 1
 nameif inside_5
 security-level 100
!
interface GigabitEthernet1/7
 bridge-group 1
 nameif inside_6
 security-level 100
!
interface GigabitEthernet1/8
 bridge-group 1
 nameif inside_7
 security-level 100
!
interface Management1/1
 management-only
 no nameif
 no security-level
 no ip address
!
interface BVI1
 nameif inside
 security-level 100
 ip address 192.168.6.1 255.255.255.0
!
ftp mode passive
clock timezone GMT/BST 0
clock summer-time GMT/BDT recurring last Sun Mar 1:00 last Sun Oct 2:00
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network obj_any1
 subnet 0.0.0.0 0.0.0.0
object network obj_any2
 subnet 0.0.0.0 0.0.0.0
object network obj_any3
 subnet 0.0.0.0 0.0.0.0
object network obj_any4
 subnet 0.0.0.0 0.0.0.0
object network obj_any5
 subnet 0.0.0.0 0.0.0.0
object network obj_any6
 subnet 0.0.0.0 0.0.0.0
object network obj_any7
 subnet 0.0.0.0 0.0.0.0
object network Office1_VPN_RA
 subnet 192.168.8.0 255.255.255.0
object network Office2_LAN
 subnet 192.168.5.0 255.255.255.0
object network Office1_LAN
 subnet 192.168.6.0 255.255.255.0
object network AWS
 subnet 10.0.1.0 255.255.255.0
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
object-group protocol DM_INLINE_PROTOCOL_1
 protocol-object ip
 protocol-object icmp
object-group protocol DM_INLINE_PROTOCOL_2
 protocol-object ip
 protocol-object icmp
object-group protocol DM_INLINE_PROTOCOL_3
 protocol-object ip
 protocol-object icmp
object-group protocol DM_INLINE_PROTOCOL_4
 protocol-object ip
 protocol-object icmp
object-group protocol DM_INLINE_PROTOCOL_5
 protocol-object ip
 protocol-object icmp
object-group protocol DM_INLINE_PROTOCOL_6
 protocol-object ip
 protocol-object icmp
object-group protocol DM_INLINE_PROTOCOL_7
 protocol-object ip
 protocol-object icmp
object-group protocol DM_INLINE_PROTOCOL_9
 protocol-object ip
 protocol-object icmp
object-group protocol DM_INLINE_PROTOCOL_10
 protocol-object ip
 protocol-object icmp
object-group protocol DM_INLINE_PROTOCOL_11
 protocol-object ip
 protocol-object icmp
object-group protocol DM_INLINE_PROTOCOL_12
 protocol-object ip
 protocol-object icmp
object-group protocol DM_INLINE_PROTOCOL_8
 protocol-object ip
 protocol-object icmp
object-group protocol DM_INLINE_PROTOCOL_13
 protocol-object ip
 protocol-object icmp
access-list outside_cryptomap_2 extended permit object-group DM_INLINE_PROTOCOL_1 object Office1_LAN object Office2_LAN
access-list outside_cryptomap_2 extended permit object-group DM_INLINE_PROTOCOL_2 object Office1_VPN_RA object Office2_LAN
access-list outside_cryptomap_2 extended permit object-group DM_INLINE_PROTOCOL_7 object AWS object Office2_LAN
access-list RemoteAccess extended permit object-group DM_INLINE_PROTOCOL_3 object Office1_VPN_RA object Office1_LAN
access-list RemoteAccess extended permit object-group DM_INLINE_PROTOCOL_4 object Office1_VPN_RA object Office2_LAN
access-list RemoteAccess extended permit object-group DM_INLINE_PROTOCOL_5 object Office1_VPN_RA any
access-list RemoteAccess extended permit object-group DM_INLINE_PROTOCOL_13 object Office2_LAN object Office1_VPN_RA
access-list outside_cryptomap extended permit object-group DM_INLINE_PROTOCOL_6 any4 object AWS
access-list SplitTunnel extended permit object-group DM_INLINE_PROTOCOL_11 object Office1_LAN object Office1_VPN_RA
access-list SplitTunnel extended permit object-group DM_INLINE_PROTOCOL_8 object Office2_LAN object Office1_VPN_RA
access-list SplitTunnel extended permit object-group DM_INLINE_PROTOCOL_10 object AWS object Office1_VPN_RA
access-list SplitTunnel extended permit object-group DM_INLINE_PROTOCOL_12 host ************* object Office1_VPN_RA
access-list SplitTunnel extended permit ip host ************** object Office1_VPN_RA
access-list SplitTunnel extended permit ip host ************** object Office1_VPN_RA
access-list SplitTunnel extended permit ip host ************** object Office1_VPN_RA
access-list SplitTunnel extended permit ip host ************** object Office1_VPN_RA
access-list SplitTunnel extended permit ip host ************** object Office1_VPN_RA
access-list SplitTunnel extended permit ip host ************** object Office1_VPN_RA
access-list SplitTunnel extended permit ip host ************** object Office1_VPN_RA
access-list SplitTunnel extended permit ip host ************** object Office1_VPN_RA
access-list SplitTunnel extended permit ip host ************** object Office1_VPN_RA
pager lines 24
logging enable
logging asdm informational
logging host inside 10.0.1.9
logging host inside 192.168.6.13
logging class vpdn trap informational
logging class vpn trap informational
logging class vpnc trap informational
mtu outside 1500
mtu inside_1 1500
mtu inside_2 1500
mtu inside_3 1500
mtu inside_4 1500
mtu inside_5 1500
mtu inside_6 1500
mtu inside_7 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
arp rate-limit 16384
nat (inside_1,outside) source static Office1_LAN Office1_LAN destination static Office1_VPN_RA Office1_VPN_RA no-proxy-arp route-lookup
nat (inside_1,outside) source static Office1_LAN Office1_LAN destination static Office2_LAN Office2_LAN no-proxy-arp route-lookup
nat (inside_1,outside) source static Office1_LAN Office1_LAN destination static AWS AWS no-proxy-arp route-lookup
nat (outside,outside) source static Office1_VPN_RA Office1_VPN_RA destination static AWS AWS no-proxy-arp route-lookup
nat (outside,outside) source static Office1_VPN_RA Office1_VPN_RA destination static Office2_LAN Office2_LAN no-proxy-arp route-lookup
nat (outside,outside) source static Office2_LAN Office2_LAN destination static AWS AWS no-proxy-arp route-lookup
nat (outside,outside) source static AWS AWS destination static Office1_VPN_RA Office1_VPN_RA no-proxy-arp route-lookup
nat (outside,outside) source static Office2_LAN Office2_LAN destination static Office1_VPN_RA Office1_VPN_RA no-proxy-arp route-lookup
nat (outside,outside) source dynamic Office1_VPN_RA interface
nat (outside,outside) source dynamic AWS interface
nat (inside_1,outside) source dynamic any interface
route outside 0.0.0.0 0.0.0.0 10.0.0.1 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 sctp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
timeout conn-holddown 0:00:15
timeout igp stale-route 0:01:10
user-identity default-domain LOCAL
aaa authentication login-history
http server enable
http 192.168.0.0 255.255.255.0 inside_3
http 192.168.0.0 255.255.255.0 inside_7
http 192.168.0.0 255.255.255.0 inside_4
http 192.168.0.0 255.255.255.0 inside_5
http 192.168.0.0 255.255.255.0 inside_6
http 192.168.8.0 255.255.255.0 outside
http 192.168.6.0 255.255.255.0 inside_2
http 192.168.6.0 255.255.255.0 inside_1
no snmp-server location
no snmp-server contact
service sw-reset-button
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS esp-aes esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS esp-des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS mode transport
crypto ipsec ikev2 ipsec-proposal AES256
 protocol esp encryption aes-256
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES192
 protocol esp encryption aes-192
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES
 protocol esp encryption aes
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal 3DES
 protocol esp encryption 3des
 protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal DES
 protocol esp encryption des
 protocol esp integrity sha-1 md5
crypto ipsec security-association pmtu-aging infinite
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-3DES-SHA ESP-3DES-MD5 ESP-AES-128-SHA-TRANS ESP-AES-256-SHA-TRANS ESP-3DES-SHA-TRANS
crypto map outside_map 1 match address outside_cryptomap_2
crypto map outside_map 1 set peer **Office1PublicIP**
crypto map outside_map 1 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 1 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
crypto map outside_map 2 match address outside_cryptomap
crypto map outside_map 2 set pfs
crypto map outside_map 2 set peer **Office2PublicIP**
crypto map outside_map 2 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 2 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
crypto map outside_map 2 set security-association lifetime seconds 3600
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto ca trustpool policy
crypto ikev2 policy 1
 encryption aes-256
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 10
 encryption aes-192
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 20
 encryption aes
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 30
 encryption 3des
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 policy 40
 encryption des
 integrity sha
 group 5 2
 prf sha
 lifetime seconds 86400
crypto ikev2 enable outside
crypto ikev1 enable outside
crypto ikev1 policy 10
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 20
 authentication rsa-sig
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 40
 authentication pre-share
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 50
 authentication rsa-sig
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 70
 authentication pre-share
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 80
 authentication rsa-sig
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 100
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 110
 authentication rsa-sig
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 130
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto ikev1 policy 140
 authentication rsa-sig
 encryption des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
management-access inside

dhcpd address 192.168.6.20-192.168.6.254 inside
dhcpd dns 8.8.8.8 interface inside
dhcpd option 3 ip 192.168.6.1 interface inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 192.168.6.6 source inside_1 prefer
group-policy DfltGrpPolicy attributes
 vpn-tunnel-protocol ikev1 ikev2 l2tp-ipsec
 pfs enable
group-policy GroupPolicy_Office1SiteToSite internal
group-policy GroupPolicy_Office1SiteToSite attributes
 vpn-filter none
 vpn-tunnel-protocol ikev1 ikev2
group-policy GroupPolicy_Office2SiteToSite internal
group-policy GroupPolicy_Office2SiteToSite attributes
 vpn-filter none
 vpn-tunnel-protocol ikev1 ikev2
group-policy VPNGroupPolicy internal
group-policy VPNGroupPolicy attributes
 banner value Successfully connected to VPN
 dns-server value 8.8.8.8
 vpn-filter value RemoteAccess
 vpn-tunnel-protocol ikev1 l2tp-ipsec
 split-tunnel-policy tunnelspecified
 ipv6-split-tunnel-policy tunnelspecified
 split-tunnel-network-list value SplitTunnel
 split-tunnel-all-dns disable
 intercept-dhcp 255.255.255.0 enable
dynamic-access-policy-record DfltAccessPolicy
 network-acl RemoteAccess
username OSXTest password ****************************** pbkdf2
username OSXTest attributes
 service-type remote-access
username WindowsTest password *************************** nt-encrypted
username WindowsTest attributes
 vpn-framed-ip-address 192.168.8.201 255.255.255.0
 service-type remote-access
tunnel-group DefaultRAGroup general-attributes
 address-pool ClientVPNPool
 default-group-policy VPNGroupPolicy
tunnel-group DefaultRAGroup ipsec-attributes
 ikev1 pre-shared-key *****
tunnel-group DefaultRAGroup ppp-attributes
 authentication ms-chap-v2
tunnel-group **Office1PublicIP** type ipsec-l2l
tunnel-group **Office1PublicIP** general-attributes
 default-group-policy GroupPolicy_Office1SiteToSite
tunnel-group **Office1PublicIP** ipsec-attributes
 ikev1 pre-shared-key *****
 ikev2 remote-authentication pre-shared-key *****
 ikev2 local-authentication pre-shared-key *****
tunnel-group VPNGroupPolicy type remote-access
tunnel-group VPNGroupPolicy general-attributes
 address-pool ClientVPNPool
 default-group-policy VPNGroupPolicy
tunnel-group VPNGroupPolicy ipsec-attributes
 ikev1 pre-shared-key *****
tunnel-group **Office2PublicIP** type ipsec-l2l
tunnel-group **Office2PublicIP** general-attributes
 default-group-policy GroupPolicy_Office2SiteToSite
tunnel-group **Office2PublicIP** ipsec-attributes
 ikev1 pre-shared-key *****
 ikev2 remote-authentication pre-shared-key *****
 ikev2 local-authentication pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
  no tcp-inspection
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:cbf4bbffb2603a039fc97ece490af892
: end
  • Unfortunately, your question is too broad to answer without simply guessing, which is off-topic here. We need more details, such as a good network description or diagram, the network device models, and the network device configurations. Please edit your question to include enough information to be able to answer your question. – Ron Maupin Sep 28 '20 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.