-1

New to this.

I have a tc4400 modem which works fine: when connected straight to my computer, internet passes.

However when I connect my EdgeRouterX to the modem and ssh into the router, pinging any public IP fails. Needless to say internet does not pass through to my computer.

How do I go about debugging this?

The config:

firewall {
    all-ping enable
    broadcast-ping disable
    ipv6-name WANv6_IN {
        default-action drop
        description "WAN inbound traffic forwarded to LAN"
        enable-default-log
        rule 10 {
            action accept
            description "Allow established/related sessions"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
    }
    ipv6-name WANv6_LOCAL {
        default-action drop
        description "WAN inbound traffic to the router"
        enable-default-log
        rule 10 {
            action accept
            description "Allow established/related sessions"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
        rule 30 {
            action accept
            description "Allow IPv6 icmp"
            protocol ipv6-icmp
        }
        rule 40 {
            action accept
            description "allow dhcpv6"
            destination {
                port 546
            }
            protocol udp
            source {
                port 547
            }
        }
    }
    ipv6-receive-redirects disable
    ipv6-src-route disable
    ip-src-route disable
    log-martians enable
    name WAN_IN {
        default-action drop
        description "WAN to internal"
        rule 10 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
    }
    name WAN_LOCAL {
        default-action drop
        description "WAN to router"
        rule 10 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
    }
    receive-redirects disable
    send-redirects enable
    source-validation disable
    syn-cookies enable
}
interfaces {
    ethernet eth0 {
        address dhcp
        description Internet
        duplex auto
        firewall {
            in {
                ipv6-name WANv6_IN
                name WAN_IN
            }
            local {
                ipv6-name WANv6_LOCAL
                name WAN_LOCAL
            }
        }
        speed auto
    }
    ethernet eth1 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth2 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth3 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth4 {
        description Local
        duplex auto
        poe {
            output pthru
        }
        speed auto
    }
    loopback lo {
    }
    switch switch0 {
        address 192.168.1.1/24
        description Local
        switch-port {
            interface eth1 {
            }
            interface eth2 {
            }
            interface eth3 {
            }
            interface eth4 {
            }
        }
    }
}
service {
    dhcp-server {
        disabled false
        hostfile-update disable
        shared-network-name LAN {
            authoritative enable
            subnet 192.168.1.0/24 {
                default-router 192.168.1.1
                dns-server 192.168.1.1
                lease 86400
                start 192.168.1.38 {
                    stop 192.168.1.243
                }
            }
        }
    }
    dns {
        forwarding {
            cache-size 150
            listen-on switch0
        }
    }
    gui {
        https-port 443
    }
    nat {
        rule 5010 {
            description "masquerade for WAN"
            outbound-interface eth0
            type masquerade
        }
    }
    ssh {
        port 22
        protocol-version v2
    }
}
system {
    host-name ubnt
    login {
        user ubnt {
            authentication {
                encrypted-password 
            }
            level admin
        }
    }
    ntp {
        server 0.ubnt.pool.ntp.org {
        }
        server 1.ubnt.pool.ntp.org {
        }
        server 2.ubnt.pool.ntp.org {
        }
        server 3.ubnt.pool.ntp.org {
        }
    }
    syslog {
        global {
            facility all {
                level notice
            }
            facility protocols {
                level debug
            }
        }
    }
    time-zone UTC
}

Thanks in advance

3
  • 1
    Consumer kit (that cablemodem) is off-topic. In most cases, cablemodems are only allowed one client, so a reboot of the modem is required to change ones router. (or clone the MAC so every router used has the same MAC.)
    – Ricky
    Oct 8 '20 at 4:10
  • 1
    You'll need to add the EdgeRouter's config to your question - without it there's no way we can tell what you did wrong.
    – Zac67
    Oct 8 '20 at 7:31
  • @Zac67 edited with pastebin
    – softcode
    Oct 8 '20 at 9:35
1

Please check configuration in edge router onces again . Configurations like interface configuration, routing ,ssh configuration ,Nating , make sure edge router egress interface connected to modem and ingress interface has to be connected LAN connecting local computer.

Ensure proper routing is configured on edge router

Default route

IP route 0.0.0.0 0.0.0.0 pointing towards ISP gàteway

Static route is required in edge router if edge router is connected another layer3 devices

In case edge route is connected layer2 switch static route is not required on edge router . Because layer3 interface configuration on edge router ARP table is created in edge router and traffic is forwarded to destination based on ARP table.

Please ensure PAT overload (port address translation) is configured on edge router for outbound traffic . And static NAT for incoming traffic.

1
  • Dude, first line. New to this. Lol. You lost me the second line. Nonetheless I edited the post with a pastebin of the config
    – softcode
    Oct 8 '20 at 9:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.