0

I have a allied telesis switch with VLAN10 & VLAN 20 and a basic ISP Router with no VLAN configuration. ISP router IP is 172.30.50.253

PC1: 172.30.3.x/24 Gateway 172.30.3.254 VLAN30
interface port1.0.6
 switchport
 switchport mode access
 switchport access vlan 30

PC2: 172.30.50.x/24 Gateway 172.30.50.254 VLAN50
interface port1.0.3
 switchport
 switchport mode access
 switchport access vlan 50
 spanning-tree portfast


interface port1.0.23
 description *** Trunk to CCTV switch ***
 switchport
 switchport mode access
 switchport access vlan 50
This is the uplink to ISP router

ip route 0.0.0.0/0 172.30.50.253

The problem I'm facing is PC2 able to get Internet from ISP router but PC1 not able to get Internet. May I know which part is wrong.

  • The router needs to know how to reach the networks on the VLANs. You need to either statically configure routing, or you need to use a routing protocol to share the routes. The layer-3 switch need to have routing enable to use it as a layer-3 switch, and it needs interfaces (either physical or virtual) in each network it will route. You are only showing layer-2 interfaces, nothing to do with layer-3. – Ron Maupin Nov 20 at 14:56
0

VLAN 30 is not connected to anything. That's why PC1 won't work. There's no gateway on VLAN 30. You need to do one of the following:

Trunk VLAN 30 to ISP router

If you want to configure a gateway for VLAN 30 on the ISP router, you may do so (as long as it supports VLANs.) The best way to do this is to change switch port port1.0.23 to switchport mode trunk and allow all VLANs to be trunked to the router. Then, configure the ISP router for 802.1Q trunking on both its VLANs 30 & 50.

Configure layer-3 switch

You can add an IP address on the switch within VLAN 30. For this to work, however, your ISP router also needs to know 172.30.3.0/24 is connected to the switch. You'd need to create a routing table entry 172.30.3.0/24 -> 172.30.50.253 on the ISP router.

| improve this answer | |
1

You need a router to route between VLANs. If your switch is layer 3, then you need to do three things:

  1. For devices on each VLAN, set the default gateway to the VLAN interface (it appears you've already done that).
  2. Add a static default route on the switch with the next hop of the ISP router
  3. Add a static route on the ISP router for each additional VLAN. The next hop is the VLAN interface (50).
| improve this answer | |
0

As per your configuration provided

interface port1.0.23 description *** Trunk to CCTV switch *** switchport switchport mode access switchport access vlan 50

Above configuration clearly says that link between switch and router is configured as access link that mean access port and only vlan 50 is allowed . To ensure internet connectivity for vlan 30 changes it to trunk link allowing all vlans to pass from link connected between router and switch ..

Switch (config)#Int port 1.0.23 Switch(config)# switch mode trunk Switch(config) Switchport trunk allowed vlans all

Switch(config)# no shutdown

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.