0

we have 10 servers with Advertised auto-negotiation: yes

as

the machines with driver driver: i40e

driver: i40e
version: 2.3.2-k
firmware-version: 10.51.5
expansion-rom-version:
bus-info: 0000:12:00.0
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: yes


Supported ports: [ FIBRE ]
Supported link modes:   10000baseSR/Full
Supported pause frame use: Symmetric
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes:  10000baseSR/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Speed: 10000Mb/s
Duplex: Full
Port: FIBRE
PHYAD: 0
Transceiver: internal
Auto-negotiation: off
Supports Wake-on: d
Wake-on: d
Current message level: 0x00000007 (7)
                       drv probe link
Link detected: yes

and we have another 10 servers with `Advertised auto-negotiation: no

the machines with driver: ixgbe

driver: ixgbe
version: 4.4.0-k-rh7.3
firmware-version: 0x8000091d
bus-info: 0000:0b:00.0
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: no


      Supported ports: [ FIBRE ]
Supported link modes:   10000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: No
Advertised link modes:  10000baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: No
Speed: 10000Mb/s
Duplex: Full
Port: FIBRE
PHYAD: 0
Transceiver: external
Auto-negotiation: off
Supports Wake-on: d
Wake-on: d
Current message level: 0x00000007 (7)
                       drv probe link
Link detected: yes

regarding to mix of auto-negotiation

is that can be a problem when both group of servers are commentated between them?

5
  • Unfortunately, questions about host/server configurations are off-topic here. You could try to ask this question on Server Fault for a business network. – Ron Maupin Dec 1 '20 at 13:15
  • What NIC and driver? Technically, 1G+ require auto-negotiation. I'm a bit puzzled by the driver saying it's not supported. (yes, I've run into carrier ethernet circuits that had to have auto-neg disabled to work, but I'd call those pseudo-ethernet) – Ricky Dec 1 '20 at 14:42
  • on the first machine the driver is driver: ixgbe – sheffadmin Dec 1 '20 at 14:48
  • on the other machines the driver is driver: i40e – sheffadmin Dec 1 '20 at 14:48
  • I update the Question – sheffadmin Dec 1 '20 at 14:53
1

In theory, No, since 10Gb Ethernet only works at full duplex. But as a general rule, you should set all your devices to auto-negotiation. It's also a good idea to make your devices as uniform as possible to simplify management.

15
  • so how to know if this is a problem of switch or linux machines? – sheffadmin Dec 1 '20 at 13:03
  • As I said, 10G only works at full duplex, so there is no other option. – Ron Trunk Dec 1 '20 at 13:04
  • I mean if we want to disabled it , what is the procedure to know if switch is enabled it or maybe this should be on linux machines as conf under /etc/sysconfig/network-scripts – sheffadmin Dec 1 '20 at 13:04
  • What kind of switch? – Ron Trunk Dec 1 '20 at 13:04
  • juniper switch ( we also configured vlan ) – sheffadmin Dec 1 '20 at 13:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.