3

In Cisco's NX-OS when forming the MLAG equivalent pair (vPC) there are some best practices to follow, for example, a separate bonded L3 interface just for the keepalive packets using separate ports from the peerlink.

So in NX-OS there's something like that done:

  vpc domain 1
  peer-switch
  role priority 1
  system-priority 1000
  peer-keepalive destination 172.31.2.2 source 172.31.2.1 vrf vpc-peer-keepalive
  auto-recovery
  ipv6 nd synchronize
  ip arp synchronize

There's the two different Port Channel interfaces:

interface port-channel47
  description vPC Peer-link Keepalive
  no switchport
  vrf member vpc-peer-keepalive
  ip address 172.31.2.1/30

interface port-channel51
  description vPC Peer-link
  switchport mode trunk
  switchport trunk native vlan 256
  spanning-tree port type network
  speed 10000
  vpc peer-link

And finally the physical interfaces:

interface Ethernet1/47
  description vPC Peer-link Keepalive Interface #1
  no switchport
  channel-group 47

interface Ethernet1/48
  description vPC Peer-link Keepalive Interface #2
  no switchport
  channel-group 47
interface Ethernet1/51
  description vPC Peer-link Interface #1
  switchport mode trunk
  switchport trunk native vlan 256
  spanning-tree port type network
  udld aggressive
  channel-group 51 mode active
  no shutdown

interface Ethernet1/52
  description vPC Peer-link Interface #2
  switchport mode trunk
  switchport trunk native vlan 256
  spanning-tree port type network
  udld aggressive
  channel-group 51 mode active
  no shutdown

So that's it for NX-OS. Now in Arista's EOS, I can't seem to find anything related to keepalives in a different interface, or if this is recommended. Accordingly to the EOS manual you just use the same Peerlink interfaces: https://www.arista.com/en/um-eos/eos-section-13-5-mlag-implementation-example?searchword=MLAG

There's any different knowledge for Arista EOS devices? Can I use separate ports for the keepalives just like in NX-OS?

Thanks.

4

Arista still does keepalives between peers.

MLAG Documentation for the peer-link statement states that you don't have to use the same link.

An MLAG is formed by connecting two switches through an interface called a peer link. The peer link carries MLAG advertisements, keepalive messages, and data traffic between the switches. This information keeps the two switches working together as one. While interfaces comprising the peer links on each switch must be compatible, they need not use the same interface number. Ethernet and Port-channel interfaces can be configured as peer links. The peer-link command specifies the interface the switch uses to communicates MLAG control traffic.

2
  • Yes, exactly, but the keepalive is carried on the same interfaces as the peerlink. What I was expecting is different physical interfaces to carry the keepalive messages. This does not seems to be recommended. Dec 7 '20 at 17:20
  • There is absolutely no reason that you can't use different interfaces on either device for the peer-link, as long as they are "compatible" (reachable, same VLAN tag, correct subnet, etc.) then it doesn't matter. If you are referring to 13.4.1 where it reccomends that "all switches: constructing peer-links from port-channels in preference to a single Ethernet interface." That's just a matter of preferring port-channels due to the redundancy and the fact that you can expand their size to accommodate any necessary data traffic. Dec 7 '20 at 18:11
2

In Section 13.5.2.2, they show VLAN 4094 being added to the MLAG trunk groups for the L3 keepalive signalling. Unlink Cisco's examples, Arista uses the existing inter-switch group instead of designating a new one. (In theory, this is a better way to go about it, as the ports for one group could fail independent of the other. i.e. the keepalive link could fail but the traffic link still be operational.)

[ 13.5.2.3 defines the "keepalive" through MLAG configuration ]

2
  • Yes, I've seen this. But it's on the same physical interfaces. That's my original question: can I run the keepalive on other physical interfaces. Dec 7 '20 at 17:24
  • Yes. There's no requirement for the peer-link to be part of the MLAG, or even a trunk. Any "compatible" interface can be used.
    – Ricky
    Dec 7 '20 at 18:37
1

Arista will also do dead peer detection over an second path in order to prevent a split brain situation. So, for example, heartbeats can also be sent over, say, the management interfaces in addition to the MLAG peer link.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.