0

I tried to build a simple network in Packet Tracer and I get "Destination host unreachable" when I try pinging a PC from another network. Pinging PCs from the same network works. When I use tracert to a PC from another network it stops at the current network default gateway. My guess it's that it has something to do with the connections between the two routers, but I have no idea what exactly. I would be really grateful if someone could help me solve this problem. Thank you in advance. Here is the image of the network.Network

Router 0 configuration :

 ROOM1#show running-config 
    Building configuration...
    
    Current configuration : 799 bytes
    !
    version 15.1
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
!
hostname ROOM1
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524U1YC-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.0.1 255.255.255.240
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 192.168.0.253 255.255.255.252
 tx-ring-limit 10000
 clock rate 128000
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Router 1 configuration :

ROOM2#show running-config 
Building configuration...

Current configuration : 781 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ROOM2
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX152462Z7-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.0.17 255.255.255.240
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 192.168.0.254 255.255.255.252
 tx-ring-limit 10000
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end
7
  • We need more information in order to help you. Please edit your question to include the configuration of your devices. Use the preformatted text { } option. Otherwise, we're just guessing.
    – Ron Trunk
    Dec 11 '20 at 14:48
  • What exactly should I post?
    – EuLaur D
    Dec 11 '20 at 14:52
  • That error means that you have misconfigured to network mask on the PCs. The PCs on one network think the PCs on the other network are on the same network as the first PCs. The PCs determine if the destination is on the same or a different network by the network mask. Likely, you have the mask 255.255.255.0 on one or more of the PCs, rather than matching what is on the network.
    – Ron Maupin
    Dec 11 '20 at 14:52
  • Post the configuration of both routers, for a start.
    – Ron Trunk
    Dec 11 '20 at 14:55
  • I posted the running config of both routers. The masks of all PCs are 255.255.255.240
    – EuLaur D
    Dec 11 '20 at 15:02
1

You can't ping because neither router knows how to get to the opposite network.

You need to either:

  1. Configure static routes on the routers. Router 0 needs to know how to get to 192.168.0.16/28. For example,
ip route 192.168.0.16 255.255.255.240 192.169.0.254

Similarly, you need a static route on router1 for 192.168.0.0/28

OR

  1. Configure a routing protocol on both routers so they can exchange routing information. You can use OSPF or EIGRP. You can also use RIP, but most consider it an obsolete protocol.
5
  • It works now. Thank you so much. I will post a reply to this comment later with what I did for anyone who is looking for a solution.
    – EuLaur D
    Dec 11 '20 at 15:31
  • For anyone looking for what I did : pastebin.com/PDkue5Tu
    – EuLaur D
    Dec 11 '20 at 15:41
  • If the answer was helpful, you should accept the answer so it doesn't keep popping up in the list.
    – Ron Trunk
    Dec 11 '20 at 15:41
  • You can also answer your own question with the solution you have.
    – Ron Trunk
    Dec 11 '20 at 15:42
  • I'll also point out that configuring static routes and RIP is redundant and not a good practice.
    – Ron Trunk
    Dec 11 '20 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.