1

I can't set an IP address on a Huawei AR207V router because it rejects the "ip address" command.

It's a used but factory reset unit, I'm currently connected on the serial port no other connections.

[Huawei]display version
Huawei Versatile Routing Platform Software
VRP (R) software, Version 5.130 (AR200 V200R005C00SPC100)
Copyright (C) 2011-2013 HUAWEI TECH CO., LTD
Huawei AR207V Router uptime is 0 week, 0 day, 0 hour, 40 minutes

MPU 0(Master) : uptime is 0 week, 0 day, 0 hour, 40 minutes
SDRAM Memory Size    : 512     M bytes
Flash Memory Size    : 512     M bytes
MPU version information :
1. PCB      Version  : AR01SRU0B VER.B
2. MAB      Version  : 0
3. Board    Type     : AR207V
..snip

I can't update to latest firmware because it needs an IP first.

This is what happens when I try to set an IP on an interface -

Please configure the login password (<6-128>)
Enter password:
Confirm password:
<Huawei>system-view
Enter system view, return user view with Ctrl+Z.
[Huawei]interface Ethernet 0/0/0
[Huawei-Ethernet0/0/0]ip address 192.168.2.1 24
                     ^
Error: Unrecognized command found at '^' position.

There are plenty of instructions* which show setting an IP as above but this unit rejects the crucial command

What's going wrong here?

Thanks

(instructions for setting an IP - https://support.huawei.com/enterprise/en/doc/EDOC1100033773/403d9282/configuring-ip-addresses-for-interfaces )

1
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could post and accept your own answer. – Ron Maupin Dec 31 '20 at 5:17
1

Thanks Zac.

I got an answer from the huawei forums; undo portswitch on ethernet 0/0/0 allows an ip to be set on that interface but you can't do that on the other ethernet interfaces.

system-view
interface Ethernet 0/0/0
undo portswitch
ip address <ip> <bits>

I'll see if vlans can help.

Thanks

Mat

1
  • That could work. Taking the port out of switching mode should enable L3 configuration. – Zac67 Dec 17 '20 at 7:06
0

I don't think that router supports L3 or routed interfaces, so you can't bind an IP address to a physical interface directly. Likely, you'd want to bind the IP address to a VLAN:

system-view
vlan 1234
quit
interface vlanif 1234
ip address 192.168.2.1 24
quit

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.