2

I am learning CCNA related tasks, I have picked up a Cisco 1900 Series router. I am attempting to set it up behind my existing router (Comcast standard router).

My "Real" network is 10.0.0.0/24
My goal is to create a 192.168.1.0 network using this router.

I have manually assigned gigabitEthernet0/0 10.0.0.111 as the "WAN" side of the router.

Below is my startup configuration, the router can communicate with the 10.0.0.0/24 network and ping google or 8.8.8.8 just fine. However, a host connected to the LAN side of the router will pull a DHCP address but cannot ping outside the router.

!
! Last configuration change at 06:00:44 UTC Wed Jan 6 2021
!
version 15.8
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname archnet
!
boot-start-marker
boot-end-marker
!
!
! card type command needed for slot/vwic-slot 0/0
!
no aaa new-model
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!


!
!
ip dhcp pool LAN1
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
 dns-server 8.8.8.8
 lease 7
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
license udi pid CISCO1921/K9 sn FTX170683J5
license boot module c1900 technology-package securityk9
license boot module c1900 technology-package datak9
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address 10.0.0.111 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
ip route 0.0.0.0 0.0.0.0 10.0.0.1
!
ip access-list extended NAT
 permit ip any 10.0.0.0 0.0.0.255
!
ipv6 ioam timestamp
!
!
!
control-plane
!
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 login
 transport input none
!
scheduler allocate 20000 1000
!
end

From my basic and beginner understanding of Networks, this appears to be a NAT issue. But that is why I am here, I have attempted as you can see to setup NAT and it doesn't work.

I am clearly doing something incorrectly, please steer me in the right direction.

Thank you.

6

For NAT to work, you must specify a standard access list to identify the traffic that should be NATted. You reference the access list (source list 1) correctly, but you have not created the access list.

Correct NAT config would be:

ip nat inside source list 1 interface GigabitEthernet0/0 overload
access-list 1 permit 192.168.1.0 0.255.255.255

Your extended access list NAT cannot be used for this, since the ip nat inside command accepts a standard access list only.

1
  • 3
    Also, remove the unnecessary (and incorrect) ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 (that's proxy-arp)
    – Ricky
    Jan 6 at 10:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.