1

I'm messing with BGP/MPLS for the first time and I have some doubts both in if I'm doing something wrong with my configuration and if it is the best approach, hope you guys can clarify me a bit here.

So first of all what I'm trying to do is be able to ping from a customer A branch to another customer A branch in another part of the network. Now considering I'm still pretty bad at this and I feel like I did a frankenstein of commands to get it to work a bit from everywhere it's very possible something is misconfigured or what I'm doing isn't possible.

This is the network:

enter image description here

(Sorry for the lousy paint)

B_South Configuration:

!

!
! Last configuration change at 21:51:05 UTC Thu Jan 7 2021
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname B_South
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
ip vrf ARASAKA-1
 rd 1020:1
 route-target export 1020:1
 route-target import 1020:1
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
mpls traffic-eng tunnels
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
! 
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.10.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.10.2.3 255.255.255.0
 duplex full
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth 512 512
!
interface FastEthernet1/0
 ip address 10.10.4.1 255.255.255.252
 speed auto
 duplex auto
 mpls traffic-eng tunnels
!
interface FastEthernet1/1
 ip vrf forwarding ARASAKA-1
 ip address 10.10.4.5 255.255.255.252
 speed auto
 duplex auto
!
interface FastEthernet2/0
 ip address 200.100.4.1 255.255.255.0
 speed auto
 duplex auto
!
interface FastEthernet2/1
 no ip address
 shutdown
 speed auto
 duplex auto
!
router ospf 1
 network 10.10.2.0 0.0.0.255 area 0
 network 10.10.3.3 0.0.0.0 area 0
 network 200.100.4.0 0.0.0.255 area 0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
!
router bgp 1020
 bgp router-id 10.10.10.11
 bgp log-neighbor-changes
 neighbor 10.10.3.1 remote-as 1020
 neighbor 10.10.3.1 update-source Loopback0
 neighbor 10.10.3.1 next-hop-self
 neighbor 10.10.3.2 remote-as 1020
 neighbor 10.10.3.2 update-source Loopback0
 neighbor 10.10.3.2 next-hop-self
 neighbor 10.10.3.4 remote-as 1020
 neighbor 10.10.3.4 update-source Loopback0
 neighbor 10.10.3.4 next-hop-self
 !
 address-family vpnv4
  neighbor 10.10.3.4 activate
  neighbor 10.10.3.4 send-community both
 exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 193.136.1.0 255.255.255.192 10.10.4.6
ip route 193.136.1.64 255.255.255.192 10.10.4.6
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

Arasaka_S configuration:

!
!
!

!
! Last configuration change at 09:24:06 UTC Sun Jan 3 2021
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Arasaka_S
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
! 
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.10.4.6 255.255.255.252
 duplex full
!
interface FastEthernet1/0
 ip address 193.136.1.65 255.255.255.192
 speed auto
 duplex auto
!
interface FastEthernet1/1
 ip address 193.136.1.1 255.255.255.192
 speed auto
 duplex auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 speed auto
 duplex auto
!
interface FastEthernet2/1
 no ip address
 shutdown
 speed auto
 duplex auto
!
router ospf 1
 network 193.136.1.0 0.0.0.63 area 0
 network 193.136.1.64 0.0.0.63 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 10.10.4.5
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

Arasaka_N configuration:

!
!
!

!
! Last configuration change at 08:54:37 UTC Sun Jan 3 2021
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Arasaka_N
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
! 
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.10.4.10 255.255.255.252
 duplex full
!
interface FastEthernet1/0
 ip address 193.136.1.129 255.255.255.192
 speed auto
 duplex auto
!
interface FastEthernet1/1
 ip address 193.136.1.193 255.255.255.192
 speed auto
 duplex auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 speed auto
 duplex auto
!
interface FastEthernet2/1
 no ip address
 shutdown
 speed auto
 duplex auto
!
router ospf 1
 network 193.136.1.128 0.0.0.63 area 0
 network 193.136.1.192 0.0.0.63 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 10.10.4.9
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

B_North configuration:

!

!
! Last configuration change at 21:57:40 UTC Thu Jan 7 2021
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname B_North
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
ip vrf ARASAKA-1
 rd 1020:1
 route-target export 1020:1
 route-target import 1020:1
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
mpls traffic-eng tunnels
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
! 
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.10.3.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.10.2.4 255.255.255.0
 duplex full
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth 512 512
!
interface FastEthernet1/0
 ip vrf forwarding ARASAKA-1
 ip address 10.10.4.9 255.255.255.252
 speed auto
 duplex auto
!
interface FastEthernet1/1
 ip address 200.100.2.1 255.255.255.0
 speed auto
 duplex auto
!
interface FastEthernet2/0
 ip address 10.20.1.1 255.255.255.0
 speed auto
 duplex auto
!
interface FastEthernet2/1
 no ip address
 shutdown
 speed auto
 duplex auto
!
router ospf 1
 network 10.10.2.0 0.0.0.255 area 0
 network 10.10.3.4 0.0.0.0 area 0
 network 200.100.2.0 0.0.0.255 area 0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
!
router bgp 1020
 bgp router-id 10.10.10.10
 bgp log-neighbor-changes
 neighbor 10.10.3.1 remote-as 1020
 neighbor 10.10.3.1 update-source Loopback0
 neighbor 10.10.3.1 next-hop-self
 neighbor 10.10.3.2 remote-as 1020
 neighbor 10.10.3.2 update-source Loopback0
 neighbor 10.10.3.2 next-hop-self
 neighbor 10.10.3.3 remote-as 1020
 neighbor 10.10.3.3 update-source Loopback0
 neighbor 10.10.3.3 next-hop-self
 !
 address-family vpnv4
  neighbor 10.10.3.3 activate
  neighbor 10.10.3.3 send-community both
 exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 193.136.1.128 255.255.255.192 10.10.4.10
ip route 193.136.1.192 255.255.255.192 10.10.4.10
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

So my questions are:

1-> Why can't router B_south "ping vrf" the B_North vrf interface (f1/0)?

2-> I have added both mpls LDP and mpls RSVP-TE, do I need to use one over the other?

3-> Is having BGP on B_South and B_North a good choice considering BGP as far as I know is more used in between things like ISP's and not in the same ASs or should I use ospf without VRF to get connectivity between the two?

If I did something horrible wrong here let me know haha.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.