1

I am attempting to 'extend' a 192.168.1.0\24 network with an experimental network 192.168.10.0\24 using a 1941W router.

I have configured 1941W to distribute a 192.168.10.0\24 network, with WLAN access via the integrated wlan-ap 0 and using

This works fine initially however after a few minutes, clients dissociate from the AP - then reconnect. When this happens, they seem to be unable to 'regain' their lease (Wireshark shows continual DCHP Discover packets with no reply), and the IP - however the lease is still shown in the DHCP bindings. Renewing the DHCP lease at the client end has no effect. The intermittent nature of this implies its something to do with the wireless but I'm not really sure.

The only way I've found to fix this is to reload the AP, but as yet haven't found a change that makes a meaningful difference. Any guidance or help would be much appreciated!

This is shown in the dot11 association enter image description here and DHCP bindings below: enter image description here

Where we can see that the 9801.a7ad.ea73 client both has a lease and association...but no IP address.

Please find my configs for the 1941W and wlan-ap0 below

Configs

1941W Router

Current configuration : 2615 bytes
!
! Last configuration change at 13:09:53 UTC Sun Jan 17 2021 by cisco
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Xbow
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 xxxxxxxxxxx
enable password 7 xxxxxxxxxxx
!
no aaa new-model
service-module wlan-ap 0 bootimage autonomous
!
no ipv6 cef
!
ip dhcp excluded-address 192.168.10.1 192.168.10.10
!
ip dhcp pool VLAN10-WIFI
 network 192.168.10.0 255.255.255.0
 default-router 192.168.1.1 
 dns-server 8.8.8.8 
!         
!
no ip domain lookup
ip domain name xbow.local
ip cef    
multilink bundle-name authenticated
!         
crypto pki token default removal timeout 0
!         
!
license udi pid CISCO1941W-E/K9 sn FCZ1407C0MH
hw-module ism 0
!                 
username cisco password 7 xxxxxxxxxxxxx     
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown 
!
interface GigabitEthernet0/0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!         
interface wlan-ap0
 description Service module interface to manage the embedded AP
 ip address 11.11.11.11 255.255.255.255
 arp timeout 0
 no mop enabled
 no mop sysid
!
interface GigabitEthernet0/1
 ip address dhcp
 duplex auto
 speed auto
!         
interface Wlan-GigabitEthernet0/0
 description Internal switch interface connecting to the embedded AP
 switchport mode trunk
 no ip address
!
interface ATM0/0/0
 no ip address
 shutdown 
 no atm ilmi-keepalive
!         
interface Vlan1
 ip address 192.168.11.1 255.255.255.0
!
interface Vlan10
 ip address 192.168.10.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!         
ip forward-protocol nd
!         
ip http server
ip http secure-server
!
ip nat inside source list 1 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 192.168.1.1 254
ip route 0.0.0.0 0.0.0.0 192.168.1.1 254
!
access-list 1 permit any
!
control-plane
!         
banner motd ^C
          
**************************
EXPERIMENTAL ROUTER
**************************
^C        
!
line con 0
 exec-timeout 30 0
 password 7 060506324F41
 logging synchronous
 login local
line aux 0
line 2    
 no activation-character
 no exec  
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line 67
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
 exec-timeout 30 0
 privilege level 15
 password 7 xxxxxxxxxx
 logging synchronous
 login local
 transport input ssh
!         
scheduler allocate 20000 1000
end

And here is my WLAN AP config

WLAN-AP 0*

Current configuration : 2001 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ap
!
enable secret 5 xxxxxxxx
!
no aaa new-model
!
!
dot11 syslog
!
dot11 ssid XBOW-WIFI
   authentication open 
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 7 xxxxxxxxxx
!               
username Cisco password 7 xxxxxxxxxx
!         
!         
bridge irb
!              
interface Dot11Radio0
 description 2.4GHz radio
 no ip address
 no ip route-cache
 !        
 encryption mode ciphers aes-ccm 
 !        
 ssid XBOW-WIFI
 !        
 antenna gain 0
 station-role root
 bridge-group 10
 bridge-group 10 subscriber-loop-control
 bridge-group 10 block-unknown-source
 no bridge-group 10 source-learning
 no bridge-group 10 unicast-flooding
 bridge-group 10 spanning-disabled
!         
interface Dot11Radio1
 description 5GHz radio
 no ip address
 no ip route-cache
 !        
 encryption mode ciphers aes-ccm 
 !        
 ssid XBOW-WIFI
 !        
 antenna gain 0
 no dfs band block
 channel dfs
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!         
interface GigabitEthernet0
 description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router
 no ip address
 no ip route-cache
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
!         
interface GigabitEthernet0.10
 encapsulation dot1Q 10
 no ip route-cache
 bridge-group 10
 no bridge-group 10 source-learning
 bridge-group 10 spanning-disabled
!         
interface BVI1
 ip address 192.168.11.253 255.255.255.0
 no ip route-cache
!         
ip default-gateway 192.168.10.0
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!                  
line con 0
 no activation-character
line vty 0 4
 logging synchronous
 login local
!         
end 
3
  • Unfortunately, questions about home networking are explicitly off-topic here. You could try to ask this question on Super User – Ron Maupin Jan 17 at 14:31
  • @RonMaupin Could you explain why the location of the network makes this any less relevant? It appears you read the word 'home' and instantly made a decision? Super User is not normally the correct forum for CCNA style problems, as shown by the fact that all 5 tags to this question are valid areas for discussion here? – davidhood2 Jan 17 at 15:05
  • 2
    As the box above explains, if your disagree with the closure, you take your disagreement to Network Engineering Meta. Both the tour and the What topics can I ask about here? page explain that home networking is explicitly off-topic here. This was a community decision because Super User handles home networking, and the professional network engineers here decided to split so that they do not deal with home networking. In fact, home/residential ISP connections are often very different than business ISP connections. – Ron Maupin Jan 17 at 15:09