2

Before deep into the question, please see this topology and the results of sending messages from one router to the other router: topology and the results of sending messages I have succeeded in sending a message from R0 to R2 (or vice versa), R1 to R3 (or vice versa). But why I can't send a message from R0 to R3 (or vice versa)? I've already set all redistribute static and redistribute connected in RIP and BGP routers (R1 and R2)

What should I do?

NOTE

Router0 configuration:

R0>enable
R0#configure terminal
R0(config)#interface Serial2/0
R0(config-if)#ip address 2.0.0.2 255.255.255.252
R0(config-if)#no shutdown
R0(config-if)#exit
R0(config)#interface Serial2/0
R0(config-if)#exit
R0(config)#ip route 1.0.0.0 255.255.255.252 2.0.0.1
R0(config)#ip route 3.0.0.0 255.255.255.252 2.0.0.1
R0(config-if)#exit
R0(config)#

Router1 configuration:

R1>enable
R1#configure terminal
R1(config)#interface Serial2/0
R1(config-if)#ip address 1.0.0.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface Serial3/0
R1(config-if)#ip address 2.0.0.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router bgp 100
R1(config-router)#neighbor 1.0.0.2 remote-as 200
R1(config-router)#network 1.0.0.0
R1(config-router)#redistribute static
R1(config-router)#redistribute connected
R1(config-router)#exit
R1(config)#

Router2 configuration:

R2>enable
R2#configure terminal
R2(config)#interface Serial2/0
R2(config-if)#ip address 1.0.0.2 255.255.255.252
R2(config-if)#exit
R2(config)#interface Serial3/0
R2(config-if)#ip address 3.0.0.1 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#network 3.0.0.0
R2(config-router)#redistribute static
R2(config-router)#redistribute connected
R2(config-router)#exit
R2(config)#router bgp 200
R2(config-router)#neighbor 1.0.0.1 remote-as 100
R2(config-router)#network 1.0.0.0
R2(config-router)#redistribute static
R2(config-router)#redistribute connected
R2(config-router)#exit
R2(config)#

Router3 configuration:

R3>enable
R3#
R3#configure terminal
R3(config)#interface Serial2/0
R3(config-if)#ip address 3.0.0.2 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#router rip
R3(config-router)#network 3.0.0.0
R3(config-router)#redistribute static
R3(config-router)#redistribute connected
R3(config-router)#exit
R3(config)#
0
1

You seem to be missing one redistribution, which is on R2 where you redistribute BGP to RIP and vice versa. R3 does not know how to reach R0. Routing protocols do not automatically share routes with each other.

You should use the show ip route command on each router to see the networks that each router knows how to reach.

5
  • Well. When I type 'redistribute rip' in R2 (after enter to 'router bgp 200'), it seems it is an invalid command. When i use 'show ip route' in R3, there is no network 2.0.0.0 – StudentWhoCurious Jan 19 at 5:06
  • You need to redistribute RIP under the router BGP configuration, and you need to redistribute BGP under the router RIP configuration. – Ron Maupin Jan 19 at 5:07
  • Do you know command for redistribute RIP? I only found that I can use 'redistribute static' and 'redistribute connected' for redistribute RIP under router BGP and vice versa (which i've done in the above configuration). – StudentWhoCurious Jan 19 at 5:11
  • If you are using Packet Tracer, you need to remember that not all commands are available because it is limited to getting you through the CCNA exams. On a real router, you can redistribute. – Ron Maupin Jan 19 at 5:17
  • But, why I can send message between RIP and BGP in that topology? It means that RIP already redistributed to BGP and vice versa, right? – StudentWhoCurious Jan 19 at 5:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.