1

I have a test scenario and trying to pass multicast traffic through Cisco 3850 according to the following diagram:enter image description here ![enter image description here MC source: several MC IPs such as 232.0.26.0, 232.0.27.1, 232.0.16.0 etc I have tried for example: ip igmp snooping vlan 701 mrouter interface Te1/0/13 with no success. Do you have any advice? Could 3850 just "passthough" all multicast traffic with dot1.q tunnel in interfaces that are connected to MC source?

Here is 3850 configuration:

Current configuration : 7562 bytes
version 15.2
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service compress-config
no service dhcp
!
hostname CFT_10G_Switch
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-vrf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
no logging console
!
username xipo privilege 15 secret 5 $1$v/GL$MNYh4S8CaxnJKlmxj9EtZ.
no aaa new-model
switch 1 provision ws-c3850-24xs
!
!
!
coap http enable
!
!
!
!
ip multicast-routing
no ip domain-lookup
ip domain-name promi-athlabs.net
!
!
login block-for 180 attempts 4 within 60
login delay 2
login on-failure log
login on-success log
qos queue-softmax-multiplier 100
vtp mode transparent
!
!
diagnostic bootup level minimal
archive
 path tftp://10.80.153.53/$h
 write-memory
spanning-tree mode rapid-pvst
spanning-tree extend system-id
hw-switch switch 1 logging onboard message level 3
!
redundancy
 mode sso
!
!
vlan 701-705,801-812,901-903
!
!
class-map match-any non-client-nrt-class
!
policy-map port_child_policy
 class non-client-nrt-class
  bandwidth remaining ratio 10
!
!
template 1/0/14
!
template 1/0/23
!
!
interface GigabitEthernet0/0
 description MGMT Port
 vrf forwarding Mgmt-vrf
 ip address 10.85.220.3 255.255.255.128
 negotiation auto
!
!
interface TenGigabitEthernet1/0/13
 switchport access vlan 701
 switchport mode dot1q-tunnel
 no cdp enable
!
interface TenGigabitEthernet1/0/14
 switchport access vlan 702
 switchport mode dot1q-tunnel
 no cdp enable
!
interface TenGigabitEthernet1/0/15
 switchport access vlan 703
 switchport mode dot1q-tunnel
 no cdp enable
!
interface TenGigabitEthernet1/0/16
 switchport access vlan 704
 switchport mode dot1q-tunnel
 no cdp enable
!
interface TenGigabitEthernet1/0/17
 switchport access vlan 705
 switchport mode dot1q-tunnel
 no cdp enable
!
interface TenGigabitEthernet1/0/18
 switchport access vlan 901
 switchport mode dot1q-tunnel
 no cdp enable
!
interface TenGigabitEthernet1/0/19
 switchport access vlan 902
 switchport mode dot1q-tunnel
 no cdp enable
!
interface TenGigabitEthernet1/0/20
 switchport access vlan 903
 switchport mode dot1q-tunnel
 no cdp enable
!
interface TenGigabitEthernet1/0/21
 switchport mode trunk
 switchport nonegotiate
!
interface TenGigabitEthernet1/0/22
 switchport mode trunk
 switchport nonegotiate
!
interface TenGigabitEthernet1/0/23
 switchport trunk allowed vlan 703-705,902
 switchport mode trunk
!
interface TenGigabitEthernet1/0/24
 switchport trunk allowed vlan 701,702,901,903
 switchport mode trunk
!
interface TenGigabitEthernet1/1/1
!
interface TenGigabitEthernet1/1/2
!
interface TenGigabitEthernet1/1/3
!
interface TenGigabitEthernet1/1/4
!
interface TenGigabitEthernet1/1/5
!
interface TenGigabitEthernet1/1/6
!
interface TenGigabitEthernet1/1/7
!
interface TenGigabitEthernet1/1/8
!
interface FortyGigabitEthernet1/1/1
!
interface FortyGigabitEthernet1/1/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan701
 no ip address
!
interface Vlan702
 ip address 1.1.1.1 255.255.255.0
 ip pim sparse-dense-mode
!
interface Vlan801
 no ip address
!
interface Vlan802
 no ip address
!
ip forward-protocol nd
no ip http server
ip http authentication local
no ip http secure-server
ip route vrf Mgmt-vrf 10.0.0.0 255.0.0.0 10.85.220.1
ip ssh version 2
!
!
logging trap notifications
logging host 10.85.55.60
access-list 99 permit 10.85.55.55
!
snmp-server community labs.community RO 99
!
!
line con 0
 exec-timeout 20 0
 logging synchronous
 login local
 transport output ssh
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 exec-timeout 20 0
 login local
 transport input ssh
 transport output ssh
line vty 5 15
 login local
 transport input ssh
 transport output ssh
!
!
monitor session 1 source interface Te1/0/17
monitor session 1 destination interface Te1/0/1
wsma agent exec
 profile httplistener
 profile httpslistener
!
wsma agent config
 profile httplistener
 profile httpslistener
!
wsma agent filesys
 profile httplistener
 profile httpslistener
!
wsma agent notify
 profile httplistener
 profile httpslistener
!
!
wsma profile listener httplistener
 transport http
!
wsma profile listener httpslistener
 transport https
!
ap group default-group
end

Thank you, Gianna

7
  • Please edit your question to include the configuration. Because the multicast traffic needs to cross VLANs, you need to set up multicast routing, which is very different than unicast routing.
    – Ron Maupin
    Jan 19 at 14:51
  • Yes, that is what is not clear, how to receive MC traffic on ports 13, 14, 15 and pass it through 23 & 24, as in my setup I need qinq for other unicast traffic received on ports 13,14,15.
    – Gianna
    Jan 19 at 14:58
  • You need to run PIM and IGMP for routing unicast. IGMP is used by the hosts to inform the multicast router that it is interested in the multicast group. IGMP snooping just allows a switch to listen in on the IGMP conversation to be able to not send multicast traffic to ports not interested, but you also need to route the multicast.
    – Ron Maupin
    Jan 19 at 15:01
  • 2
    In any case, we need to see the full switch configuration to really help. Please edit the question to include that.
    – Ron Maupin
    Jan 19 at 15:02
  • Please also include a sketch or drawing that shows the intended L3/Multicast setup. In which VLANs will the sources be? In which VLAN will the consumers of the multicast be? Which L3-forwarding instance is supposed to route mutlicast between which subnets/VLANs (if at all?). This does not become entirely clear from your description nor from the configuration. Jan 20 at 9:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.