I come more from a cisco back ground and there when i show the running configuration i can see the encrypted / hased local user password.

This makes it more secure to have in a automation tool where I dont have to store it in plain text.

With the aruba switchs i have it used the "password manager admin ...." comand to set a password but i cant see how to enter the password in its hased / encrypted form like i can in CISCO.

IE when you set up the user on cisco you can chose to enter a plain text, or type 5, 7 9 encrypted / hashed passsword string.

I actuly run TACACS for normal admin access this is jsut for the local admin last resorce access.

Can any one tell me if there is a simular feature on Aruba to what i am use to on CISCO.

Thank you

  • Did any answer help you? if so, you should accept the answer so that the question does not keep popping up forever, looking for an answer. Alternatively, you could post and accept your own answer.
    – Ron Maupin
    Dec 23, 2021 at 16:42

1 Answer 1


You can SHA1 encrypt the local password, e.g.

password manager admin sha1 <hash>

I have extensively used RSA authentication for SSH and SFTP access - imho the best option since there's no shared password. This is initially set up with

aaa authentication ssh enable public-key

You upload the public key ring to /ssh/mgr_keys and can check if the keys are working properly using

show crypto client-public-key
  • I dont get the option to chose sha1, password manager admin ? just give me choise of plaintrext
    – DevilWAH
    Feb 25, 2021 at 13:13
  • What's the device type? There are (more or less) subtle differences across series and releases...
    – Zac67
    Feb 25, 2021 at 13:14
  • its mutiply models and ages of firmware. About 5,000 of them :) my issue with aruba / hp all different
    – DevilWAH
    Feb 25, 2021 at 13:15
  • Well, RSA pubkey authentication worked on all I've tried - 2610, 2510, 2910al, 2530.
    – Zac67
    Feb 25, 2021 at 13:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.