0

This is my test topology:

R6---R7

the interface IP address I have configured on it, you can check in the snapshot. and in both routers I have configured the static route, in R6 10.0.0.22/32 out interface R6 GE-0/0/0, in R7 10.0.0.11/32 out interface R7 GE-0/0/0.

enter image description here

I think this will be communicative in both Routers' lo0. but however the result is, cannot reach each other. why?


EDIT-01

In R6:

interface LoopBack0
 ip address 10.0.0.11 255.255.255.0
#
ip route-static 10.0.0.22 255.255.255.255 GigabitEthernet0/0/0

interface GigabitEthernet0/0/0
 ip address 100.0.0.1 255.255.255.0
[R6]dis ip routing-table 
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
         Destinations : 7        Routes : 7        

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

       10.0.0.0/24  Direct  0    0           D   10.0.0.11       LoopBack0
      10.0.0.11/32  Direct  0    0           D   127.0.0.1       LoopBack0
      10.0.0.22/32  Static  60   0           D   100.0.0.1       GigabitEthernet
0/0/0
      100.0.0.0/24  Direct  0    0           D   100.0.0.1       GigabitEthernet
0/0/0
      100.0.0.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
0/0/0
      127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
      127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0

In R7:

interface LoopBack0
 ip address 10.0.0.22 255.255.255.0
#
ip route-static 10.0.0.11 255.255.255.255 GigabitEthernet0/0/0

interface GigabitEthernet0/0/0
 ip address 100.0.0.2 255.255.255.0
<R7>dis ip routing-table 
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
         Destinations : 7        Routes : 7        

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

       10.0.0.0/24  Direct  0    0           D   10.0.0.22       LoopBack0
      10.0.0.11/32  Static  60   0           D   100.0.0.2       GigabitEthernet
0/0/0
      10.0.0.22/32  Direct  0    0           D   127.0.0.1       LoopBack0
      100.0.0.0/24  Direct  0    0           D   100.0.0.2       GigabitEthernet
0/0/0
      100.0.0.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
0/0/0
      127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
      127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
2
  • 2
    Your diagram does not match your display. Please edit your question to REMOVE the images. Instead, post your router configurations and route tables using the preformatted text option { }.
    – Ron Trunk
    Mar 17, 2021 at 16:08
  • I have updated my post, please tell me where I did wrong.
    – 244boy
    Mar 17, 2021 at 16:19

2 Answers 2

0

As Ron has already answered, the problem is, that you had the router's own address as gateway to the loopback address of the peer. That way the router would use ARP on the Gigabit interface to ask for the correct MAC address. This doesn't work, unless the peer does proxy ARP for its loopback address.

When you use the peers IP address in the ethernet as next-hop for its loopback address, the router can find the correct gateway to the peers loopback address without proxy ARP.

0

It appears that you have the next-hop addresses reversed

6
  • I set the next-hop to the router's out interface, but why it reversed?
    – 244boy
    Mar 17, 2021 at 16:24
  • I'm not sure, but a better practice is to use the destination IP of the next hop.
    – Ron Trunk
    Mar 17, 2021 at 16:28
  • Also, both your loopback interfaces are in the same subnet. That is an invalid configuration.
    – Ron Trunk
    Mar 17, 2021 at 16:29
  • but I use the static route and /32, it's more priority.
    – 244boy
    Mar 17, 2021 at 16:33
  • thanks, use next-hop IP address, it works.
    – 244boy
    Mar 17, 2021 at 16:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.