0

Text

I am currently working with the network above. When ever I send a packet across from a network, on the return to the router it is unable to translate back and ends up dropping the packet. I am how ever able to get return packets from the static 1-1 translation.

Router1

Current configuration : 1478 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.0.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 10
 ip address 192.168.10.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
!
interface FastEthernet0/0.2
 encapsulation dot1Q 20
 ip address 192.168.20.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
!
interface FastEthernet0/0.3
 encapsulation dot1Q 30
 ip address 192.168.30.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 129.137.107.130 255.255.255.128
 ip nat outside
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
router eigrp 1
 network 129.137.107.128 0.0.0.127
 network 192.168.0.0
 network 192.168.10.0
 network 192.168.20.0
 network 192.168.30.0
 auto-summary
!
ip nat inside source list 10 interface Serial2/0 overload
ip classless
!
ip flow-export version 9
!
!
access-list 10 permit 192.168.0.0 0.0.255.255
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Router0

Current configuration : 2231 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 2
 ip address 192.168.2.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
!
interface FastEthernet0/0.2
 no ip address
 shutdown
!
interface FastEthernet0/0.3
 encapsulation dot1Q 20
 ip address 192.168.20.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
!
interface FastEthernet0/0.5
 encapsulation dot1Q 40
 ip address 192.168.40.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
!
interface FastEthernet0/0.6
 encapsulation dot1Q 50
 ip address 192.168.50.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
!
interface FastEthernet0/0.7
 encapsulation dot1Q 60
 ip address 192.168.60.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
!
interface FastEthernet0/0.8
 encapsulation dot1Q 70
 ip address 192.168.70.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
!
interface FastEthernet1/0
 ip address 192.168.80.1 255.255.255.0
 ip helper-address 192.168.80.2
 ip nat inside
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 129.137.107.129 255.255.255.128
 ip nat outside
 clock rate 2000000
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
router eigrp 1
 network 129.137.107.128 0.0.0.127
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.10.0
 network 192.168.20.0
 network 192.168.30.0
 network 192.168.40.0
 network 192.168.50.0
 network 192.168.60.0
 network 192.168.70.0
 network 192.168.80.0
 auto-summary
!
ip nat inside source list 10 interface Serial2/0 overload
ip nat inside source static tcp 192.168.80.3 80 129.137.107.131 80 
ip classless
!
ip flow-export version 9
!
!
access-list 10 permit 192.168.0.0 0.0.255.255
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end
1

The network looks private. You need not do NAT inside private networks, e.g. over serial link. You may simply route across.

If you insist on NAT over serial link, it should be done on the router on the right. The router on the left should not route over serial (no ip nat inside). It may do NAT over upstream link (top left) only if necessary.

Unless there is good reason for such a topology, your whole design needs a major revision.

0

Setting up dynamic NAT on Router1 was unnecessary.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.